Author Topic: [1.7] PHP5 compatible  (Read 54483 times)

0 Members and 1 Guest are viewing this topic.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[1.7] PHP5 compatible
« on: March 12, 2005, 01:08:22 AM »
In PHP v5.x some default settings are turned off, which makes 4images not compatible with it.

Here are few changes u should make in order to make it to work with PHP5

1) Open global.php
Find:
Code: [Select]
if (get_magic_quotes_gpc() == 0) {Insert above:
Code: [Select]
/*
  FIX PHP5
  START INSERT
*/
if (!isset($HTTP_GET_VARS)) {
  $HTTP_GET_VARS    = &$_GET;
  $HTTP_POST_VARS   = &$_POST;
  $HTTP_COOKIE_VARS = &$_COOKIE;
  $HTTP_POST_FILES  = &$_FILES;
}
/*
  FIX PHP5
  END INSERT
*/


2) Open includes/upload.php
Find two (2) times:
Code: [Select]
  var $upload_errors = array();Remove one (1) of them (doesnt metter which one)



P.S. If I or someone else remmember anything else it will be added to this topic ;)
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline michi-w.

  • Hero Member
  • *****
  • Posts: 505
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #1 on: September 27, 2005, 04:15:37 PM »
In PHP v5.x some default settings are turned off, which makes 4images not compatible with it.

2) Open includes/upload.php
Find two (2) times:
Code: [Select]
  var $upload_errors = array();Remove one (1) of them (doesnt metter which one)

I do not understand that, that is my upload.php:

Code: [Select]
  var $upload_errors = array();
  var $accepted_mime_types = array();
  var $accepted_extensions = array();
  var $upload_mode = 3;

  var $image_type = "";
  var $max_width = array();
  var $max_height = array();
  var $max_size = array();
  var $upload_path = array();

  var $field_name;
  var $file_name;
  var $extension;

  var $image_size = 0;
  var $image_size_ok = 0;
  var $lang = array();
  var $upload_errors = array();

  function Upload() {
    global $config, $lang;

    $this->max_width['thumb'] = $config['max_thumb_width'];
    $this->max_width['media'] = $config['max_image_width'];
    $this->max_height['thumb'] = $config['max_thumb_height'];
    $this->max_height['media'] = $config['max_image_height'];

    $this->max_size['thumb'] = $config['max_thumb_size'] * 1024;
    $this->max_size['media'] = $config['max_media_size'] * 1024;

    $this->upload_mode = $config['upload_mode'];
    $this->lang = $lang;

    $this->set_allowed_filetypes();
  }

Help, please!

Gruß
michi-w.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [1.7] PHP5 compatible
« Reply #2 on: September 27, 2005, 11:49:52 PM »
I'm not quet sure what is it you dont understand...find:
Code: [Select]
var $upload_errors = array();there are two lines like this. Remove ONE of them, doesn't metter wich one you chose to delete.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline michi-w.

  • Hero Member
  • *****
  • Posts: 505
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #3 on: September 28, 2005, 12:03:32 PM »
Thanks!
 

Offline markuskohler

  • Pre-Newbie
  • Posts: 1
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #4 on: October 07, 2005, 07:19:08 PM »
Hallo
Ich habe alles installiert und die entsprechenden .php gelöscht. Wenn ich aber jetzt meine Anpassungen machen möchte, erscheint im Browser die Datei install.php.
Was muss ich machen, dass ich meine Einstellungen nun anpassen kann.

Vielen Dank für die Hilfe

Markus

Offline michi-w.

  • Hero Member
  • *****
  • Posts: 505
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #5 on: October 07, 2005, 10:33:40 PM »
Falls die Datenbank bereits installiert wurde, muss die install.php natürlich gelöscht werden.
Quote
Löschen Sie die Datei "install.php" und alle "update_*_to_*.php" von Ihrem Server.
     Zusätzlich können Sie die Dateien im Ordner "data/database/default" und den
     Ordner "docs" löschen.

Gruß
michi-w.

Offline Sopur

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • Bilder des Harassenlaufs in Basel
Re: [1.7] PHP5 compatible
« Reply #6 on: November 22, 2006, 11:50:50 AM »
Hallo!
Ich habe die Änderung gemacht - leider ohne Erfolg.
Hier die Homepage: http://www.harassenlauf.ch
Oder liegt das an was anderem?

M
F
G
Sopur
« Last Edit: November 22, 2006, 05:34:16 PM by Sopur »

Offline pda

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #7 on: November 22, 2006, 01:39:33 PM »
Du musst alle FROM statements welche anschliessen mit einem LEFT JOIN verbunden werden mit runden Klammern umrunden. Das duerfte dann deine Seite kompatibel zu php5 machen  :wink: Hoert sich jetzt nach viel Arbeit an, ist es aber mit den enstprechenden Programmen gar nicht. Probiers mal diesem Programm (Find.exe). Gebe den Suchbegriff LEFT JOIN ein und waehle den zu durchsuchenden Ordner (4images). Danach oeffnest du jede Seite aus den Suchergebnissen welche das besagte LEFT JOIN enthalten, und fuegst die Klammern um den FROM Befehl.

Find.exe
http://www.uploading.com/de/files/OJHI91GH/Find.exe.html


Hier ein Beispiel, wie du danach im Code vorgehen musst :
Code: [Select]
  $sql = "SELECT i.image_id, i.cat_id, i.user_id, i.image_name, i.image_description, i.image_keywords
          FROM ".IMAGES_TABLE." i,  ".CATEGORIES_TABLE." c
          LEFT JOIN ".USERS_TABLE." u ON (".get_user_table_field("u.", "user_id")." = i.user_id)

Fuege die runden Klammern nur um den FROM Befehl hinzu (Musst auch keine Abstaende wie hier im Beispiel verwenden):
Code: [Select]
  $sql = "SELECT i.image_id, i.cat_id, i.user_id, i.image_name, i.image_description, i.image_keywords
          FROM    (    ".IMAGES_TABLE." i,  ".CATEGORIES_TABLE." c    )   
          LEFT JOIN ".USERS_TABLE." u ON (".get_user_table_field("u.", "user_id")." = i.user_id)

Das wars...glaube ich jedenfalls. Ich meinte das dies jedoch nur fuer den Support mit Mysql5 noetig ist.. versuchs mal...


Offline Sopur

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • Bilder des Harassenlaufs in Basel
Re: [1.7] PHP5 compatible
« Reply #8 on: November 22, 2006, 04:07:24 PM »
@pda: VIELEN DANK!!!!

Hat tiptop geklappt!!!

M
F
G
Sopur

Offline bibabobu

  • Sr. Member
  • ****
  • Posts: 311
  • Technische und künstlerische Gravuren
    • View Profile
    • Technische und künstlerische Gravuren für die gesamte Metall-, Kunststoff- und Papierindustrie
Re: [1.7] PHP5 compatible
« Reply #9 on: February 06, 2007, 09:12:32 PM »
Hello!

My website is not working anymore after a PHP update from version 5.1 to 5.2 :!:

IS 4images not compatible with the newest PHP Version 5.2 :?:

What can i do to fix it???

Offline SkyRanger

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #10 on: August 07, 2007, 10:41:57 AM »
I have same problem with php5 i make patching but if i use russian in image name or description, or i try use russian in comment header and it body i hab\ve no errors, it just load again same page without any changes :(

So it no effect :(

If i use latin chars - all fine...

Offline SkyRanger

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #11 on: August 07, 2007, 11:13:17 AM »
if i comment string

$val = preg_replace($search, $replace, $val);

string in global.php, function clean_array() all works fine!
« Last Edit: August 07, 2007, 11:31:23 AM by SkyRanger »

Offline bart_the1st

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #12 on: September 23, 2007, 10:12:49 PM »
Du musst alle FROM statements welche anschliessen mit einem LEFT JOIN verbunden werden mit runden Klammern umrunden. Das duerfte dann deine Seite kompatibel zu php5 machen  :wink: Hoert sich jetzt nach viel Arbeit an, ist es aber mit den enstprechenden Programmen gar nicht. Probiers mal diesem Programm (Find.exe). Gebe den Suchbegriff LEFT JOIN ein und waehle den zu durchsuchenden Ordner (4images). Danach oeffnest du jede Seite aus den Suchergebnissen welche das besagte LEFT JOIN enthalten, und fuegst die Klammern um den FROM Befehl.

Find.exe
http://www.uploading.com/de/files/OJHI91GH/Find.exe.html


Hier ein Beispiel, wie du danach im Code vorgehen musst :
Code: [Select]
  $sql = "SELECT i.image_id, i.cat_id, i.user_id, i.image_name, i.image_description, i.image_keywords
          FROM ".IMAGES_TABLE." i,  ".CATEGORIES_TABLE." c
          LEFT JOIN ".USERS_TABLE." u ON (".get_user_table_field("u.", "user_id")." = i.user_id)

Fuege die runden Klammern nur um den FROM Befehl hinzu (Musst auch keine Abstaende wie hier im Beispiel verwenden):
Code: [Select]
  $sql = "SELECT i.image_id, i.cat_id, i.user_id, i.image_name, i.image_description, i.image_keywords
          FROM    (    ".IMAGES_TABLE." i,  ".CATEGORIES_TABLE." c    )   
          LEFT JOIN ".USERS_TABLE." u ON (".get_user_table_field("u.", "user_id")." = i.user_id)

Das wars...glaube ich jedenfalls. Ich meinte das dies jedoch nur fuer den Support mit Mysql5 noetig ist.. versuchs mal...



Hat irgendjemand dieses Programm noch? der link geht leider nicht mehr
häf a naiß däi - bart_the1st :D

Offline matobi

  • Pre-Newbie
  • Posts: 4
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #13 on: June 11, 2008, 03:14:29 PM »
Hallo,
muss ich diese Änderungen auch bei der Version 1.7.6 vornehmen?

Grüße, matobi

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.863
    • View Profile
Re: [1.7] PHP5 compatible
« Reply #14 on: June 11, 2008, 03:16:44 PM »
Hallo,

nein musst Du nicht. 1.7.6 ist fit für PHP5.

nobby

 

Post your comments here