Author Topic: Bräuchte Hilfe  (Read 656 times)

0 Members and 1 Guest are viewing this topic.

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Bräuchte Hilfe
« on: January 31, 2019, 04:42:47 PM »
Liebe 4images-Gurus,
vor 10 Jahren habe ich mühevoll, unter teilweiser Hilfe einiger Spezialisten dieses Forums, meine HP:  www.digital-photogalerie.de erstellt.
Ein Hackerangriff in 2014 veranlasste mich erneut dieses Forum um Hilfe zu bitte- 2 Herren waren bereit mir zu helfen und habe meine HP wieder in Form und ins Netzt gebracht- leider stehen die Herren nicht mehr zur Verfügung.
Ich bin nunmehr 70 Jahre und hänge an dieser HP- ist sie doch für mich eine Art *Lebensaufgabe* geworden die mich trotz Krankheit und Behinderung zum Fotografieren aufs Rad steigen lässt um die Seiten der HP mit Leben zu füllen.

Nunmehr ist es so, dass ich von 1&1 IONUS.de die Mitteilung bekommen habe eine alte PHP Version= PHP 5,6 zu nutzen für die es keinen Support mehr gibt und ich solle auf Version PHP 7.2 upgraden.
Dies habe ich versucht mit dem Ergebnis dass mir meine HP nicht mehr angezeigt wird.... deshalb bin ich gezwungen die 4images- Version 1.8 zu installieren.
Ein erster Versuch schlug fehl mit dem Ergebnis dass ich einen ganzen Tag benötigte um auf die HP über 9 000 Bildern *hochzuladen* damit ich sie wieder Online sehen konnte!- einen zweiten Versuch wage ich deshalb nicht mehr.

Wer ist bereit mir diesbezüglich zu helfen- trotz kleiner Rente würde ich diese Mühe natürlich auch bezahlen.
Die Höhe müsste man vorab abklären.

LG
Ernst





Offline Tino23

  • Full Member
  • ***
  • Posts: 190
    • View Profile
    • LMJ - Motorsport
Re: Bräuchte Hilfe
« Reply #1 on: January 31, 2019, 07:21:21 PM »
Versuche es doch erst mal mit deiner "alten" 4images Version und erstelle dir wie hier beschriebe eine .htaccess-Datei mit folgendem Inhalt

Code: [Select]
AddHandler x-httpd-php55 .phpund Kopiere die ins root Verzeichnis von deinem Server. Bei meinem Provider klappt das erst mal als Zwischenlösung sehr gut.

https://jweiland.net/know-how/internet/php-anleitungen/php-version-fuer-einzelnes-verzeichnis-aendern.html

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Re: Bräuchte Hilfe
« Reply #2 on: February 01, 2019, 06:39:54 AM »
Hallo und einen schönen guten Morgen Tino...

vorab ganz herzlichen Dank für deinen Rat... habe ihn versucht umzusetzen d.h. habe eine neue .htaccess- Datei mit php 7.2 erstellt und sie ins gleiche Verzeichnis hochgeladen wo sich die bisherige uralte Version 4.4 auch befindet.
Dann auf der 1&1 IONUS Seite auf die neuere php-Version 7.2 umgestellt- leider mit dem Ergebnis einer Fehlermeldung...
Fehlermeldung: Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /homepages/34/d232718231/htdocs/Digital-Photogalerie/includes/db_mysql.php:37 Stack trace: #0 /homepages/34/d232718231/htdocs/Digital-Photogalerie/global.php(401): Db->__construct('db2114.1und1.de', 'dbo298714987', 'ernst654321', 'db298714987') #1 /homepages/34/d232718231/htdocs/Digital-Photogalerie/index.php(31): include('/homepages/34/d...') #2 {main} thrown in /homepages/34/d232718231/htdocs/Digital-Photogalerie/includes/db_mysql.php on line 37

Ich kann damit überhaupt nichts anfangen... Sorry, aber ich habe von diesen php/mysql Scripten null Ahnung und tue mir deshalb mit allem was damit zusammenhängt sehr schwer.

Nochmals Danke für deine Mühe zu antworten.
LG
Ernst
« Last Edit: February 01, 2019, 06:56:19 AM by *megadrive* »

Offline Tino23

  • Full Member
  • ***
  • Posts: 190
    • View Profile
    • LMJ - Motorsport
Re: Bräuchte Hilfe
« Reply #3 on: February 01, 2019, 07:14:41 AM »
Hi, du mußt auf die Version 5.5 umstellen und nicht auf die aktuelle PHP Version 7.2 da macht 4images Probleme. Mit der PHP Version 5.5 hast du die wenigsten Probleme.

Code: [Select]
1
 AddHandler x-httpd-php55 .php
 

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Re: Bräuchte Hilfe
« Reply #4 on: February 01, 2019, 07:40:59 AM »
Hi Tino...

habe das umgestellt- leider kommt bei Verwendung> 7.2 Empfohlen nach wie vor die gleiche Fehlermeldung.
Wenn ich die Einstellung php 5.6 auswähle (siehe Bild)  dann sehe ich meine HP.... nur, das ist nicht der Sinn der Sache :?
Ab 01.03.2019 will 1&1 IONUS eine EXTRA- Support Zahlung von knapp 9 € im Monat haben damit ich die HP (geschützt) weiter betreiben kann....

Da ist ja die Krux- ich möchte 4images auf Version 1.8 umstellen um diese Kosten zu vermeiden.
Hierfür bräuchte ich einen Fachmann der mir das Schritt für Schritt zeigen kann oder per Remote auf diese HP zugreifen und alles entsprechend umstellen kann.

Erneut ein Dankeschön an dich für die Zeit.
NG
Ernst

« Last Edit: February 01, 2019, 09:11:55 AM by *megadrive* »

Offline Tino23

  • Full Member
  • ***
  • Posts: 190
    • View Profile
    • LMJ - Motorsport
Re: Bräuchte Hilfe
« Reply #5 on: February 01, 2019, 07:24:30 PM »
https://website-bereinigung.de/blog/php-extended-support-strato-1und1    :oops:

Da kann ich nur empfehlen bei dieser Abzocke den Webspace Anbieter zu wechseln. 4images ist noch nicht zu 100% auf php 7.2 umgestellt und läuft im Moment mit der Version 1.8 unter php 7.0.

Vieleicht auf kostenloßen Webspace erst mal wechseln und bei 1&1 eine Weiterleitung einrichten.
 z.B. bei https://www.bplaced.net/  (ab php 5.6 kann man dort alles einstellen)


Ansonsten mal versuchen in der config.php
 suchen
Code: [Select]
$db_servertype = 'mysql';
und ersetzen durch
Code: [Select]
$db_servertype = 'mysqli';
Die db_mysqli.php mußt du dir aus der Version 1.8 in deine alte Version mit Kopieren

http://www.4homepages.de/forum/index.php?topic=32049.0;msg=166960

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Re: Bräuchte Hilfe
« Reply #6 on: February 02, 2019, 04:42:48 AM »
Hallo und einen schönen guten Morgen Tino,
herzlichen Dank für deine erneute Hilfestellung- muss dann mal schauen ob ich den Provider wechseln kann. Mitte Januar hat sich leider der Vertrag um ein Jahr verlängert :evil:
Ansonsten werde ich versuchen deine Ratschläge umzusetzen.

Nochmals Danke für deine nette Hilfe
LG und eine schöne Zeit für dich
Ernst

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Re: Bräuchte Hilfe
« Reply #7 on: February 05, 2019, 07:16:36 AM »
Hallo Tino,

möchte mich nochmals ausdrücklich bei dir für den Tipp mit bplaced bedanken :D
Habe mir dort die Pro-Version gekauft!
Dort hat man mir dann unbürokratisch und schnell geholfen und das Update von meiner 1.7er Version auf die 4images 1.8 vollzogen- gleichzeitig wurde  PHP 7.0 - eingestellt.
Bin also rundum zufrieden.

Danke für deine Hilfe.
LG
Ernst

Offline Tino23

  • Full Member
  • ***
  • Posts: 190
    • View Profile
    • LMJ - Motorsport
Re: Bräuchte Hilfe
« Reply #8 on: February 06, 2019, 10:29:22 AM »
Kein Problem  8)

Offline *megadrive*

  • Newbie
  • *
  • Posts: 17
    • View Profile
    • Go4morePhotographie
Re: Bräuchte Hilfe
« Reply #9 on: February 25, 2019, 10:38:47 AM »
Hallo nochmals
(hänge meine Frage hier an bevor ich einen erneuten Thread eröffne)

Mein Update von 4images 1,7 auf  1.8 hat dank Hinweis von Tino über bplaced wunderbar geklappt.
Nunmehr bin ich dabei die mir sichtbaren Fehler zu beheben- bislang klappt es recht gut- eine Ansicht bekomme ich einfach nicht hin- Bild anbei!
Kann mir jemand sagen wo/in welcher Script-Datei von 4images muss ich die Einstellungen/Werte ergänzen um die EXIF- Info- Datenanzeige genau unter die oberhalb befindliche Anzeige zu bekommen?

Wäre sehr nett wenn da jemand helfen könnte.
Schon mal vorab Dankeschön für die Mühe.

NG
Ernst