Author Topic: 4images 1.8 - Feedback  (Read 15916 times)

0 Members and 1 Guest are viewing this topic.

Offline kp

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: 4images 1.8 - Feedback
« Reply #15 on: October 09, 2017, 10:04:45 PM »
So, habe es selbst gelöst.

In der my_sqldb.php steht seit der V1.8 die Zeile:

   mysql_set_charset
('utf8'$this->connection);

Diese Zeile muss auskommentiert oder gelöscht werden.

Die Sache war umso schwerer zu finden, da man sich darauf verlässt, dass, wenn man in der lang/deutsch/main.php den Charactercode einstellt, diese Einstellung auch im gesamten Programm berücksichtigt wird.
Mit dieser Zeile wir die DB aber in jedem Fall auf utf8 eingestellt.
Hier könnte man den Code ggf. etwas optimieren...

Many thanks!!!

Problem 1:
Ich hab allerdings einen fehler beim Text wenn ich auf

 $lang
['charset'] = "UTF-8";


ändere - dann habe ich ein paar "?"  

somit lasse ich
$lang['charset'] = "iso-8859-1";



Hallo,
ich habe im Prinzip das gleiche Problem.
Da meine ganze Seite NICHT in UTF-8 programmiert ist (und es sich auch nicht so ohne weiteres ändern lässt), muss ich die Galerie auf iso-8859-1 oder windows-1252 weiterlaufen lassen.
Leider tritt das Problem auf, dass alle Texte wie Catergorie oder Description etc. die aus der Datenbank gelesen werden, falsch dargestellt werden.
Zum Beispiel wird München als  München ausgegeben.
Ein Umstellen auf UFT-8 macht es wieder richtig, aber der Rest meiner Seite wird dann falsch dargestellt.

Glaubt mir, ich habe schon 2 volle Tage meines Urlaubs mit probieren und debuggen verbracht.
Habe Funktionen wie formattext htmlspechialschars usw. untersucht aber keine Lösung gefunden.
Habe auch z.B. alle 4Image Dateien in ANSI Foirmat konvertiert usw. aber es bringt nichts.

Man kann es sogar schon gut an der Kategorie-Dropdown-Box sehen.
Der oberste Text der aus der PHP selbst kommt heißt korrekt "Kategorie wählen" mit ä
wohingegen die anderen Texte die Fehler bei den Umlauten aufweisen.

Habe jetzt erst mal aus Verzweiflung und Resignation auf V1.7.13 zurück gewechselt.

Hat jemand eine Idee wieso/wo die Texte aus der mysql DB falsch interpretiert werden?

P.S: Kann bei Bedarf auch die Version 1.8 wieder aufspielen.

Schon mal vielen Dank wenn sich jemand dem Problem anehmen kann.

Offline Tino23

  • Full Member
  • ***
  • Posts: 190
    • View Profile
    • LMJ - Motorsport
Re: 4images 1.8 - Feedback
« Reply #16 on: February 06, 2019, 11:16:06 AM »
Ich fände es schön, wenn noch eine Anleitung geschrieben wird wie man seine 4images Seite, auf die in der Aktuellen Version 1.8 UTF8 Konvertieren kann (Stichwort Datenbank). Nur mit dem Updaten auf die Version 1.8 ist es eben leider nicht getan, da die Datenbank zum Beispiel dabei unberührt bleibt  :!:.

http://www.4homepages.de/forum/index.php?topic=32245.0