Author Topic: Missing plugin to play mp4 file  (Read 1975 times)

0 Members and 1 Guest are viewing this topic.

Offline surferboy

  • Full Member
  • ***
  • Posts: 142
    • View Profile
Missing plugin to play mp4 file
« on: October 11, 2015, 04:51:03 PM »
Hi -

I added an extension for .mp4 files following Vano's instructions http://www.4homepages.de/forum/index.php?topic=7277.0 

The file I wanted to play was huge, bigger than 20mb, so I uploaded it via ftp.  The file is there no problem.

The issue is that in almost all of the browsers, I get this message: "a plugin is needed to display this content."  The file will play on IE 11 but will not play on Firefox, on Waterfox, on Pale Moon, and on Chrome.  I have atttached a printscreen

Here is the mime type I have added in the upload_definitions.php file:
$mime_type_match['mp4'] = array("video/mp4", "application/octet-stream");

Here is the code in the mp4.html file:

Quote
<!-- Template file for MP4 Movies  -->
<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="320" height="256" codebase="http:www.apple.com/qtactivex/qtplugin.cab">
<param name="SRC" value="{media_src}">
<param name="CONTROLLER" value="TRUE">
<param name="AUTOPLAY" value="TRUE">
<param name="CACHE" value="TRUE">
<param name ="SaveEmbedTags" value="true">
<embed
src="{media_src}"
width="320" height="256"
controller="TRUE"
autoplay="TRUE"
cache="TRUE"
SaveEmbedTags ="true"
type="video/quicktime"
pluginspage="http://www.apple.com/quicktime/download/">
</embed>
</object>

yes, I have the file extension in the acp settings. 

Should I use a different set of codes for the mp4.html file?  Any ideas?

Thanks,

Brian

 

Post your comments here