Author Topic: Ergebnisse der (Stichwort-)suche fehlerhaft bzw. unvollständig  (Read 2560 times)

0 Members and 1 Guest are viewing this topic.

Offline svdh

  • Pre-Newbie
  • Posts: 2
    • View Profile
Ergebnisse der (Stichwort-)suche fehlerhaft bzw. unvollständig
« on: February 01, 2011, 11:01:51 PM »
Hallo,

sorry, wenn ich diesen Fehler vielleicht mit der Lösung hier im Forum übersehe, aber ich habe nichts konkretes gefunden..  :oops:

Bei der Suche über die search.php werden nach einem bestimmten String nicht alle Bilder gefunden/angezeigt, obwohl diese alle den Suchstring beinhalten.
Es ist nur ein Wort, nämlich: "presse_SPORTART" wobei "SPORTART" für eine Sportart aus unserem Verein steht.
Ich verweise somit auf die Sucherergebnisse, wenn ich alle Presseartikel (die al Bild abgespeichert sind), in denen dieser Begriff hinterlegt ist.
Komischerweise werden mit die Ergebnisse aus 2009 angezeigt, aber nicht aus 2010... woran kann das liegen?

Hier die aktuelle Seite bzw. eine Seite, von der aus auf das Script verlinkt:
xxx: xxx: tsv-westerland. de/sparten. php?sparte=Judo

Weiter unten gibt es den Link "Presseberichte aufrufen".
Hier wird (über eine Frame-Seite, damit ich eine zusätzliche Navigation oben habe) das search-Script aufgerufen mit der übergebenen Variable.
Nun werden mir aber leider nicht alle Bilder angezeigt...  :(

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.287
    • View Profile
    • Discover the New World of Kindersurprise
Danke Harald




Offline svdh

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: Ergebnisse der (Stichwort-)suche fehlerhaft bzw. unvollständig
« Reply #2 on: February 02, 2011, 11:00:38 PM »
Hallo,

ok, das Script ist fehlerfrei durchgelaufen, aber nun wird gar nichts mehr angezeigt.
Die Stichwörter sind noch vorhanden, aber jetzt bricht das Suchscript mit der Meldung "Die Suche ergab leider keine Treffer." ab.
Vorher waren zumindest ein paar Ergebnisse da, jetzt gar keine mehr...  :(

UPDATE:
Problem gelöst. Anscheinend habe ich den Fehler gefunden: Stichwörter mit einem Unterstrich, also bei mir z. B. "presse_judo" wurden wohl nicht richtig umgesetzt.
Per SQL-Export / Suchen-Ersetzen / habe ich den Unterstrich entfernt und dann gehts auch - nachdem man dann wieder den re-index durchlaufen lässt.
Bei mir ist das Problem also erstmal gelöst...  :)

Danke und Gruß
« Last Edit: February 02, 2011, 11:22:58 PM by svdh »

 

Post your comments here