Author Topic: [1.7.1 - 1.7.8] Can't login  (Read 7451 times)

0 Members and 1 Guest are viewing this topic.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[1.7.1 - 1.7.8] Can't login
« on: August 25, 2010, 04:45:35 AM »
On some servers this "bug" won't let login into 4images unless selected "Log me on automatically next visit" checkbox at members login form. It only affects some servers that for some reason return text value of boolean settings in php.ini Technically this is not 4images fault, because according PHP documentation register_globals is a boolean value, and in documentation for ini_get() states:
Quote
   Note: When querying boolean values
A boolean ini value of off will be returned as an empty string or "0" while a boolean ini value of on will be returned as "1". The function can also return the literal string of INI value.



The fix is simple:
in includes/sessions.php find:
    if (@ini_get('register_globals')) {

Replace with:
    $register_globals strtolower(@ini_get('register_globals'));
    if (
$register_globals && $register_globals != "off" && $register_globals != "false") {
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)