Author Topic: Automatischer Foreneintrag  (Read 2580 times)

0 Members and 1 Guest are viewing this topic.

Offline Sumale.my

  • Addicted member
  • ******
  • Posts: 1.786
  • Neverdie
    • View Profile
Automatischer Foreneintrag
« on: March 18, 2010, 01:18:55 PM »
Hallo zusammen,


in 4images habe ich es so eingestellt, wenn ich ein Bild hochlade das passend dazu im WBB (Gleiche DB) eine Forenpost erstellt wird. Das klappt soweit auch, allerdings wird in wbb1_1_post der Wert threadID nicht angelegt und muss ihn somit von selbst anlegen.


So sieht das ganze aus:

 // Forenpost erstellen
 
$sql "INSERT INTO wbb1_1_post
 (username, subject, userID, message)
 VALUES
 ('"
.FOREN_USER_NAME."', '$image_name', '".FOREN_USER_ID."', 'Test Beitrag zum Spiel')";
 
$result $site_db->query($sql);

 
// Forenthread erstellen
 
$sql "INSERT INTO wbb1_1_thread
 (boardID, topic, username)
 VALUES
 ("
.FOREN_BOARD_ID.", 'Diss $image_name', '".FOREN_USER_NAME."')";
 
$result $site_db->query($sql);


In wbb1_1_thread wird der Wert threadID automatisch erstellt. Wie bekomme ich das hin, dass in wbb1_1_post die threadID mit dem aus wbb1_1_thread dann übereinstimmt? Kann mir jemand dabei helfen oder es erklären, etwas dafür schreiben damit es funktioniert?

Wenn ich aus 4images selber das &cat_id verwende und das direkt in beiden tabellen als threadID eingetragen wird (was auch klappt), ist das Problem das er mir dann sagt das es den Eintrag schon gibt.

Bin für jede Hilfe extrem dankbar!

Ich habe es soweit hin bekommen, bekomme bekomme folgende Fehlermeldung
Parse error: syntax error, unexpected T_STRING in /www/htdocs/w00b2576/site/admin/images.php on line 557

Edit://
Habe es geschafft, waren kleine Flüchtigkeitsfehler.
« Last Edit: March 18, 2010, 07:06:48 PM by Sumale.nin »