Author Topic: User Groups  (Read 2494 times)

0 Members and 1 Guest are viewing this topic.

Offline killie

  • Pre-Newbie
  • Posts: 4
    • View Profile
User Groups
« on: September 17, 2009, 11:51:41 PM »
Using 4images 1. 7. 7

Just got the gallery set up and am quite happy with the way its looking.  When in the ACP I have set up 3 new user groups, Clients and 2 tests user groups.   When I try to add a non admin member to one of the newly created usergroups they do not appear in any of the drop down menus.  For example if I go to "Edit Users"  select the member name then Edit, in the User Level drop down menu I thought I would expect to find the appropriate user group to assign that member to, for example one of the newly created groups.
All that shows in the drop down menu is "Administrators" ,  "Registered Users" and Registered Users  (not validated) but not the new user groups .  Am I doing something wrong?
I suspect perhaps one of the files needs Chmodding checked but I'm not sure which one.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: User Groups
« Reply #1 on: September 18, 2009, 04:13:45 AM »
When you search for members in ACP, there are 4 links next to each name:
Edit, Delete, Permissions and User Groups

The "User Groups" is where you need to go.

And I agree, accessing permissions and assigning user groups should be available from within the edit user page.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline killie

  • Pre-Newbie
  • Posts: 4
    • View Profile
Re: User Groups
« Reply #2 on: September 18, 2009, 09:06:05 AM »
After searching for a member the 4 links are there Edit, Delete, Permissions User Groups, I click on user group and create it, no problem at that part. 

The problem is AT edit user page, when I try to assign a member to one of the new groups I created "Clients" it is not available from the drop down menu, all that shows in the drop down box is the default groups Administrators" ,  "Registered Users" and Registered Users  (not validated).

If I go back and select User Groups from the main ACP the new user group is there, it just seems I can't assign anyone to it.


Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: User Groups
« Reply #3 on: September 18, 2009, 03:08:39 PM »
Ok, you misunderstand the steps.
Do the following:

1) In ACP click on "Edit users" link
2) type in username you want to find, hit search button
3) at the list of search results click on "User groups" link (see right side of the screenshot)

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

 

Post your comments here