Author Topic: [1.7 - 1.7.6] Search stop terms not being used with english language  (Read 12747 times)

0 Members and 1 Guest are viewing this topic.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
nuzecast discovered a bug in search engine, that does not ignore "common" words during search (words such as "the", "are", "by", etc). The bug seems only affect english language pack that comes with 4images.
The bug is actually not in the code, but in misspelling the file with stop terms list.
The fix is simple - rename:
lang/english/stop_searchterms.txt
to this:
lang/english/search_stopterms.txt
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline MitchJohnson

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: [1.7 - 1.7.6] Search stop terms not being used with english language
« Reply #1 on: January 14, 2010, 03:18:13 PM »
Ah so we rename the file not edit the code. I've been putting up with this problem for a while now and have been trying to edit the code when all i needed to do was rename the file, lmao. So simple. Thanks V@no.
« Last Edit: January 28, 2010, 03:45:59 PM by MitchJohnson »

 

Post your comments here