Author Topic: high CPU use (high load on the server)  (Read 6554 times)

0 Members and 1 Guest are viewing this topic.

Offline dilkebol

  • Newbie
  • *
  • Posts: 34
    • View Profile
high CPU use (high load on the server)
« on: March 12, 2009, 03:20:58 PM »
My host told me that my site is consuming high CPU usage about 20 % .
I am using shared server.
SO I changed from disabled captcha to below one.
-Captcha is enabled to stop spamming using send as ecard . (8 digit captcha)
-Comments are also captcha enabled (8 digit captcha)
-Registration is also captcha enabled (8 digit captcha)
-Image download only available to reg. users.
-send as ecard only available to reg. users.
-image upload only for admin
-FTP password  changed to 24 digits & & all webmail accounts deleted(only default one is there )
-keywords which are automatically creates hyperlink to search page is also disabled in order to stop load on sql database.i.e.only keywords are there no hyperlink.
Getting below 1000 visitors per day.
Still my host is saying high CPU use.
 command : [php]<defunct>
is causing high CPU %
Anyone help please.
Thanks in advance

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: high CPU use (high load on the server)
« Reply #1 on: March 12, 2009, 03:40:23 PM »
Just googled around for [php]<defunct> and came to conclusion that this is more related to problem on the server rather then to a script.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Bogdan

  • Newbie
  • *
  • Posts: 22
    • View Profile
    • Press Release
Re: high CPU use (high load on the server)
« Reply #2 on: March 28, 2009, 05:49:39 PM »
My host told me that my site is consuming high CPU usage about 20 % .
I am using shared server.
SO I changed from disabled captcha to below one.
-Captcha is enabled to stop spamming using send as ecard . (8 digit captcha)
-Comments are also captcha enabled (8 digit captcha)
-Registration is also captcha enabled (8 digit captcha)
-Image download only available to reg. users.
-send as ecard only available to reg. users.
-image upload only for admin
-FTP password  changed to 24 digits & & all webmail accounts deleted(only default one is there )
-keywords which are automatically creates hyperlink to search page is also disabled in order to stop load on sql database.i.e.only keywords are there no hyperlink.
Getting below 1000 visitors per day.
Still my host is saying high CPU use.
 command : [php]<defunct>
is causing high CPU %
Anyone help please.
Thanks in advance


Caching feature is active and working? Also, your pictures are large ( 800 - 1000 KB )?

Offline comicart

  • Full Member
  • ***
  • Posts: 148
    • View Profile
Re: high CPU use (high load on the server)
« Reply #3 on: January 22, 2015, 06:48:44 PM »
I'm also getting this problem at times.

| Top Process | 78.0 | /usr/bin/php /home/comicart/public_html/index.php |
| Top Process | 60.0 | [php] <defunct> |
| Top Process | 56.0 | [php] <defunct> |

And the note from my server management saying
Quote
the traffic and the badly optimized php scripts of comicartcommunity.com (the defunct php processes) are causing high loads in the server which causes critical services to fail.  We would suggest having the website developer take a look into the php coding to better optimize it.

I've made many changes/add-ons over the years. I'm sure I need to go back and strip some out.

 

Post your comments here