Author Topic: GD updaten auf 2.0.1 wird nicht erkannt  (Read 3979 times)

0 Members and 1 Guest are viewing this topic.

Offline Fox Mulder

  • Newbie
  • *
  • Posts: 13
    • View Profile
GD updaten auf 2.0.1 wird nicht erkannt
« on: October 08, 2002, 12:53:21 AM »
Ich hab ein kleines Problem, und zwar will ich auf meinem Suse 7.3
System die GD Library von 1.8.x auf 2.0.1 updaten, da mit der
1.8.x Library die Thumbnails eine relativ schlechte Qualitaet haben.
Ich habe nun den Quellcode dazu heruntergeladen, das Makefile
angepasst und mit "make install" compiliert und installiert.
Ich habe nun auch die Library /usr/lib/libgd.so.2.0.1 und die Tools
in /usr/local/bin.
Soweit sogut, aber wenn ich jetzt in der Datei /includes/constants.php
den Eintrag "define('CONVERT_IS_GD2', 0)" auf 1 setze kommt
trotzdem beim Thumbnail generieren die Fehlermeldung:

    Erstelle Thumbnail für: test1 (test1.jpg) ....  
    Fatal error: imagecreatetruecolor(): requires GD 2.0 or later in /usr/local/httpd/htdocs/bilder/includes/image_utils.php on line 65[/list:u]

    Jetzt weiss ich nicht, wieso er die GD 2.0.1 Library nicht erkennt auf
    meinem System. Ich hoffe irgend jemand kann mir da vieleicht einen Tip
    geben, was ich machen muss, damit das funktioniert. :)

    Ciao,
    Fox

 

Post your comments here