Author Topic: 1.7.2 - 1.7.4 [FIX] mit Umlauten in Kommentaren-/Suche - Comments-/Search  (Read 110770 times)

0 Members and 1 Guest are viewing this topic.

Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #30 on: August 30, 2007, 11:45:38 AM »
@Jan , @Kai oder @Nicky

... die beiden Fixes sollten in den Thread "Bug Fixes & Patches" aufgenommen werden ...  :!:
... sonst gehen sie für viele User hier unter ...
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline ivan

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 2.279
    • View Profile
    • Bilder Gallery
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #31 on: August 30, 2007, 08:11:10 PM »
danke jan für den prompten dienst!
nun läuft auch der image name in der alt"" funktion
super...

gruss ivan
greetings / grüsse
ivan

Facebook Fan Page | Follow Twitter

Blog: Reisen Blog
Bilder Gallery: Bilder Gallery

Offline lordi

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #32 on: October 16, 2007, 09:19:45 PM »
guys

can someone translate to me ???

i didn't understand anything!!!!!!!

plz

i have 1.7.4 version

Offline kai

  • Administrator
  • Addicted member
  • *****
  • Posts: 1.407
    • View Profile
    • 4images - Image Gallery Management System
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #33 on: October 17, 2007, 12:53:41 PM »
@ lordi: It's a fix for posting comments with special characters like ü ö ä å ...
« Last Edit: January 10, 2008, 02:17:02 PM by kai »
Your first three "must do" before you ask a question:
1. Forum rules
2. FAQ
3. Search

Offline Alessio

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
    • Webax.it [Alessio's photogallery]
Alessio
my homepage: http://www.webax.it

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #35 on: October 20, 2007, 02:43:51 PM »
No need for Google translation. Is say in english on right of each step.
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

marcuskillen

  • Guest
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #36 on: January 10, 2008, 02:11:47 PM »
thx !!! the fix did it for me  :lol: äöåööåä no problems now

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.284
    • View Profile
    • Discover the New World of Kindersurprise
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #37 on: January 23, 2008, 12:19:48 AM »
hätte hier auch noch etwas zum fixen  :wink: (hoffe bin hier richtig)
Und zwar wird im Bildnamen kein Zeilenumbruchzeichen mehr interpretiert
Wir hatten in der 1.7.1 wegen der Übersichtlichkeit einige <br> eingebaut, hat auch immer geklappt, hier in der 1.7.4 leider nicht
habe die Fixes dieser Seite alle eingebaut.



gruss Harald




Danke Harald




Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #38 on: January 23, 2008, 01:30:53 AM »
Hallo Harald,

... hast natürlich Recht ... gehört eigentlich nicht hierher ... aber trotzdem ...  :wink:
... ungetestet ... aber versuche mal Folgendes in der includes/functions.php ...
... statt ...
Code: [Select]
"image_name" => format_text($image_row['image_name'], 2),
... dieses ...
Code: [Select]
"image_name" => format_text($image_row['image_name'], 1, 0, 1),
... damit sollte die html-Konfiguration für den Bildnamen erfolgen und <br> als Umbruch ausgeführt werden ...


« Last Edit: January 23, 2008, 03:16:39 AM by mawenzi »
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.284
    • View Profile
    • Discover the New World of Kindersurprise
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #39 on: January 23, 2008, 01:52:02 AM »
Hallo Detlev,
Du hast wohl auch kein Bett ;)
hatte leider keinen besseren Threat gefunden  :o

So, hab es eingebaut, doch leider kein Erfolg  :cry:

Danke Harald
Danke Harald




Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #40 on: January 23, 2008, 03:18:42 AM »
@ Harald,

... habe die Codezeile noch mal geändert ... wiederum ungetestet ...
... ansonsten müsste ich mal mit 'nem Test anfangen ...

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.284
    • View Profile
    • Discover the New World of Kindersurprise
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #41 on: January 23, 2008, 09:54:18 AM »
Nachteule  :wink:

So, in der Kategorie übersicht klappt es jetzt, nur in der Detailübersicht noch nicht
http://www.ue-ei-portal-sammlerkatalog.de/details.php?image_id=38763

gibt es da 2 verschiedene Stellen zum ändern ?
obwohl hat es mich da immer gestört, weil dann eine 2te Zeile angefangen wurde :?
Kann man da nicht ausklammern ? so das es da nicht angezeigt wird 

Harald
Danke Harald




Offline nikitaspj

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #42 on: January 23, 2008, 07:00:43 PM »
Hallo guys ;)
i am a new user of 4images
I faced the problem with special characters (i am from Greece      αβγδεζ.....  )
the fix seems to work for me now


but i dont understand if i have to do and that (i copy paste from the Jan's Reply #29 on: August 30, 2007, 09:25:58 AM )

Fix (in includes/functions.php):

Code:
"image_name" => $image_name,

ersetzen durch

Code:
"image_name" => format_text($image_name, 2),

und (kommt 3x vor)

Code:
alt=\"".$image_name."\"

ersetzen durch

Code:
alt=\"".format_text($image_name, 2)."\"


and most important it would be right to post the fix with another title
cause the word Umlauten there will be many people that they will not understand.
When i was a kid i tried to learn Deutch and that little knowledge helped me understand that there is a Special Character issue.If i didn't knew ,maybe i would still try to find the solution .
The bug propably affects all the users that their languages have special characters.Slavic Arab Greek Turkish Chinese etc etc.Some they have allready posted about the prob and some of these threads seem unsolved.
so it would be Real Helpfull if u post it as a
Special Characters Bug in Upload -Comments -Search sollution

danke schön

Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #43 on: January 23, 2008, 08:16:32 PM »
@ nikitaspj
... this fix in fuctions.php has nothing to do with the fix for posting comments with special characters ...
... it is a special fix for Jan-Lucas request ...
... and you are right ...
... "it would be Real Helpfull if u post it as a Special Characters Bug in Upload -Comments -Search sollution" ...
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline Thotty

  • Jr. Member
  • **
  • Posts: 53
    • View Profile
    • VW-Freaks.net
Re: [FIX] 1.7.4 mit Umlauten in Kommentaren-/Suche - Comments-/Search
« Reply #44 on: February 17, 2008, 09:28:40 AM »
Ich habe Keywords mit Umlauten und nun das Problem, dass diese (auch mit dem Fix) nicht gefunden werden.
Erst wenn ich das Bild übers Control Panel aufrufe und auf Änderungen Speichern klicke, werden Bilder mit Umlaut-Keywords gefunden. :!:

Woran liegt das und gibts irgend 'ne Möglichkeit, das per SQL zu machen, damit ich das nicht bei jedem Bild einzeln machen muss? :?:

 

Post your comments here