Author Topic: html-code in Bildbeschreibung wird automatisch maskiert - warum?  (Read 3057 times)

0 Members and 1 Guest are viewing this topic.

Offline tsegge

  • Pre-Newbie
  • Posts: 2
    • View Profile
Hallo,

in der Bildbeschreibung verwende ich html-code.
Leider wird bei mir html-code automatisch beim Speichern maskiert und wird demzufolge zu normalem Text, was natürlich nicht Sinn und Zweck der Sache ist.
Das passiert sowohl mit IE als auch mit Firefox (beide auf XP).

Beispiel:
aus < wird &lt;
aus > wird &gt;

Woran liegt das und wie kann ich das verhindern?
Alles in meiner 4images-Installation ist noch Standard.


Offline e-trader_2002

  • Jr. Member
  • **
  • Posts: 53
    • View Profile
Re: html-code in Bildbeschreibung wird automatisch maskiert - warum?
« Reply #1 on: April 20, 2006, 12:01:39 AM »
Hallo,

ich habe das gleiche Problem und bin ebenfalls an einer Lösung interessiert !
A hobby is a great way to spent time you actually don't have! :wink:


Offline Blondi

  • Pre-Newbie
  • Posts: 1
    • View Profile
Re: html-code in Bildbeschreibung wird automatisch maskiert - warum?
« Reply #2 on: April 20, 2006, 12:17:25 AM »
Suche im Verzeichnis "includes" in der Datei  functions.pho die Zeile

 $description = (!empty($image_row['image_description'])) ? format_text($image_row['image_description'], 0) : REPLACE_EMPTY;

und ersetze sie wie folgt:

 $description = (!empty($image_row['image_description'])) ? format_text($image_row['image_description'], 1) : REPLACE_EMPTY;

Danach geht html in der Beschreibung wieder.

Offline tsegge

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: html-code in Bildbeschreibung wird automatisch maskiert - warum?
« Reply #3 on: April 20, 2006, 10:05:46 AM »
Ja, das funktioniert. Vielen Dank!

Trotzdem verwunderlich. Könnte ja wenigstens ein Hinweis dabei stehen, wie z.B.:

"Sie können HTML-Code verwenden, wenn Sie die Datei functions.php editieren."

oder so ähnlich.

 

Post your comments here