Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jan

Pages: [1] 2 3 4 5 ... 287
1
Feedback & Suggestions / Re: 4images 1.7.10 - Feedback
« on: June 15, 2011, 04:53:57 PM »
Fix in includes/sessions.php.

Suche nach
$this->set_cookie_data("userpass"$this->user_info['user_password']);
und ersetze mit
$this->set_cookie_data("userpass"md5($this->user_info['user_password']));

2
Feedback & Suggestions / Re: 4images 1.7.10 - Feedback
« on: June 15, 2011, 10:08:04 AM »
Hallo,

seit 1.7.10 funktioniert bei einigen unserer Usern und auch bei mir selbst die AutoLogin Funktion nicht mehr.
Cookies und Cache wurden schon mehrfach gelöscht, es will einfach nicht klappen.
Was kann ich tun?

Sonst läuft alles prima, danke für das Update.

Kannst Du ne URL zu Deiner Galerie posten?

3
Ja, sorry. Ich hatte Kais Post geändert und vergessen den Link im Text anzupassen. Link stimmt jetzt.

4
Du musst in dem Suchformular lediglich das method-Attribut auf "get" ändern:

Code: [Select]
<form target="_blank" action="http://www.online-fremdfigurenkatalog.de/search.php" method="get">

5
Ich habe die csrf_utils.php im Hauptpost aktualisiert. Bitte ersetzt die aktuelle mit dieser, dann sollten auch die Plugins wieder funktionieren.

Zu den Konfigurationsvariablen:

Code: [Select]
$csrf_protection_enable      = 1;
Dies auf 0 gesetzt, schaltet den Schutz komplett aus (für Frontend und Backend).

Code: [Select]
$csrf_protection_frontend    = 1;
Dies auf 0 gesetzt, schaltet den Schutz komplett für das Frontend aus.

Code: [Select]
$csrf_protection_backend     = 1;
Dies auf 0 gesetzt, schaltet den Schutz komplett für das Backend aus.

Meine Empfehlung:

$csrf_protection_enable und $csrf_protection_backend sollten in jedem Fall auf 1 gesetzt sein. Falls es Probleme gibt, bitte hier melden. Im Falle von Problemen kann man $csrf_protection_backend temporär auf 0 setzen um benötigte Änderungen durchzuführen. Danach wieder auf 1 setzen.

$csrf_protection_frontend sollte man natürlich am besten auf 1 belassen. Falls es Probleme gibt, kann man hier aber vorrübergehend 0 setzen um die Galerie am Laufen zu halten.

6
Chit Chat / Re: Just 4 V@no
« on: August 06, 2009, 09:26:16 AM »
Happy Birthday and thanks for all!  :D

7
Chit Chat / Re: V@no is back on web ...
« on: July 03, 2008, 09:28:04 AM »
Yeah! Welcome back, mate...

8
%20 ist ein kodiertes Leerzeichen. Also, entweder ein Bug in FF oder gewollt. Sollte aber so oder so funktionieren...

9
wird der link so abgeändert
Code: [Select]
/search.php?search_keywords=gotthard %2Bbuchs

Wo genau wird der Link abgeändert? Im Quellcode? In der Adressleiste?

10
Das + ist in diesem Fall ein Platzhalter für ein Leerzeichen (urlencoded).

Um einen Suchausdruck zu kodieren kannst Du zB. das Forumlar hier verwenden:
http://www.hypergurl.com/urlencode.html

Du trägst in das Textfeld einfach den Ausdruck ein so wie Du ihn ins Suchfeld eintragen würdest:

Code: [Select]
biene +bienen +bienenhaus
Heraus kommt dann:

Code: [Select]
biene%20%2Bbienen%20%2Bbienenhaus
Der Link ist dann also:

Code: [Select]
./search.php?search_keywords=biene%20%2Bbienen%20%2Bbienenhaus

11
Tutorials / Re: [Tutorial] Making additional field searchable
« on: April 14, 2008, 12:53:40 PM »
Ja, und ohne Deine super Fehlerbeschreibung hätten wir wahrscheinlich noch Wochen gebraucht um ihn zu finden.
Werden den Post als Vorbild für eine perfekte Fehlerbeschreibung bookmarken ;)

Gruß Jan

12
Tutorials / Re: [Tutorial] Making additional field searchable
« on: April 11, 2008, 05:59:24 PM »
Code: [Select]
CREATE TABLE `4images_wordmatch` (
  `image_id` int(10) unsigned NOT NULL default '0',
  `word_id` int(10) unsigned NOT NULL default '0',
  `name_match` tinyint(1) NOT NULL default '0',
  `desc_match` tinyint(1) NOT NULL default '0',
  `keys_match` tinyint(1) NOT NULL default '0',
  ` gmap_match` tinyint(1) NOT NULL default '0',
  UNIQUE KEY `image_word_id` (`image_id`,`word_id`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

Hier liegt der Fehler:
Code: [Select]
` gmap_match` tinyint(1) NOT NULL default '0',
Das Tabellenfeld gmap_match hat ein führendes Leerzeichen. Das ist bei neueren MySQL-Versionen möglich und passiert manchmal wenn man zB mit phpMyAdmin arbeitet.

13
You are right, the correct line is:

Code: [Select]
$user_homepage = (isset($user_row['user_homepage'])) ? format_text(format_url($user_row['user_homepage']), 2) : REPLACE_EMPTY;
I've update the fix in my previous post!

14
To fix this, search in member.php for

Code: [Select]
$user_homepage = (isset($user_row['user_homepage'])) ? format_url($user_row['user_homepage']) : REPLACE_EMPTY;
and replace it with

Code: [Select]
$user_homepage = (isset($user_row['user_homepage'])) ? format_text(format_url($user_row['user_homepage']), 2) : REPLACE_EMPTY;

15
Mit diesem Plugin den Suchindex neu erstellen:
http://www.4homepages.de/forum/index.php?topic=6718.0

Pages: [1] 2 3 4 5 ... 287
Post your comments here