Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Fastian

Pages: [1] 2 3 4 5 ... 15
1
Mods & Plugins (Releases & Support) / Re: [Mod] Avatar v2.01
« on: March 14, 2009, 11:34:48 AM »
Bug fixes -> [1.7 - 1.7.6] Additional user fields not being used for guests
Sorry  :oops:
I missed it. I should have looked there.
It works perfect now  :)

2
Mods & Plugins (Releases & Support) / Re: [Mod] Avatar v2.01
« on: March 14, 2009, 09:20:29 AM »
Did steps 4 and 12?
Yes. I am pretty sure I followed your instructions completely. Infect, I double checked everything just now.
Addition user filed is there in db_field_definitions.php and in my DB, I can see "user_avatar" under 4images_users table.

Also, this error comes in Search page only when I view as a Guest. When logged in as Admin/User, I don't see this error message.

3
Mods & Plugins (Releases & Support) / Re: [Mod] Avatar v2.01
« on: March 14, 2009, 08:50:09 AM »
Quote from: drhtm
is it possible to add the avatar in the box 'Registered Users' after a member login right after their name and above the link to 'lightbox'?

And if a user hasn't chosen an avatar is it possible to put a default image or text in that space to remind the user to choose an avatar?

thanks
hmmm...I like the idea add avatar under the name :wink:
just did it on my site:open /includes/page_header.php
Find:
Code: [Select]
 "url_upload" => (!empty($url_upload)) ? $site_sess->url($url_upload) : $site_sess->url(ROOT_PATH."member.php?action=uploadform"),Add after:
Code: [Select]
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",
Then, open user_logininfo.html template. Add this:
Code: [Select]
{user_avatar_current}

About default image - just change blank.gif with image u want.
@V@no
After this modification, I am getting following error message on Search page.
Notice: Undefined index: user_avatar in xxxx\includes\page_header.php on line 204
And on line 204 I have this
Code: [Select]
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",When I view Search page as Admin, I don't get this error.
Can you please help.

4
Looks like the mod I am searching for :)
Anyone using this mod will like to share the site? (i.e. working demo)

5
I spent hours trying to find a way to use Lightbox with this Mod of V@no version (Images in diff folders) but no success.
Would certainly appreciate your help :)

6
Hi V@no

How can I modify the following code of yours so that I can use different buttons on Lightbox page do download different file sizes?
(i.e. files from different folder (800, 1024)

if anyone interesting use different folders for different size images, then here is modifyed mod:
change original mod code to this:
Code: [Select]
 $additional_download_sizes = array(72, 120, 300);

  $register_array = array();
  foreach ($additional_download_sizes as $size) {
    ereg("(.+)\.(.+)", basename($image_row['image_media_file']), $regs);
    $file = ((is_local_file($image_row['image_media_file'])) ? dirname($image_row['image_media_file'])."/" : MEDIA_PATH."/".$image_row['cat_id']."/").$size."/".$regs[1].".".$regs[2];
    if (!$allow_download || !get_file_path($file, "media", $image_row['cat_id'], 0, 0)) {
      $register_array['download_button_'.$size] = "<img src=\"".get_gallery_image("download_off.gif")."\" border=\"0\" alt=\"\" />";
      $register_array['download_zip_button_'.$size] = (function_exists("gzcompress") && function_exists("crc32")) ? "<img src=\"".get_gallery_image("download_zip_off.gif")."\" border=\"0\" alt=\"\" />" : "";
    }
    else {
      $register_array['download_button_'.$size] = "<a href=\"".$site_sess->url(ROOT_PATH."download.php?".URL_IMAGE_ID."=".$image_row['image_id']."&amp;size2=".$size."&amp;size=".$size)."\"".$target."><img src=\"".get_gallery_image("download.gif")."\" border=\"0\" alt=\"\" /></a>";
      $register_array['download_zip_button_'.$size] = (function_exists("gzcompress") && function_exists("crc32")) ? "<a href=\"".$site_sess->url(ROOT_PATH."download.php?action=zip&amp;".URL_IMAGE_ID."=".$image_row['image_id']."&amp;size2=".$size."&amp;size=".$size)."\"><img src=\"".get_gallery_image("download_zip.gif")."\" border=\"0\" alt=\"\" /></a>" : "";
    }
  }
  $site_template->register_vars($register_array);
I dont know if size= also uses somewhere else, so I just add one more, size2=
so, then open download.php file.
find
Code: [Select]
 if (isset($HTTP_GET_VARS['size']) || isset($HTTP_POST_VARS['size'])) {
    $size = (isset($HTTP_GET_VARS['size'])) ? intval($HTTP_GET_VARS['size']) : intval($HTTP_POST_VARS['size']);
  }
  else {
    $size = 0;
  }
add after:
Code: [Select]
 if (isset($HTTP_GET_VARS['size2']) || isset($HTTP_POST_VARS['size2'])) {
    $size2 = (isset($HTTP_GET_VARS['size2'])) ? intval($HTTP_GET_VARS['size2']) : intval($HTTP_POST_VARS['size2']);
  }
  else {
    $size2 = 0;
  }
then find:
Code: [Select]
   $file['file_path'] = dirname($image_row['image_media_file'])."/".$file['file_name'];
change to this:
Code: [Select]
   $file['file_path'] = dirname($image_row['image_media_file'])."/".(($size2) ? $size2."/" : "").$file['file_name'];
few lines down find:
Code: [Select]
   $file['file_path'] = (is_local_file($image_row['image_media_file'])) ? dirname($image_row['image_media_file'])."/".$file['file_name'] : MEDIA_PATH."/".$image_row['cat_id']."/".$file['file_name'];
change to this:
Code: [Select]
   $file['file_path'] = (is_local_file($image_row['image_media_file'])) ? dirname($image_row['image_media_file'])."/".(($size2) ? $size2."/" : "").$file['file_name'] : MEDIA_PATH."/".$image_row['cat_id']."/".(($size2) ? $size2."/" : "").$file['file_name'];

7
Chit Chat / Re: My website has been Hi-jacked!!!
« on: March 17, 2007, 01:23:33 PM »
This is really sad.
These days, its so hard to trust anyone. I have seen few incidents and i am trying to be even more careful now.
Also, that hurts a lot when your "so called friends" do such things ... I know, that sucks ...


Quote
To punish the guy who did this injustice to me... I will release the template of hotdt.com for public use to 4image users!!! (I am working on it now
Lolzzz .. I think that would be an interesting idea :)
Who ever will use "that" template and will give a link back to maxpaul's Original site, I will put his link on my site. (Without Link Exchange)
:)
I wish there would be an easy way to kicks his a**

Quote
p.s @Fastian the top menu is superb!!! Is the menu generated dynamically from the 4images database or it’s a static menu?
Thanks Max :) ... Its a Static menu, I tried to use 4images table but wasn’t able to ..
I used some JavaScript from DynamicDrive to do that ...
If you need it, just let me know :)

8
Chit Chat / Re: My website has been Hi-jacked!!!
« on: March 16, 2007, 11:47:43 PM »
Holy shit ...

How that can happen??  :o

I just saw the msg on your site. How he/she was able to copy all the stuff from your site ?????

The site is hosted at Site5.Com .... Can't you contact them that its a "Hacked" site and do something about it ???

That is soo sad.  :(

9
Chit Chat / Valentine’s Day Special
« on: February 12, 2007, 09:57:48 PM »
Let this valentine spirit wrap you in the fragrance of love with some romantic valentine wallpapers to color your desktop.













































I hope you like my collection. I just thought to share some of theme here in case you guys are looking for them. ;)
 Do reply in the thread.
:)

10
Your software is enabling this theft.
What does 4images have to do with this??  :x  8O
It’s up to the user how he/she use it. They could have used any gallery script.
It's kinda harsh statement.

11
Mods & Plugins (Requests & Discussions) / Re: [MOD] Hot or Not Rating
« on: January 30, 2007, 03:27:33 PM »
First of all, thanks for the Mod and the efforts you spend on development and support!

Anyway, i really tried a lot (probably too much), but i don't get it runing, as it should:
Main Problem is, after voting, you are not forwarded to the next picture. The same picture is displayed again; the vote got counted correctly.

I use rev. 1.7.3., the star rating mod (which works fine).
As mentioned above, conditional tag modification should not be necessary since 1.7.2. However, i had a couple of problems without modifiying the original template.php (parse error), so i swapped the whole "compile condition tags" to those over here:  http://www.4homepages.de/forum/index.php?topic=7493.0

Now that conditional tags should be working, i tried version 'a' of the form tag, however this one caused a "file not found" (bad url, starting with method=post...)
This one (version 'b' without "&"):
"<FORM action={if next_image_url}{next_image_url}{endif next_image_url}{self} method=post target=_top>"
now works, however, as mentioned above, without moving to the next picture.

Going to the next picture works by clicking on the picture!

I tried so much and i'm so glad the voting itself is working now; please excuse that i can't report all detailed errors i had! :-)


***
Another unimportant thing: Where/How can i disable the reload / revote function?
***

Thanks in advance for your help!
Maybe anybody can provide a working rate_form and templates.php for 1.7.3?   :)

Cheers,
Hardy

Exactly the same problem.  :(
Can someone have a look at it? I hope it will not be a big problem as there are not much of changes involved in the mod.
Please  :(

12
Mods & Plugins (Releases & Support) / Re: [MOD]More than more statistics
« on: January 28, 2007, 08:18:39 PM »
I have just tried on a new installation and looks like this mod is working just fine with v 1.7.4.
So i thought to let you guys know. :)
Thanks for the mode.

13
Chit Chat / Re: 4images Licence & other questions
« on: November 04, 2006, 09:36:28 PM »
It depends on the owner of the site. If its a company, they must have a licence, no matter whats the usage of the site.

If the owner of the site is a private person, theres no licence required. Having some banners on your site doenst makes you being a company. So, no licence is required.

Selling something as a private person makes you (in most cases) being seen as a company and a licence is required.

There are a lot of cases wheres its not very clear what you are. In this case, just write an email to us and we'll check the individual situation.

Jan

Thanks Jan for replying here

I have send you a detail mail using your online form.
What would you say about this point?
Quote
4Images is available free and I respect it. But can you (me) charge others to provide your services like installing 4images, maintaining it & customizing template?

The idea behind this came from Joomla forum where people are offering their services to setup Joomla sites. (Free & Paid depending on work)

14
This is mod is not working with v1.7.4 (At least for me)

When i click on Mass Msgs, all i see is a blank page.

However with one other installation of 4images v 1.7.1, its working just fine.

15
Chit Chat / Re: 4images Licence & other questions
« on: October 27, 2006, 07:29:14 PM »
if you make money from the script i guess you must pay for it , read more here http://www.4homepages.de/4images/license.php#english

Sure.
But actually I am not sure about my point (3) in first post. I don’t know if people will see it like "Selling Wallpapers". Although, in no way I would be selling anything coz I simply can’t. I don’t own any wallpaper so I can not sell it.

With my AdSense ads, I haven’t got anything yet. No check so far. My daily earning is under 1$ and most of the time at max $0.30.

So currently with my site, I m not getting any thing that I can even pay for my hosting charges. Earning is something different.

I don’t want to do business with it, but yes I want to get “Something” from it so that I can put more efforts and can do better work.

Lately I was having trouble with my hosting coz of database issue. You can confirm it from my previous posts. My host is asking me to pay more if I want to keep my site with them. (They want me to get a VPS for $29.99/month)
I am no way able to do that coz I am not a person with that kind of money. That’s how I thought to do something different than just displaying AdSense ads.

Pages: [1] 2 3 4 5 ... 15
Post your comments here