Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - steveeyes

Pages: [1] 2 3
1
Discussion & Troubleshooting / Problem and can't find Code
« on: April 10, 2007, 07:43:43 PM »
Hi

I made the following changes to add an email button to my site::




 Open /includes/function.php file.

Find:
Code:

    $user_name_link = "<a href=\"".$site_sess->url($user_profile_link)."\">".$user_name."</a>";


Add after:
Code:

    $user_row = get_user_info($image_row['user_id']);
    if (!empty($user_row['user_email']) && (!isset($user_row['user_showemail']) || (isset($user_row['user_showemail']) && $user_row['user_showemail'] == 1))) {
      $user_email = $user_row['user_email'];
      $user_email_save = str_replace("@", " at ", $user_row['user_email']);
      if (!empty($url_mailform)) {
        $user_mailform_link = $site_sess->url(preg_replace("/{user_id}/", $user_row['user_id'], $url_mailform));
      }
      else {
        $user_mailform_link = $site_sess->url(ROOT_PATH."member.php?action=mailform&amp;".URL_USER_ID."=".$user_row['user_id']);
      }
      $user_email_button = "<a href=\"".$user_mailform_link."\"><img src=\"".get_gallery_image("email.gif")."\" border=\"0\" alt=\"".$user_email_save."\" /></a>";
    }


Find:
Code:

    "user_name_link" => $user_name_link,


Add after:
Code:

    "user_email_button" => $user_email_button,



When I use the search on the site  I get the following error:

Undefined variable: user_email_button in /home/filipina/public_html/online-dating-gallery/includes/functions.php on line 413


I'm a little lost and can't find a fix or what I did wrong. Any help would be appreciated.


Thanks

2
Discussion & Troubleshooting / No images or photo
« on: April 06, 2007, 07:25:23 PM »
I looked throughout the forum but not luck (my search term was "no image" which gave me 199 files to look at - ugh 8O


I have registered users -- some upload their photo and some  do not. It is the ones who do not upload a photo that concerns me. I'm not good at SQL but wanted to know of a query that would list all registered users who does not have a photo along with their email address. If I knew such a query, I could export the list of members and email them (I have a program that can import the list).

The query would have to show the users who did not upload a photo and their email address.


As a side note, the biggest problem I have on my site is how to handle the membes who do not upload a photo. I use custom profiles to make 4images into a dating site. For those who do not upload a photo, I wish a default graphic could be put in place saying no photo at this time, but one coming. I just don't have the skill to do it.

Any thoghts, suggestions, etc, would be appreciated. I hope someone knows the sql query to solve my email problem.

Thanks

3
Discussion & Troubleshooting / 1.7.4 RSS not working after upgrade.
« on: April 06, 2007, 03:03:59 PM »
I was using 1.7.3 and upgraded to 1.7.4. After the upgrade, I noticed that there was no RSS. I have installed 1.7.4 fresh and  the RSS works, but can't figure out why it isn't working when doing an upgrade.

I know there is an RSS link in the footer.html file and made sure that was uploaded but still no RSS.

Can anyone give me a clue to how to get RSS working on 1.7.4 after upgrading?


Thanks
Steve

4
Jan/Members

I created a video tutor for those who are beginners or have not used 4images beyond the basics (link below).  

The tutor is built around a project of turning 4images into a free dating site. The tutors are broken down by subject and are fairly detailed.

I'm far from a php expert or even a 4image expert. I'm sure I made a few mistakes here and there.  Since I was unable to contribute very little over the years to other members, I hope the videos help.

For the experts out there, you are welcome to comment on the project. Like I said I'm far from an expert so please be kind.

For those who are just starting to use 4images or those who have been using it for a while but have not done anything beyond the basics, the videos may be helpful.

cheers

NEW URLS: up to steveeyes get them again online on his one..

adsense-templates
annotation2-mod
custom01
custom02
custom-page
default-usergroup-1
default-usergroup-2
email02
email03
email04
extra-closing
INSTALL-DONE
memberlist01
memberlist02
memberlist03
PERMISSIONS
PRE-INSTALL
resize-mod
settings
showimages-specificcCAT
small-mod
template-color
template-logo
template-width
tweak01-emailbutton
tweak-menu01
tweak-menu02
usergroups2



OLD URLS:

Link to the TOC for video tutor is at:

http://www.asian-lady.org/asian-forum/index.php?topic=26.0
or
http://www.asian-lady.org/tutors/

Note: the tutors are done in flash and voice -- will require broadband connection. The project itself (site) is 99% finished.

5
Discussion & Troubleshooting / Help -- can not add member from ACP
« on: March 15, 2007, 10:12:40 PM »
Everything was working fine until today. Now when I want to add a new user from the ACP I get the following error:

DB Error: Bad SQL Query: INSERT INTO 4images_users (user_id, user_level, user_name, user_password, user_email, user_showemail, user_allowemails, user_invisible, user_joindate, user_activationkey, user_lastaction, user_lastvisit, user_comments, user_homepage, user_icq, user_limit, user_country, user_first, user_height, user_weight, user_DOB, user_religion, user_ed, user_meet, user_self, user_phone, user_cell, user_job, user_age, user_sex) VALUES (215, 2, 'jack', 'eac572796cb9c7590471c38157f91cf2', 'jack@jack.com', 1, 1, 0, 1173991795, '9a63dea52c857dfec51aa1fd2d6cd6b7', 1173991795, 1173991795, 0, '', '', , 'usa', 'jack', '5\'10\"', '180', 'jan 14 1953', 'none', 'college', 'pretty and kind', 'good looking', 'none', 'none', 'retired', 'none', '1')
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'usa', 'jack', '5\'10\"', '180', 'jan 14 1953', 'none', 'college', 'pretty and ' at line 4


I did modify the profile of 1.7.4 weeks ago but like I said all was working fine until today. I'm not sure what went wrong or if I have been hacked.

The user can still register from the front end. And once they are registered, I can still edit the user from the ACP.


 I only get the above error when I try to register a NEW  user from the ACP. I'm not sure where the new user FORM for the ACP is controlled from nor do I have any clue about SQL.

 Any help would be appreciated?

Thanks
Steve

6
Discussion & Troubleshooting / No Photo -- Mass Email from ACP
« on: March 06, 2007, 08:08:34 PM »
I use 4images for a dating site. One problem I have is how to manage those members who do not upload a photo. I have searched the forum high and low to no avail.

I'm no php programmer so hopefully someone can help me complete my idea.

1. I installed the "list group members and Enhanced administrator email" for one reason. V@no says:

"Further enhancement to this quick mod allows you to send emails based on group, or any search criteria users.php allows"

Link to mod: http://www.4homepages.de/forum/index.php?topic=7387.0


2. I looked at the edit users in the ACP.

You can do a search without any criteria and it will list all members. My only wish is that there was a column that showed who does or does not have a photo (like the memberlist mod).

If there was such a column, with the above mod installed, I could selectively check the members who do not have a photo and mass email those selected members only telling them if they do not upload their photo by a certain date, their account will be deleted.

Is there anyone  with the skill to show how you can add such a column so it shows who does or does not have a photo listed. This would have to be in the ACP area under Users - Edit Users so you can list members photo status. Others have made similar request but as of yet no viable solution.

As a side interest it would be great if someone could show us how to customize this form inside the ACP in case  we would like to add a column that showed other user information. But for now, my primary concern is finding a way to manage members photos showing who has and has not uploaded a photo  and being able to notify them by mass email.

Thanks in advance.

p.s. What happen to V@no. It looks like he has not been active for a while on this forum  :(

7
Hi

I have customized memberedit_profile.html. What puzzles me is when I edit a users profile from the ACP, the fields are not the same as the fields in memberedit_profile.html. Specifically, at the bottom of the form in the ACP are two radio buttons with yes no values. The no value is pre-checked. The problem is, I have no idea what these radio buttons represent since there is no title/label for these radio buttons. It simply shows two radio buttons with yes no value.

I do not have any fields like this in my memberedit_profile.html. How do I find out what these two fields are in the edit users in the ACP? How do I edit the fields in the ACP for users?

 Any thoughts or suggestions would be appreciated.

Thanks
Steve

8
Discussion & Troubleshooting / Show Email by Default
« on: March 02, 2007, 05:45:02 PM »
Hello

I want the show email as the default when a member registers (I use 4images for a dating site). Some where I read or was told to do this:



Quote
open register.php
Find
Code:

$user_showemail = (isset($HTTP_POST_VARS['user_showemail'])) ? intval($HTTP_POST_VARS['user_showemail']) : 0;


You can edit 0 to 1. Now the default is show email when new people register.



After the member is registered, his email shows by default. But when he updates his profile through the control panel, the email no longer shows.

How can I prevent the email from not showing after updating their profile?




Thanks
Steve

9
Discussion & Troubleshooting / Displaying data in details.html
« on: March 01, 2007, 02:27:31 PM »
I created a new field for the user when they register as follows:


Step 1. In db_field_definitions.php I added:

$additional_user_fields['user_job'] = array($lang['user_job'], "text", 0);



Step 2. In main.php I added:

$lang['user_job'] = "Your Work:";



Step 3. In register_form.html  and member_editprofile.html  I added:

 <tr>
    <td class="row2"><b>{lang_user_job} (optional) </b></td
     <td class="row2"><input type="text" name="user_job" size="30" value="{user_job}" class="input" /></td>
 </tr>



Step 4. In member_profile.html I added:

<tr>
   <td class="row2"><b>{lang_user_job}</b></td>
   <td class="row2">{user_job}</td>
 </tr>



Step 5. I updated the datbase and added to the 4images_users table: user_job - varchar(255)



Ok. the above 5 steps worked fine. I added some data and it displayed in member_profile.html...


The last step is where I had a problem.


Step 6:  I also added to details.html



<tr>
 <td valign="top" class="row1"><b>{lang_user_job}</b></td>
 <td valign="top" class="row1"><span class="row2">{user_job}</span></td>
 </tr>

However, the information does not show in details.html. Why? How do I get the same data from member_profile.html to show in details.html?


Thanks
Steve

10
Discussion & Troubleshooting / User change photo
« on: February 28, 2007, 08:16:48 PM »
I have my gallery set up so the user can upload his own photo. I also use the mod to limit users uploads.

When the user edits his photo, there is no option for him to replace the current photo with another photo/upload.  He can only edit his description, keywords, etc.

Is there a way for the user to edit or replace a photo? The user does not want to upload another photo, only replace the one they have on file with a new one. As it is now, they have to delete their current photo to upload a new one or  bug the admin if they want to change their photo.



Any help would be appreciated.

Thanks
Steve

11
Discussion & Troubleshooting / radio button
« on: February 26, 2007, 07:20:06 PM »
Hi

I'm trying to make radio buttons for male and female selection. I read the information in db_field_definitions.php, but it didn't provide enough information for me to understand how to create the buttons.

Next I looked at the example in the default template for making a user invisible or visible, but this didn't help me to adapt my radio button to an image field.

Here  is what I did:

1. Updated main.php with the following:

$lang['image_gender'] = "Your Gender:";
$lang['image_male'] = "Male";
$lang['image_female'] = "Female";


2. Added the image_gender to sql with tinyint(1) as the integer


3. Added  to db_field_definitions.php the following:

$additional_image_fields['image_gender'] = array($lang['image_gender'], "radio", 1);


3. Added the following to member_uploadform.html and member_editimage.html

 <tr>
            <td class="row2"><b>{lang_image_gender}</b></td>
            <td class="row2">

<input type="radio" name="image_gender" value="1"{image_gender_male}/>{lang_image_male}

<input type="radio" name="image_gender" value="0" {image_gender_female}/>{lang_image_female}
             
            </td>
          </tr>


When I went to test it, it did not work. All I saw was the words "Your Gender" but no male or female was provided (it was blank).

I didn't quite understand what the value=1 or value=0 meant. I also tried value=male and value=female, but the results where the same -- nothing shown.

I would appreciate it if anyone could tell me how to make this work?

I know others have  asked how to do radio buttons, but the answer was always to look at db_field_definitions.php. Again, I did read and I can make text fields and textarea fields with no problems,  but it did not provide me with enough info for me to understand how to do radio buttons.

Thanks in advance
Steve

12
Discussion & Troubleshooting / Relative Paths
« on: February 25, 2007, 05:40:47 PM »
I guess I don't understand what relative is. Hopefully someone can show me the way.

I have a folder in my includes directory called forum and a file called 4menu2.php. The path to that folder is:

http://www.asian-wife.net/include/fourm/4menu2.php.

I created a new template file called forum.html and included the following include command in the template.

<?php
include($_SERVER['DOCUMENT_ROOT']."/include/forum/4menu2.php");
?>

The forum.html file is located at: http://www.asian-wife.net/tempates/blue/forum.html

When I  execute my new template I use the following:

http://www.asian-wife.net/index.php?template=forum

I get the following errors:

Code: [Select]
Warning: Unknown(/home/asianlad/public_html/asian-wife-net/include/forum/4menu2.php): failed to open stream: No such file or directory in /home/asianlad/public_html/asian-wife-net/includes/template.php(101) : eval()'d code on line 81

Warning: Unknown(/home/asianlad/public_html/asian-wife-net/include/forum/4menu2.php): failed to open stream: No such file or directory in /home/asianlad/public_html/asian-wife-net/includes/template.php(101) : eval()'d code on line 81

Warning: (null)() [function.include]: Failed opening '/home/asianlad/public_html/asian-wife-net/include/forum/4menu2.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/asianlad/public_html/asian-wife-net/includes/template.php(101) : eval()'d code on line 81

I tried different paths with the include command but no success.


I'm sure it is because I don't understand relative paths. Boy, do a google on relative path and you get pages of elaboration that confuses you more than helps.

Hopefully someone can tell me what the correct relative path is for my include command. It would be appreciated.

Thanks
Steve


I did read Chris's mod at: http://www.4homepages.de/forum/index.php?topic=4295.msg17676#msg17676, but for dummies like me it didn't help since I didn't understand my relative path.

13
Discussion & Troubleshooting / Find Users without images
« on: February 23, 2007, 07:44:23 PM »
I searched with the keywords "users photo" but was not successful in finding the results I'm looking for. I'm hoping someone can help.

I run a penpal site. Registered users are required to upload a photo. After they register, I tell them they have a week to upload a photo or their user account will be deleted.

I realized after I made this rule, there is no easy was to find which registered users did not upload a photo. At least I could not find one.

Does someone have the knowledge to know how this can be done -- or provide the php code to do so? I want to be able to search my gallery for registered users who did not upload a photo.

I would appreciate any help.

Thanks
Steve

14
Hello

I'm using the  profile procedures in db_field_definitions.php to create custom fields. All went well except for image fields.

I created two image fields in db_field_definitions.php and added those fields in my 4images image table. Here are the fields I created:

$additional_image_fields['image_meet'] = array($lang['image_meet'], "textarea", 1);

$additional_image_fields['image_self'] = array($lang['image_self'], "textarea", 1);

In sql I added two columns in the 4images_images table as image_meet and image_self


Next, I went to the main.php and added the language code as follows:

$lang['image_meet'] = "Describe the type of person you would like to meet:";
$lang['image_self'] = "Describe yourself:";


Next, I went to register_form.html and added the codes as follow:

<tr>
  <td class="row2"><b>{lang_image_meet}</b></td>
  <td class="row2"><textarea name="image_meet" cols="50" rows="8" class="input">{image_meet}</textarea></td>
</tr>

<tr>
 <td class="row2"><b>{lang_image_self}</b></td>
 <td class="row2"><textarea name="image_self" cols="50" rows="8" class="input">{image_self}</textarea></td>
</tr>

Next I went to member_editprofile.html and added the following:

<tr>
 <td class="row2"><b>{lang_image_meet}</b></td>
 <td class="row2"><textarea name="image_meet" cols="50" rows="8" class="input">{image_meet}</textarea></td>
</tr>

<tr>
 <td class="row2"><b>{lang_image_self}</b></td>
 <td class="row2"><textarea name="image_self" cols="50" rows="8" class="input">{image_self}</textarea></td>
</tr>

Finally, I went to details.html and added the following:

<tr>
 <td valign="top" class="row1"><b>{lang_image_self}</b></td>
 <td valign="top" class="row1">{image_self}</td>
</tr>

<tr>
 <td valign="top" class="row1"><b>{lang_image_meet}</b></td>
 <td valign="top" class="row1">{image_meet}</td>
</tr>

I'm using 4images for a free dating site. I want the user to be able to type in his description and the type of person they would like to meet when they register or edit their profile through the control panel. The problem is when I type in the information when I register or update my profile  for these two fields, it does not save the info nor does it show up in the details.html template.


Would anyone be able to guide me on how to do this?  Maybe the following pictures will help explain what I want to do:






Thanks
Steve






15
Discussion & Troubleshooting / Radio Button Defaults
« on: February 21, 2007, 04:36:41 PM »
Hi

Hopefully someone can help me with the following.

I want to change the default radion button pre selections (yes or no)  in two areas: (1) user control panel and (2) admin area edit user.

Below are two pictures  showing where I'm talking about:



USER CONTROL PANEL





ADMIN AREA





I did search the forum. I found a few posts that talked about this but either I didn't understand or it wasn't what I wanted. I saw a few other posts that asked this question also, but no reply. Sorry, if it is posted elsewhere and I didn't see it.

This is the post I studied the most but it did not help me accomplish my goal (I think because I couldn't understand the instructions):

http://www.4homepages.de/forum/index.php?topic=12216.0

I think the answer may be there, but it is not clear on how and no matter what I tried I could not get the desired results.

Any help would be appreciated. I think others would be interested in clear instructions as well.

Thanks

steve

Pages: [1] 2 3
Post your comments here