Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - budduke

Pages: [1] 2 3 4 5 ... 34
1
Installation, Update & Configuration / Re: PHP 7 - installation not running!
« on: September 01, 2016, 01:55:22 AM »
I must state I am not part of the 4images development team but have been here for awhile now and I made a quick google search and it looks like MySQL is no longer an option in php version7.
One person on another board said that he went through his code and everywhere he saw MySQL he changed it to mysqli (notice the I on the end meaning improved) and after he made all those changes his PHP program began working again.
I cannot say that would be the case with 4images because I did not develop it. I have heard people say that the new mysqli has some flaws that crash their sites from time to time but not sure if any of the calls in 4images would cause that or not.
As technology get better developers are always trying to catch up or walk away. I would think if the developers where going to upgrade 4images to this new format then they would be testing it very hard before releasing the code.

Just like my facebook login mod stopped working because facebook updated their code. I am looking into trying to fix it so 4image users can continue to enjoy it.
Your lucky because I cannot get my host to upgrade to php 5.4 (They do not see it in the near future) yet alone php7

I hope I gave you a little help in seeing that php 7 is a whole different world that opened up in the coding.

2
Yes, Facebook changed their coding and stop supporting the code that my mod was written under. It turned off a couple of weeks ago.
I have had allot on my plate lately but I will try to look over my code to see what needs to be changed to get it working again.
If I can figure it out, I will post the changes in this area.

3
Mods & Plugins (Releases & Support) / Re: [MOD] Left Gallery QuickList
« on: August 22, 2014, 11:50:33 PM »
Hallo zusammen.
Super Mod. Läuft hervorragend. Nur wie kann man einstellen, dass nur die Hauptkategorien angezeigt werden?
Die Unterkategorien kann man eigentlich komplett ausblenden. Zumindest für meine Zwecke.
Desweiteren möchte ich den Schrifttyp in dem Mod verändern. Andere Größe, Fett etc. In der CSS des Mods geht das nicht und in der Style.css des Template ändert sich die Schrift für die ganze Seite


Grüße

To get only the main categories to be displayed, here is a quick modification to the code. The only problem is when you are down in the subfolders it does not highlight the main category that the subfolders are in. I do not see a fix for that...
in the functions.php file...
search for
Code: [Select]
$result= get_left_quicklist_bits($cat_id, $category_id, $depth + 1);Replace with...
Code: [Select]
//$result= get_left_quicklist_bits($cat_id, $category_id, $depth + 1);
and only the main categories should be displayed.

The font question. There are no font calls in the jquery.treeview.css file in the treeview so you will have to add them somehow. I do not know CSS well enough to guide you.

4
I would think it would integrate the same way the recaptcha did. I will look into it and see if I can get it to work.
I have to get my local server seen from the internet again. Something happened with my WAMP that now I cannot hit it from outside.
After I get that fixed then I will see how easy this keycaptcha will be and will let you know.

Update:
Here is what I came up with and it seems to work. I did notice it does not let the admin bypass the captcha code and I do not see a way around that so as long as you are OK with that here are the steps to make this thing work...

Step 1
Copy the "keycaptcha.php" file from their site to your /includes/ folder.
You will need to edit the top of the file putting in your userid and private key in the places they point out on their site.

Step 2
in your pageheader.php file...
Search for
Code: [Select]
$site_template->register_vars($array);insert AFTER
Code: [Select]
//keycaptcha
if (!class_exists('KeyCAPTCHA_CLASS')) {
// Replace '/home/path_to_keycaptcha_file/' with the real path to keycaptcha.php
include('includes/keycaptcha.php');
}
$kc_o = new KeyCAPTCHA_CLASS();

//end keycaptcha

search for...
Code: [Select]
  "url_captcha_image" => $site_sess->url(ROOT_PATH."captcha.php"),insert AFTER
Code: [Select]
  "keycaptcha" => $kc_o->render_js(),
in your includes/captcha_utils.php file
search for
Code: [Select]
$sess_code = trim($site_sess->get_session_var('captcha'));insert BEFORE
Code: [Select]
//keycaptcha
if (!class_exists('KeyCAPTCHA_CLASS')) {
// Replace '/home/path_to_keycaptcha_file/' with the real path to keycaptcha.php
include('includes/keycaptcha.php');
}
$kc_o = new KeyCAPTCHA_CLASS();
if ($kc_o->check_result($_POST['capcode'])) {
return true;
}
else {
// A visitor solved KeyCAPTCHA task incorrectly
// Add your code that will generate an error message
}
//end keycaptcha

Now the difficult part. In your templates, on the ones you want to add this keycaptcha code...
You need to place {keycaptcha} on the template where you are wanting it to be displayed...
also, on the template page you will see something like
Code: [Select]
<input type="hidden" name="action" value="postcomment" /> (value may be different)
insert BEFORE
Code: [Select]
<input type="hidden" name="capcode" id="capcode" value="false" />on the line like...
Code: [Select]
<input type="submit" name="postbutton" value="{lang_post_comment}" class="button" /> (may be different looking depending on page you are editing...
ADD
Code: [Select]
id="postbut" BEFORE the
Code: [Select]
class="button"the line would read...
Code: [Select]
<input type="submit" name="postbutton" value="{lang_post_comment}" id="postbut" class="button" />
and you should be done...
If you are having troubles getting it to work with certain templates, let me know which one and I may have time to take a look.








5
It has been a year since the above post and I am wondering the same thing. Is there still any developers working on 4images to bring it up to the modern web or have they walked away from it?

I have a couple of mods on the back burner (never seem to have time) but don't want to waist my time on a product that is not going to be upgraded.
When I mean new version, I do not mean fixes and streamlining some code. I mean bringing the whole system up to the modern web that everyone is using now.

Would love to here from anyone in the development part of the program. If you do not want to post on forum, I do read PM's

6
Discussion & Troubleshooting / Re: Any email problem ?
« on: March 19, 2014, 11:06:05 PM »
I don't know allot about the e-mail workings in PHP but I do remember that in order to get my site to work. I had to turn on "php mail" in my domain control panel for my domain before it would send any e-mails.
If you are getting an "OK" message on the email_test.php, Did you replace the 'anyemail@anydomain.com' with your e-mail address? When you did, did you receive an e-mail in your inbox from the test file?
Also, I noticed in your first post, it shows a /tmp/phpmail.log Can you post what it says in that log file?

7
The only two choices that I think you can do would be either...
1. update your current install to 1.7.11 but you would have to do each update between there which would be time consuming (you might be able to get away with going as far as 1.7.8 or 1.7.9 (I think that is when it supported 5.3)
or
2. you can install a fresh install of 1.7.11 and try to bring over all your mods/templates to the fresh install.

That is the reason my site is still running 1.7.7 (I am lazy in doing all the updates)

8
Not sure if this helps or not but when I clicked on "new images" on your site, I received this at the top of your page...
Quote
Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 149 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 149 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 149 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 149 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 149 Deprecated: Function ereg() is deprecated in /home/accounts_w/wikmail/public_html/includes/functions.php on line 101

Do you know if your provider changed your PHP version overnight? When I googled the above error it talks about PHP Version 5.3.0
If I remember correctly, all input from boxes are ran through that function during being processed.
this is what I found when I searched this site...
http://www.4homepages.de/forum/index.php?topic=30950.0

Not sure if that is much help or not...

9
@wallward,
There is annotation already built in by an earlier request...
if you install this mod
http://www.4homepages.de/forum/index.php?topic=13719.0
Then it will add the annotation as the resized images are created.

I do not think it will work with the on the fly because my mod does not even create the resized image until it is called in the download.php file
It may be possible using the popup template.
Let me know if the above mod does not give you what you are looking for and I may have time in the next few days to see what I can do with the popup template.

10
I using "[MOD] On-fly image annotation ( watermark)" and i Want use source image with watermark for download, how to this

Just glancing over the on-fly mod. It looks like it places a watermark on the thumbnail that is used on the details page, but when you download the actual image the watermark is removed.
This mod should work the same alongside my mod because my mod does not do anything with the thumbnail.
Not sure if that is your question or not.

11
I cant find the api key at the new facebook developers site !?

The 2.0 version does not use the api key, it is now changed to the "app secret" which is asterisk on the site till you press "show" at facebook's site under the dashboard of the app.

12
Thanks for the updates and your outstanding efforts, I've your mod installed on my gallery long ago, its V4 I believe as I've the grouped download.. is there a way to change how it looks like the attached image!
Thanks in advance.

I did not see an attached image on your post so I am assuming you are talking about the image on my first post with the different layouts?
You can change to the text links and image button links by changing the variable in the code in the global.php file at the beginning of the mod.
change
Code: [Select]
$multi_download_var['type'] = 0; //0=dropdown, 1=text links, 2=image linksChange the 0 to a 1 for text links or change the 0 to a 2 for the button links.

13
Hello Budduke

Well this Works:)
But this is not what is in my mind.
I see that in Delayed activation field i have to put date and time manually.
I want something different like if i choose delayed activation option then it scheduled
images in minutes or days from current day and time.
Like after 5 minutes or 60 minutes or after 2 days or 5 days intervals etc etc.
Is it Possible? It will be big help
Thanks

The reason I made the mod was because I upload a years worth of calendars and they get activated on the 1st of each of thier months so I do not have to remember to do it.
Your request looks doable but right now I am in Halloween mode. I put up a big halloween display every year. I will look at it when I get a chance.
Also, note on this mod there is a small bug. When you upload an image and want to activate it 2 weeks from now, it works, but the date on the image is todays date so it is not marked as new.
That will also be something I will change but now, I just go in and change the date on the image to the date I want it activated and then it is marked as new when it gets activated.

14
Are you wanting images that you upload to show up at a later date, like you just uploaded them?
I made this mod back awhile. I know it does not work with the current batch move edit mod that vano made but it might be what you are looking for...
http://www.4homepages.de/forum/index.php?topic=22354.msg122756#msg122756
You upload you images and tell it when you want it to become active. Not sure if that is your question or not.
I have not testing it on the current version of 4images but I am assuming it should work.

15
So you are wanting if a user is logged into facebook in a session and then they click on a link that comes to your site then the facebook comments show up. but if no facebook session is detected then nothing is displayed?
I think you can do it with a javascript call to see if you are logged in but not sure. If I get some free time I will see if it can be done. Facebook is pretty locked down on doing things their way and not much beyond that.

Pages: [1] 2 3 4 5 ... 34
Post your comments here