Author Topic: template error-detail won't display  (Read 6155 times)

0 Members and 1 Guest are viewing this topic.

Offline bigwave

  • Newbie
  • *
  • Posts: 36
  • stuck on the North Shore of Maui
    • View Profile
    • Maui Tropica
template error-detail won't display
« on: November 12, 2008, 04:28:31 AM »
Hello,

All of a sudden I've had this image break, when the detail should display I get this message:

Template Error: Couldn't open Template ./templates/default/comment_bit.html

I can see comment_bit.html is in the right place on the server and the images before and after this one display ok.  The thumbnail also shows in the category.  Any ideas?

Thanks,
Brian

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: template error-detail won't display
« Reply #1 on: November 12, 2008, 05:06:11 AM »
Check permissions on that file. Also make sure the template is not empty.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline bigwave

  • Newbie
  • *
  • Posts: 36
  • stuck on the North Shore of Maui
    • View Profile
    • Maui Tropica
Re: template error-detail won't display
« Reply #2 on: November 12, 2008, 10:44:49 PM »
Hello Vano,

Thanks for taking a look and welcome back--your sitemap is the reason I'm using 4images
http://www.maui-tropica.com/maui-tropica-gallery/sitemap.php

Anyway, I checked the permissions for the image and category_bit.html and they are the same as all the other files in their respective directories.  Also category_bit.html looks ok to me, at least I can view the source

Code: [Select]
<table border="0" cellspacing="0" cellpadding="0" width="166">

          <tr>
    <td>
  <a href="{cat_url}" class="maincat">{cat_name}</a>&nbsp;({num_images})
      {if cat_is_new}<sup class="new">{lang_new}</sup>{endif cat_is_new}
</td>
  </tr>
</table>

<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0 WIDTH="166">
<TR>
<TD>{if cat_description}<span class="smalltext">{cat_description}</span>{endif cat_description}</TD>
</TR>
<TR>

<TD class="subcatbl">{if sub_cats}{sub_cats}{endif sub_cats}</TD>
</TR>
</TABLE>



and is working on all the other images.

The broken image is here:
http://www.maui-tropica.com/maui-tropica-gallery/details.php?image_id=212

and I just found another one-same category:
http://www.maui-tropica.com/maui-tropica-gallery/details.php?image_id=335

Thanks again for any help.

Brian

Offline Nicky

  • Administrator
  • 4images Guru
  • *****
  • Posts: 3.195
    • View Profile
Re: template error-detail won't display
« Reply #3 on: November 12, 2008, 11:52:16 PM »
cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi

Offline bigwave

  • Newbie
  • *
  • Posts: 36
  • stuck on the North Shore of Maui
    • View Profile
    • Maui Tropica
Re: template error-detail won't display
« Reply #4 on: November 13, 2008, 01:19:51 AM »
Hello Nicky,

Thanks for noticing this for me!  Where could that file have gone?  I uploaded one from a backup and all of a sudden a comment shows up:

 
Code: [Select]
Some pages: prozac is about <i>prozac side effects</i>. soma drug interactions is about <i>soma drug interactions</i>. zithromax result site is about <i>zithromax result</i>. fluoxetine prozac site is about <i>fluoxetine prozac</i>. <alprazolam er is about <i>alprazolam er</i>. phentermine for sale is about <i>phentermine for sale</i>. fosamax tells about <i>fosamax</i>. acyclovir tells about <i>acyclovir</i>. fioricet tells about <i>fioricet</i>.
With a ton of links--looks like I've been broken into.  Any sugestions?

Thanks,

Brian

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: template error-detail won't display
« Reply #5 on: November 13, 2008, 02:21:53 AM »
Looks like simple spam...Unless you disallow guests posting comments, your only solution would be ban the spammers after they posted spam...
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline bigwave

  • Newbie
  • *
  • Posts: 36
  • stuck on the North Shore of Maui
    • View Profile
    • Maui Tropica
Re: template error-detail won't display
« Reply #6 on: November 13, 2008, 06:24:54 PM »
Hello,

Thanks, I'm a little slow--I guess I tried to disallow comments by taking out comment_bit.html but some spammers had slipped some rubbish in and the picture details page, where there were comments, wouldn't display and I didn't notice up till now.

Thanks again for all the help!

Brian

 

Post your comments here