Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - senloel

Pages: [1] 2
1
Discussion & Troubleshooting / Sicherheit bei MySQL-Anweisungen
« on: June 12, 2016, 02:33:14 PM »
Hallo allerseits,

ich hätte da mal eine allgemeinere Frage zu 4images und der Absicherung gegenüber z.B. SQL-Injections.
Inwiefern ist das Ausführen einer Anweisung über
$site_db->query($sql);
abgesichert?

Ist es notwendig, die z.B. mit GET übergebenen Variablen noch mit Funktionen wie
mysqli_real_escape_string
zu bereinigen oder wird das "von Haus aus" schon erledigt beim Benutzen des Codes oben?

Freue mich auf Antworten ;)

Grüße
Patrick

2
Programming / Variable auf Bindestrich prüfen
« on: August 05, 2015, 06:50:05 PM »
Hi,

ich habe ein kleines Problemchen:
Eine Variable soll auf einen Bindestrich überprüft werden. Ist dieser nicht vorhanden, wird eine Meldung ausgegeben.

if ($image_row['image_name'] == str_replace("-"""$image_row['image_name']))
	
	
	
	
	
	
$check_format_1 'Meldung'; }


Nun klappt dies leider nicht sehr zuverlässig.
Bei folgenden Inhalten ist der Bindestrich anscheinend nicht vorhanden:

ITL Import Transport Logistik

oder auch

ES 64 F4-995.

Das Ersetzen des "-" durch "-" im str_replace hat leider auch keinen Erfolg gebracht.

Hat jemand eine Idee?

Danke und Grüße,
Patrick

3
Discussion & Troubleshooting / Wordmatch und Wordlist-Table: Nutzen?
« on: March 27, 2015, 09:28:55 PM »
Hallo,

mir ist gerade eine eher allgemeinere Frage in den Sinn gekommen, als ich ein SQL-Backup erstellt habe:
Die Wordlist bzw. Wordmatch-Tabellen sind im Vergleich sehr groß, warum benutzt man diese überhaupt?
Wäre es nicht einfacher, bei der Suche einfach auf die Images-Table zuzugreifen?

Die Gründe dafür würden mich sehr interessieren, schließlich muss ein Gedankengang dahinter sein.

Grüße,
Patrick

4
Discussion & Troubleshooting / Suchfunktion nicht mehr möglich
« on: August 27, 2014, 09:23:17 PM »
Hallo,

ich habe leider seit einigen Tagen ein Problem und weiß nicht, woher das kommt:

Man kann über die Suchfunktion nicht mehr nach zusätzlichen image fields suchen.
Das komische an der Geschichte ist: In der lokalen Version, die die identischen Dateien enthält, funktioniert es reibungslos.

Hat vielleicht jemand eine Idee, an was das liegen könnte?

Vielen Dank und Grüße,
Patrick

5
Add-on for: http://www.4homepages.de/forum/index.php?topic=8286.0

What?
This MOD will delete inactive pictures automatically after some days.

How?
Once somebody has opened the index.php (guest, admin, etc.), the code will check if there are inactive images older than X days.

Let's start:
 :arrow: Please make a backup of your index.php

1.) Open index.php

2.) Find
//-----------------------------------------------------
//--- SEO variables -----------------------------------
//-----------------------------------------------------
    
$site_template->register_vars(array(
      
"detail_meta_description"   => $lang['meta_description'],
      
"detail_meta_keywords"      => $lang['meta_keywords']
      ));


add below:

//-----------------------------------------------------
//--- Delete inactive pictures ------------------------
//-----------------------------------------------------

$inactive_cutoff time() - 60 60 24 XX;

$sql2 ="SELECT i.image_id, i.cat_id, i.image_date, i.image_active, i.image_media_file, i.image_thumb_file FROM ".IMAGES_TABLE." i WHERE i.image_date <= '$inactive_cutoff' and i.image_active ='0'";
$result2 $site_db->query($sql2);

while (
$row $site_db->fetch_array($result2)){

	
$path "./data/media/".$row['cat_id']."/".$row['image_media_file']."";
	
$path_thumbs "./data/thumbnails/".$row['cat_id']."/".$row['image_thumb_file']."";

	
@
unlink($path);
	
@
unlink($path_thumbs);
	

	
$sql "DELETE FROM ".IMAGES_TABLE."
	
WHERE image_id = "
.$row['image_id']."";
  
$site_db->query($sql);

};


3.) Replace XX with a number after how many days the inactive pictures should be deleted.
Example: Inactive pictures should be deleted after 6 days: Replace XX with 6


4.) Enjoy! ;)

Regards,
Patrick

6
Discussion & Troubleshooting / Javascript Openwindow komplett entfernen
« on: January 04, 2014, 11:20:15 AM »
Hallo und erstmal frohes Neues!

Ich habe folgendes Problem:

Momentan ist ja javascript aktiv und öffnet daher insgesamt nur ein neues Fenster in der Galerie.
Klickt man dann auf ein anderes Bild, das ebenfalls mit target="blank" versehen ist, öffnet sich dieses im bereits zum ersten Mal geöffnetem Fenster.

Wie kann man diese Funktion komplett abschalten? Sodass man mehrere Bilder in neuen Fenstern öffnen kann?

Vielen Dank für jede Hilfe!

Grüße,
Patrick

7
Hey,

this MOD adds checkboxes to the validation area. The ticked boxes will be entered into the textarea.

!! This MOD requires Email image validation results to the user v2 !!

Let's start:

Files to edit:
admin/validateimages.php
lang/yourlang/admin.php

1.1) Open admin/validateimages.php and find

<td class=\"tableseparator\">".$lang['validate_msg']."</td>\n

Add below:

<td class=\"tableseparator\">".$lang['validate_reasons']."</td>\n

1.2) Find:

      echo "<td>".(($image_row['user_id'] != GUEST) ? "<textarea name=\"msg_list[".$image_row['image_id']."]\" id=\"msg\" rows=\"3\" cols=\"57\">".((isset($HTTP_POST_VARS['msg_list'][$image_row['image_id']])) ? stripslashes($HTTP_POST_VARS['msg_list'][$image_row['image_id']]) : "")."</textarea>" "")."</td>";

Add below:

	
  echo 
"<script>
             // Erwartet die ID der Textarea als ersten und den einzufügenden Text als zweiten Parameter
                function insertHTML(elementID, content) {
                    // Fügt über innerHTML den als zweiten Parameter übergebenen Text in die Textarea ein
                        document.getElementById(elementID).innerHTML += content;
                }
            </script>"
;


To insert the checkboxes, add below:

<td style=\"background-color:#F5F5F5; color:#0F5475;\">
<input type=\"checkbox\" onclick=\"insertHTML('msg["
.$image_row['image_id']."]','Reason1')\" value=\"Reason1\" > Reason1<br>
<input type=\"checkbox\" onclick=\"insertHTML('msg["
.$image_row['image_id']."]','Reason2')\" value=\"Reason2\" > Reason2
</td>\n


2.1) Open lang/yourlang/admin.php and search for ?>

Add above closing ?>:

$lang['validate_reasons'] = "Reasons";

3.1) Have fun :!: ;)


See also: http://www.cwcity.de/community/board/showthread_6_4_44552-In-javascript-onclick-Variable-benutzen.html

Regards,
Patrick

8
Discussion & Troubleshooting / if (action == submit) ???
« on: November 10, 2013, 06:53:09 PM »
Hey,

hab ne kurze Frage:

Beim Submit-Klicken im Validation area soll eine sql-Abfrage ausgeführt werden, die in einer if-Bedingnung steht.

Nur: Wie schreibt man die Bedingnung?

Mit
if ( action == Submit ) {
funzt es nicht.

Ist wahrscheinlich ganz einfach, deshalb bitte nicht aufregen, PHP ist für mich manchmal noch Neuland ;)

Grüße und Danke,
Patrick

9
Discussion & Troubleshooting / Link für Suche mit Keyword + User
« on: October 28, 2013, 12:25:36 PM »
Hey,

kurze Frage:

Wie lautet der Link um nach einem keyword und gleichzeitig nach einem User zu suchen, d.h. das nur das Bild vom entsprechenden User angezeigt wird.

Beispiel:

search.php?search_keywords='BR 1016 014'&search_user='test'

Danke und Grüße,
Patrick

10
Puhhh, das sieht wieder nach einem größeren Problem aus...

Heute Mittag den PM v2-MOD installiert und heute Abend ausprobiert.
Ich denke, das ist jedoch ein generelles Problem, deshalb poste ich es mal hier.

Beim Absenden einer PN erscheint folgende Fehlermeldung:

Warningfgets() expects parameter 1 to be resourceboolean given in /home/www/cwcity/hosting/t/r/train-photos/htdocs/includes/email.php on line 186

Email Error
Invalid mail server response (service not ready?): 


Davor kam noch eine größere Fehlermeldung:

Warningfsockopen() [function.fsockopen]: unable to connect to smtp.strato.de:25 (Connection timed outin /home/www/cwcity/hosting/t/r/train-photos/htdocs/includes/email.php on line 185

Warning
fgets() expects parameter 1 to be resourceboolean given in /home/www/cwcity/hosting/t/r/train-photos/htdocs/includes/email.php on line 186

Email Error
Invalid mail server response (service not ready?):


Diese konnte ich aber durch das einfügen eins @ beheben.

Hier mal die entsprechende Stelle aus der email.php (Zeile 185+186):

    $fp = @fsockopen($config['smtp_host'], 25);
    
$result fgets($fp1024);


Kann mir da vielleicht jemand helfen?

Danke und Grüße,
Patrick

// EDIT: ///

Hat sich erledigt, nachdem ich (bin vor 2 Tagen mit der Homepage auf einen neuen Server umgezogen) im Admin Bereich der alten HP den SMTP-Versand ausgeschaltet habe.



11
Hey,

I have a little problem:
Ich habe ein kleines Problem:

When Users register in our website, they have to cklick a link in the registration email to activate their account.
Wenn sich User registrieren in unserer Website, müssen diese einen Link in der Activation-Mail klicken damit der Account aktiv wird.

But after activating they still can't log-in.
Aber nach dem Aktivieren können sie sich immernoch nicht einloggen.

If I edit their password for example, they can log-in.
Wenn ich jedoch deren Passwort ändere z.B., können sie sich plötzlich einloggen.

Can somebody help me please?
Kann mir vielleicht jemand helfen?

Thank you and Regards,
Patrick

12
Tutorials / [TUT] Add a url-variable like {url_yourlink}
« on: September 16, 2013, 06:52:38 PM »
Hey,

as you maybe know, you can add different types of variables in your template files.
One type are the url-Variables.

If you want to add a link to different sites, it's useful to write a variable instead of the whole link.
It's much easier to edit this link, if something has changed. You only have to change the link in one file instead in every template file where you added the link.

This MOD will show you how to add this Variable.

Step 1  :arrow: Open the template files where you want to add a link.

Step 2  :arrow: Add the following anywhere to show the link:

<a href="{url_yourlink}">Yourlink-text</a>

Step 3.1  :arrow: Open includes/page_header.php and search:

  "url_new_images" => $site_sess->url(ROOT_PATH."search.php?search_new_images=1"),

add below:

  "url_yourlink" => $site_sess->url(ROOT_PATH."yourlink-url"),

  Step 3.2  :arrow: How to add the link url:
If you want to link to a file which is in your 4images directory:

Use   "url_yourlink" => $site_sess->url(ROOT_PATH."yourlink-url"),
 
for example:

  "url_yourlink" => $site_sess->url(ROOT_PATH."search.php"),

or with subfolders:

  "url_yourlink" => $site_sess->url(ROOT_PATH."admin/index.php"),


That was it already ;)

Regards,
Patrick

13
Hey,

this is just a little Tutorial (MOD) which explains how to add a new table in your frontpage.
It will look like the who's online-table and you can fill it with your content.


Let's start.
Please make a backup first!

Step 1 :arrow: open home.html in your template folder (your-website/templates/your-template/home.html)

Step 2 :arrow: add this whereever you want:


                 
<table width="100%" border="0" cellspacing="0" cellpadding="0">
                    <
tr>
                      <
td class="head1">
                        <
table width="100%" border="0" cellspacing="0" cellpadding="4">
                          <
tr>
                            <
td class="head1" valign="top">{lang_your_headline}</td>
                          </
tr>
                        </
table>
                      </
td>
                    </
tr>
                    <
tr>
                      <
td class="head1">
                       
yourcontent
                      
</td>
                    </
tr>
                  </
table><br>


Step 3 :arrow: replace yourcontent with a text, image or whatever ;)

Step 4 :arrow: open main.php in your language folder (your-website/lang/your-language/main.php)

Step 5 :arrow: find
?>

and add this above:

$lang['your_headline'] = "Name of your headline";

To change the name of the headline, replace Name of your headline with your text.


Examples:
If you want to add the new table below the categories section:

Example Step 6 :arrow: find

                            
<td class="row2" valign="top">{categories}</td>
                          </
tr>
                         </
table>
                        </
td>
                      </
tr>
                    </
table>


and add the same as explained in Step 2 below.

That's it!


Regards,
Patrick


14
Hi,

the idea came from here: http://www.4homepages.de/forum/index.php?topic=31322.0


Let's start:

Step 1 :arrow: Open home.html in your template folder

Step 2 :arrow: find this section:
                          <tr>
                            <
td class="row2" valign="top">{categories}</td>
                          </
tr>


Step 3 :arrow: add after {categories}...
<br><a href="http://yourlink">yourlink-Text</a>

Step 4 :arrow: ...so that it looks like this:
                          <tr>
                            <
td class="row2" valign="top">{categories}<br><a href="http://yourlink">yourlink-Text</a></td>
                          </
tr>


Step 5 :arrow: Replace yourlink with the link


If you want to add more than one link:

 :arrow: do Steps 1-5

Step 6: :arrow: after
{categories}<br><a href="http://yourlink">yourlink-Text</a>

add this for a second time...
<br><a href="http://yourlink">yourlink-Text</a>

 :arrow: ...so that it looks like this:
                          <tr>
                            <
td class="row2" valign="top">{categories}<br><a href="http://yourlink">yourlink-Text</a><br><a href="http://yourlink">yourlink-Text</a></td>
                          </
tr>



If you want to add a button instaed the normal link text:

 :arrow: do Steps 1-5

Step 8: :arrow: add after:
<a href="http://yourlink">

this...
<img src="http://yourbutton-url.jpg" alt="Link-Text">

...so that it looks like this:
                           <tr>
                            <
td class="row2" valign="top">{categories}<br><a href="http://yourlink"><img src="http://yourbutton-url.jpg" alt="Link-Text"></a></td>
                          </
tr>


Step 9: :arrow: Remember to delete yourlink-Text here:
<a href="http://yourlink">yourlink-Text</a>


Have fun!

Patrick

15
Discussion & Troubleshooting / Datum Dropdown: Problem mit Code
« on: August 16, 2013, 10:29:19 AM »
Hey,

ich habe mir Daten-Dropdown-Felder gebastelt und in mein Uploadformular eingefügt.
Jedoch wird nur immer der erste Wert genommen (also nur der Tag). Monat und Jahr werden nicht in die Datenbank eingetragen + ausgegeben.

Wo ist mein Denkfehler?

Hier der Code:

<select width="15" name="image_date_taken" value="{image_date_taken}">
	
<
option value="1">1
	
<
option value="2">2
	
<
option value="3">3
	
<
option value="4">4
	
<
option value="5">5
	
<
option value="6">6
	
<
option value="7">7
	
<
option value="8">8
	
<
option value="9">9
	
<
option value="10">10
	
<
option value="11">11
	
<
option value="12">12
	
<
option value="13">13
	
<
option value="14">14
	
<
option value="15">15
	
<
option value="16">16
	
<
option value="17">17
	
<
option value="18">18
	
<
option value="19">19
	
<
option value="20">20
	
<
option value="21">21
	
<
option value="22">22
	
<
option value="23">23
	
<
option value="24">24
	
<
option value="25">25
	
<
option value="26">26
	
<
option value="27">27
	
<
option value="28">28
	
<
option value="29">29
	
<
option value="30">30
	
<
option value="31">31
</select>

<
select name="image_date_taken_month" width="15" value="{image_date_taken}">
	
<
option value="1">January,
	
<
option value="2">February,
	
<
option value="3">March,
	
<
option value="4">April,
	
<
option value="5">May,
	
<
option value="6">June,
	
<
option value="7">July,
	
<
option value="8">August,
	
<
option value="9">September,
	
<
option value="10">October,
	
<
option value="11">November,
	
<
option value="12">December,
</
select>
<
select name="image_date_taken_year" width="15" value="{image_date_taken}">
	
<
option value="2013">2013
	
<
option value="2012">2012
	
<
option value="2011">2011
	

        <
option value="2010">2010
	
<
option value="2009">2009
	
<
option value="2008">2008
	
<
option value="2007">2007
	
<
option value="2006">2006
	
<
option value="2005">2005
	
<
option value="2004">2004
	
<
option value="2003">2003
	
<
option value="2002">2002
	
<
option value="2001">2001
	
<
option value="2000">2000
	
<
option value="1999">1999


</select>


Danke schonmal für eure Hilfe.
(wenn das dann klappt, kann ich einen MOD daraus machen)

Grüße,
Patrick

Pages: [1] 2
Post your comments here