Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TMO

Pages: [1]
1
hi,
 for some reason i get an error message, trying to plugin a picture into a new category.

Fatal error: Cannot break/continue 1 level in /home/www/web4161/html/swb9001/db/includes/template.php(101) : eval()'d code on line 97

if i delete this image, category page work well again without any picture of course.

I try to solve this problem looking for Tags Errors, but without success, may anyone help me?

Thanks
TMO

2
ICh kann im Bildermanager ein Bild auswählen und dann über den Button "move" in eine andere Kategorie schieben.

ICh habe auch schon versucht ein neues Bild hochzuladen, oder über das hier irgendwo angebotene ZIP Upload Plugin.

Sobald eine neue Kategorie ein Bild enhält ist diese Seite nicht mehr aufruftbar, der Error 404 sagt mir ja aus, das die Seite, die ich versuche aufzurufen nicht existiert.

Wenn jetzt alle Bilder wieder aus der cat raus sind, geht alles wieder ohne probleme, kann das evtl an der Datenbank liegen, an der temp datenbank, wie genau funktionert diese?

3
German:
Hallo, ich habe vor über einem JAhr eine 4image Gallery für einen Freund aufgsetzt, daran richtig viel umgebaut und auch ergänzt und trotz alledem klappte es damals ohne Probleme.
Jetzt habe ich ohne das ich wieder daran rumgeschraub habe plötzlich folgende Probleme:
Wenn ich eine neue Kategorie erzeuge geht diese ohne Probleme, sobald ich aber ein Bilöd in diese Kategorie schiebe ist sie nicht mehr aufzurufen. Ich bekomme einen 404 Error des Providers. Sobald ich wieder alle Bilder aus der Kategorie genommen habe geht alles wieder.

Das PRoblem hatte ich vor etwa 1 Monat schonmal, doch urplötzlich ging dann alles wieder normal und jetzt schon wieder dieser Fehler.
Weiß jemand, an welcher Stelle ich bei diesen Symtomen suchen muss? Wie funktioniert technisch das Verschieben der Bilder, was passiert da.


English

i have started a 4images gallery last year, modified a lot but finnaly i got now errors. But today there´s a problem:
If if try start a new category, nothing went worng, but when i try to move an image from an other cat to this new one, i get an error message "code 404"
After that new image will be removed, all works perfect.

Does anyone know how to solve that problem or where to search for?
thanks

4
Hallo
gibt es einen Trick um an das zukommen, was in einem Feld definiert ist, dh ich brauche in der thumbnail_bit das was in {thumbnail} aktuell drinsteht
Warum? Ich habe die Thumbnailansicht und die datenbank um iptc infos erweitert, die nicht nur auf der Detailsseite sondern auch der Übrsichtsseite angezeigt werden sollen.
Default zeigt 4images ja eine Liste mit allen Bilder der ausgewählten Kategorie an, in der thumbnail_bit.html habe ich definiert, das zum jeweiligen Bild rechts deneben {image_autor} angezeigt wird, das funktioniert auch prima, woher auch immer er weiß welches Bild gerade angezeigt wird und in welcher Zeile der Datenbank er den Autor suchen soll...

Ich möchte nun den Wert der in {image_autor} steht auslesen, um ihn auf einer Externen Seiten verwenden zukönnen, dazu müsste ich erstmal in php sowas aller $variable={image_autor} machen, was leider nicht geht.
Wie komme ich also an dern Wert dran?

Hi, i would like to get the value with is in a field like {thumbnail}. For example in thumbnail_bit.html. I thought its quite simple, easy give any variable the value of eg {thumbnail} ($var={thumbnail})
But its not so easy, but how can i get it?
thx/Danke

5
Hallo Zusammen, in der Hoffnung im richtigen Forum gelandet zusein, hier meine Frage.

Ich möchte gerne im Adminbereich eine Ergänzung haben, und zwar in der Tabelle, die die Suchergebnisse bei der Bildersuche ausgibt.  Über "Bilder bearbeiten" kann ich ja nach Bildern suchen, klicke dann auf Suchen wird eine Tabelle ausgegeben, diese Tabelle soll neben image_name username usw. auch weitere Spalten aus der Datenbanktabelle 4images_images enthalten. Diese Neue Spalte soll natürlich selbstverständlich auch suchbar sein.

Ich habe bisjetzt keine PRobleme gehabt die weiteren DB-Felder durch  "additional_image_fields" bearbeitbar zumachen, aber ich blicke durch das System nicht durch um entsprechend in der admin/images.php Änderungen durchführen zukönnen. Villeicht kann mir jemand sagen wo ich was ändern muss, damit meine Wünsche Wahr werden.

Hi,
can anyone help me to put some more columns into the table which is given by 4images, if you want to search for images, edit them in backend. (if you click on "change images" then click on Start search (page bottom))
iE i would like to add a column (a searchable column) with some metatags inside.

Thanks for your help

ps: year i know my problem is quite better to understand in german, but my english is absolutly not good enough to write it in english
 

6
Ich den Mod auch super installiert bekommen, bekomme aber in der Karte, die auch die User zusehen bekommen "Gelände, Relief +, un d Relief -" angezeigt. Klicke ich drauf muss ich ein passwort angeben, was ich nicht kenne, raus komme ich nurnoch über den taskmanger und den browser beenden.
Könnte mir mal jemand erklären was das genau ist und wie man die Passwortabfrage verhindert.

Lösen kann man es ja so wie ich das sehe in der details.php, fragt sich nur was da?

Würde mich über Antworten freuen

gruß
Thorben

EDIT: FEhler gelöst. Die Adresse http://srtm.in-ulm.de/ im Quelltext der details.php ist Passwortgeschützt, diese Adresse muss getauscht werden gegen http://www.maps-for-free.com/, dann klappst auch!

7
Mhm, irgendwie fühle ich mich nicht ganz vollgenommen....

Selbstverständlich wird ein datensatz erzeugt, doch gefüllt wird dieser Datensatz durch die checkimages nur mit dem was 4iamges standardmäßig in die datenbank einfüllt. Die Spalten die dieser MOD nachträglich hinzugefügt hat bleiben leer, demzufolge sind auch die Bilderinformationen verfügbar, das Bild wird angezeigt, aber die Felder wie images_Credits etc. bekommen keine Daten aus dem IPTC Header zugewiesen. Diese Felder werden erst gefüllt wenn ich die rebuildindex ausgeführt habe, was laut anmeldung eigendlich nur für Bilder notwendig seien sollte, die vor der Installation des Mods hinzugekommen sind, oder?

Es amcht auf mich den eindruck, als würde die checkimages bei mir nicht richtig funktionieren.

8
Naja ich habe die bilder mit XNview getaggt, mit verschiedenen anderen Softwaren habe ich es überprüft die daten sind vorhanden.
Lade ich jetzt ein Bild über den Backend Upload hoch läuft ja die checkimages (ich habe die datei aus dem eingangspost genommen und meine alte überschrieben) über die Bilder.
Gucke ich nach erfolgreichem Upload in die Datenbanlk so ist kein Datensatz hinzugekommen.
Wenn ich jetzt dieses Bild auswählen und "bearbeite" bekomme ich die Maske zum upload vom großen und dem kleinen Bild, sowie alle IPTC Felder und alle Standardfelder.

Neben dem Standardfeld "Bildbeschreibung" ist ein Button "IPTC Bildbeschreibung", ich gkaube das ist bei Version 1.7.6 ebenfalls Standard. Klicke ich darauf wird die Bildbeschreibung aus dem IPTC Header eingefügt.

Die Felder darunter (die die durch diesen Mod hinzugefügt wurden nehme ich an) sind leer.

Führe ich jetzt die rebuild _iptcindex Datei aus fügt er alle IPTC Daten aus dem Bild der Datenbank hinzu, jetzt sind alle Daten vorhanden, aber auch damit wird ein neuer Datensatz erzeugt, nicht ein ggF schon vorhandener überschrieben, wäre schön wenn das ginge, zur Not lasse ich einfach nach jedem Upload die rebuild _iptcindex drüber laufen

@Rembrand: Sorry das ich mich da ungenau ausgedrückt habe.
Danke für deine Hilfe

9
Mhm, nicht?

Ich meine die Infos sind ja vorhanden, sonst könnte sie die rebuildindex ja nicht später in die Datenbank eintragen, oder?
 Wenn ich das Bild bearbeite kann ich IPTC Bildbeschreibung als Bildbeschreibung klicken.

10
Hallo zusammen,
wie schon viele vor mir habe ich eine Frage zu der Funktion random Image, sie wurde in der form aber so noch nicht gestellt, habe alles durchgelsen:

Zunächst einmal habe ich auf einen Tipp hier aus dem Forum hin die {random_image} folgendermaßen verändert:
Quote
<img src="{media_src}" border="0" alt="{image_name}" style="max-width: 400px; width: expression(this.width > 400 ? 400: true);">
So erreiche ich ein größeres Thumbnailbild, bzw ein Zufallsbild was größer als die Standardvariante ist, aber kleiner als das "große Bild"

Zu meinem Problem: Ich möchte gerne auf der Cat-Seite jeweils vor den ganzen kleinen thumbs ein Zufallsbild (Größe: 400px (s.o.) einfügen, dieses Bild soll aber aus der jeweiligen Cat stammen und da beginnen die Probleme...
ICh schaffe es dort ein Zufallsbild einzublenden, aber dieses ist nicht immer aus der jeweiligen CAT.
JEtzt gibt es ja die Möglichkeit des random_cat_image, leider funktiniert das aber überhaupt nicht, denn dann erzeugt er (bei entsprechender Änderung der  "constants.php") nur ein "X-Bild", soll heißen er fügt ein bild ein, kann dessen URL aber nicht finden.

Wer weiß wie man dieses Problem lösen kann?

ENGLISCH:
Hi, i need some help with random images. I like to have random images on my categories-page, 4images randowm generator should take them from only one cat, exactly those one, with is actually activaed.
For an exemple: The visitor is on the categories page with id=5, so on this cat page should an image, and choosen from that cat only.
Any changing in constants.php  didn´t help 


Grüße greets
TMO

11
Hallo zusammen,
nachdem jetzt endlich die Aktivierungsemail angekommen ist kann ich auch meinen senf dazugeben. Dieser MOD ist genial, funktinoert bei mir aber nur zu 50%. Meine zurzeit noch lokal installierte Gallery soll ausschließlich über das Backend bedient werden, dh ich lade auch so die Bilder hoch. Leider werden dabei keinerlei IPTC Infos ausgelesen, erst wenn ich die Reachindedex.php ausführt findet er im Bild die IPTC Infos und trägt sie in dei Datenbank ein. Ich habe die Anleitung genau befolgt, hat jemand eine Idee waran es liegen könnte?

Das ganze ist eine Gallery für einen Kollegen der damit die Fahrzeugflotte eines Unternehmens dokumentieren will. Er hat eien Liste mit allen Fahrzeugen mit Infos wie Kennzeichen Fahrzeugtyp etc. Diese Infos liegen in den Bilder in den IPTC infos, jedoch hat er nicht von allen Fahrzeugen fotos, ergo trage ich die Liste(Tabelle mit den daten) manuell in die DB eiin und nutze die Felder die dieser Mod erzeugt. Wird jetzt ein Bild hochgeladen, das zB als Fahrzeugnummer einen Wert hat, zu dem schon ein Datensatz vorliegt soll optimalerweise dieser Eintrag überschrieben werden und nicht ein identischer Datensatz erzeugt werden.

Da ich mir mit mysql/php noch etwas schwer tue  jetzt die frage an euch, wie dazu die checkimages und rebuildindex umgestellt werden müssten, wenn überhaupt?

Ich freue mich auf euere Antworten zu meinem Einstandsthread^^
gruß
Thorben

Pages: [1]
Post your comments here