Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Bommel

Pages: [1] 2 3 4 5 ... 8
1
Installation, Update & Configuration / Re: Rahmen der thumb bilder Problem
« on: February 12, 2010, 08:44:45 PM »
Hast du es auch nur mit Angabe der Höhe versucht? Also "width=200" komplett entfernt. Ähnliches Phänomen tauchte auch bei mir auf und nach dieser Änderung war alles OK.

2
Installation, Update & Configuration / Re: Rahmen der thumb bilder Problem
« on: February 12, 2010, 08:19:16 PM »
Hallo MIB1983,

ändere in deiner thumbnail_bit.html die Höhe auf den Wert, den du im ACP unter "Maximale Höhe der Bilder in Pixel" eingestellt hast. Dann sollte sowohl das Hoch- als auch Querformat gleich ausfallen.

Zur Zeit steht er bei dir im HTML auf 200x200.

3
Hallo Allround,

diese Seite gibt es auch deutsch-sprachig: http://de.php.net/manual/de/function.ereg.php

4
Español / Castellano / Re: [MOD] Incorporar Moderadores en la galería
« on: February 12, 2010, 12:18:59 PM »
Hallo sumale.nin,

das ist der News-MOD, den ich verwendet habe: http://www.4homepages.de/forum/index.php?topic=9064.msg42316#msg42316

Um Moderatoren bearbeiten zu können, müssen diese erst einmal festgelegt werden. Das geschieht, wie du schon festgestellt hast, in dem du dem Benutzer den Level eines Moderators erteilst. Erst danach befindet sich der Benutzer im Menü "Moderatoren bearbeiten" und du kannst dann im Anschluss die verschiedenen Berechtigungen setzen.

Funktionieren tut das ganze einwandfrei. Bin aber noch nicht ganz zufrieden, denn es soll auch möglich gemacht werden, dass Moderatoren auf dieses Plugin Zugriff bekommen: http://www.4homepages.de/forum/index.php?topic=7066.msg31011#msg31011.

Bin da noch nicht so ganz dahinter gestiegen und es eilt auch nicht, da die eigentliche Seite auf der das ganze Moderatoren-System dann laufen soll noch nicht online ist. Ich benutze aber meine private Seite, um es vorab zu testen und herzurichten.

Autsch... Post 111... ich gebe jetzt aber bestimmt keine Runde aus. Karneval ist erst am Montag. ;)

5
Chit Chat / Re: 4Images Aktualisierung - Erfahrungswerte gesucht!
« on: February 10, 2010, 05:19:42 PM »
Hallo mawenzi,

...3. Zu beachten ist nur, das man alle in der alten Version eingebauten Modifikationen in die neue Version übernimmt (WinMerge -> copy -> paste) ...

hier stellt sich für einen Anfänger folgendes Problem - woher weiß er, welches die Modifikationen und welches die Änderungen in 4Images selbst sind? Jetzt wirst du sicherlich einwenden, dass man so etwas wissen sollte, schließlich hat er ja die Modifikationen selbst eingebaut. Aber, ich weiß aus eigener Erfahrung, dass einige Modifikationen ohne entsprechende Anmerkungen existieren und so manche Anfänger dass einfach einbauen. Ich selbst habe mir das mittlerweile abgewöhnt und fehlende Anmerkungen zu den geänderten Stellen selbst eingefügt, damit ich später weiß, was wozu gehört.

Wie kann ein Anfänger dann bei diesem Problem nachträglich am besten verfahren, damit nicht irrtümlich eine Aktualisierung verändert wird?

6
Chit Chat / 4Images Aktualisierung - Erfahrungswerte gesucht!
« on: February 10, 2010, 04:10:51 PM »
Hallo allerseits,

auch wenn es aktuell (noch) nicht nötig ist, irgendwann wird es aber soweit sein. Ich suche eure Erfahrungswerte bezüglich der Aktualisierung von 4Images mit bereits eingebauten Modifikationen.

  • Wie geht ihr dabei vor?
  • Welche zusätzliche Software benutzt ihr dazu?
  • Was muss beachtet werden?

Fragen über Fragen, die für einen Neuling von Interesse aber für alteingesessene Anwender kein Problem sind. Ich bin gespannt auf eure Anregungen, Hinweise und Erfahrungsberichte.

9
Discussion & Troubleshooting / Re: Benutzerdaten-Seite aufteilen?
« on: February 07, 2010, 04:17:19 AM »
Hallo Sumale.nin,

ich denke, das nicht die Länge dass Problem darstellt. Vielmehr ist es die Tatsache, dass ich im Grunde genommen kein Profi bin. Aber vielleicht sollte ich mal diesen Schritt wagen und es einfach machen. Immer im Vertrauen darauf, dass hier Profis ein Auge darauf haben und im Falle von Fehlern die Keule schwingen.  :lol:

Habe etwas Geduld, ich bemühe mich. ;)

10
Mods & Plugins (Requests & Discussions) / Re: MOD PhotoBlog
« on: February 07, 2010, 03:12:09 AM »
Hallo rinaldos,

...zu Punkt 2: Das kann ich bei mir nicht nachvollziehen :-( Der Fehler ist da, das kann ich bestätigen, aber auch nur in der 4images Serien Installation. Auf meiner HP leider nicht, das erschwert nun die Fehlersuche .-(...

Das du den Fehler bestätigst, gibt mir schon mal Ruhe. Ich ging nämlich davon aus, dass ich in meinen nachträglichen Anpassungen etwas falsch gemacht habe. Kann ich dir bei der Fehlersuche womöglich behilflich sein?

...zu Punkt 3: Gebe ich Dir recht, aber ich bin bisher nie davon ausgegangen das Nutzer sinnlos F5 drücken. Es wird ein Bugfix rauskommen, das dies nicht mehr passiert. :-)...

War bei mir auch nur ein purer Zufall. Die F6-Taste ist bei mir mit einer für mich wichtigen Funktion belegt. Ich hatte mich einfach nur vertippt. Das die neuangelegten Blogs und Kategorien dabei erneut angelegt wurden, fiel mir erst später auf. Ein Blick auf meine bisherigen niedergelegten Arbeitsschritte brachte es dann zu Tage. ;)

...zu Punkt 4/5, ich habe leider die Links irgendwann einmal entfernt, und nur den Text in der lang/main_pb.php nicht angepasst. Kommt aber ein Bugfix release raus ....

Zuerst einmal zum Verständnis - ich hoffe, dass du nicht die Links auf der nachfolgenden Seite meinst, wenn eine Aktion ausgeführt wurde! Vielmehr meinte ich die automatische Weiterleitung nach einer solchen Aktion. Wenn ich mich nicht irre, dann ist dafür u.a. auch dieser Code zuständig:

    if($_GET['aktion'] == $lang['user_pb_delete_no']) { 
      
$url $site_sess->url(ROOT_PATH."pb.php?action=overview");
      
redirect($url);


Bei den Weiterleitungen scheint es einige Probleme zu geben. Manche funktionieren und manche nicht. Bei denen, die funktionieren, gibt es wiederum einige, die nicht korrekt weiterleiten. So z.B. beim Anlegen oder Löschen einer Kategorie. Hier erfolgt die Weiterleitung nicht wie erwartet zurück zum Blog-Management, sondern direkt zur Übersicht der eigenen Blogs. Oder wenn ein Blogeintrag zum Löschen ausgewählt wurde und dann aber bei der Sicherheitsabfrage auf "Nein" geklickt wird, dann gelangt man nach der Weiterleitung direkt zur Übersicht aller vorhandenen Blogs, anstatt zur Übersicht der eigenen Blogs. Ich denke, dass die Weiterleitungen nicht komplett entfernt werden sollten. Vielmehr sollten diese für das nächste Bugfix-Release allesamt überarbeitet und korrigiert werden. Die Zeit für die Weiterleitung sollte auch etwas verkürzt werden. Ist aber nur meine Meinung. :)

...Die Textpassagen mit den Leerzeichen findest du in den lang_files...

 :lol:... Daran habe ich nun nicht gleich gedacht. Ich ging davon aus - weil eine extra main.php für Photo-Blog vorliegt - dass diese Einträge auch dort vorliegen. Nun gut, dass Problem ist geklärt und die Textausgaben sind korrigiert.

... Ein Blog gilt solange als neu, solange wie die Bilder als neu gelten. Ich habe den Wert vom ACP aus übernommen...

Perfekt! So sollte es auch sein.

... Die Tags {if admin} funktionieren bei mir. wahrscheinlich habe ich da einen kleinen Unterschied zu Dir. Du hast sicherlich den is_admin von Hand reingebastelt?...

Ich möchte nicht meine Hand dafür ins Feuer legen aber ich bin mir fast sicher, dass dies in der Version 1.7.7 Standard ist. Ich habe mir auch nochmal die originale unmodifizierte Version angeschaut und auch dort findet sich die Definition "is_admin" wieder. Ich habe leider keine frühere Version vorliegen, da ich erst mit der 1.7.7 begonnen habe. Aber egal, ich denke, dass es da nicht allzu viel Unterschiede geben wird und wer sucht der findet. ;)


Das Problem mit der Clickstream-Ausgabe ist nun auch erledigt. Habe mir noch mal systematisch alle Clickstream-Anweisungen in der pb.php vorgenommen. Hat etwas gedauert, aber jetzt weiß ich, welche von den 20 "$txt_clickstream"-Funktionen abgeändert werden müssen. Hier nur ein Beispiel:

  $txt_clickstream "<a href=\"".$site_sess->url(ROOT_PATH."user_cp.php")."\" class=\"clickstream\">".$lang["user_cp"]."</a>".$config['category_separator'].$lang['user_pb'].$user_name2;

Was hältst du von meinen beiden Wünschen? Ließe sich denn wenigstens der zweite ermöglichen? Im Moment habe ich das improvisiert, indem ich eine Benutzergruppe für Photo-Blog angelegt habe. Jedoch lässt dass immer noch das Verwenden aller Kategorien zu. Was ich aber z.B. im Fall der Kategorie Gästebuch gern unterbinden möchte.

11
Mods & Plugins (Requests & Discussions) / Re: mehrere Kontaktformulare
« on: February 06, 2010, 06:09:06 PM »
Hallo Sumale.nin,

wenn ich mich recht entsinne, dann besteht da aber immernoch das Problem mit dem vorgefertigten Betreff. Diese MOD hat keine vorgefertigte Betreffzeile. Es sei denn thorstenp hatte dies bereits schon modifiziert.

Andererseits ist da dann immer noch das Problem:

Quote
...Der User soll aber immer automtich den richtigen Betreff bekommen und nicht auswählen müssen.

Er hat dann drei verschiedene Kontaktformulare, zwischen denen sich der Benutzer entscheiden muss. Doch genau das soll automatisch geschehen, wenn ich das richtig interpretiere.

12
Mods & Plugins (Requests & Discussions) / Re: mehrere Kontaktformulare
« on: February 06, 2010, 05:28:34 PM »
Hallo thorstenp,

nein das ist leider nicht der Fall. Der Benutzer kann hier aus einem Dropdown-Feld den entsprechenden Betreff auswählen. Es ist also ein Kontaktformular mit unterschiedlichen Auswahl-Möglichkeiten.

13
Mods & Plugins (Requests & Discussions) / Re: mehrere Kontaktformulare
« on: February 06, 2010, 05:09:21 PM »
Hallo thorstenp,

wenn es dir nur um unterschiedliche Betreffzeilen geht, so schaue dir mal das hier an: http://www.4homepages.de/forum/index.php?topic=22624.msg123454#msg123454

Hier kannst du die Betreffzeilen jederzeit im ACP definieren. Vielleicht hilft dir das weiter. :)

14
Mods & Plugins (Requests & Discussions) / Re: MOD PhotoBlog
« on: February 06, 2010, 04:57:40 PM »
Hallo rinaldos,

so... ich habe gestern abend deine MOD integriert und getestet (noch nicht ausführlich bis ins Detail). Kurz und gut - ich bin begeistert. Die Integration gelingt dank der gut ausgeführten Anleitung schnell und unkompliziert. Die Grundanpassung an das eigene Design ist trotz der vielen vorliegenden Dateien auch recht einfach, da hierfür erst einmal nur zwei Dateien geändert werden müssen. Das Feintuning bedarf eines etwas größeren Aufwands, ist aber angesichts der Funktionalität deiner MOD kaum der Rede wert.

Bevor ich jetzt auf weitere Details eingehe, möchte ich sagen, dass ich mich in den nachfolgenden Ausführungen auch irren kann, diese durch eigene Fehler verursacht werden oder durch andere MODs. Ich bin kein Profi und beschreibe nur meine Beobachtungen. Abgesehen davon sind es eigentlich auch nur Schönheitsfehler. Also...

  • Fehler im Schritt 6 der Modifikationsanweisungen. Hier muss es in lang/deutsch/main.php "include(ROOT_PATH.'lang/deutsch/main_pb.php');" heißen, anstatt "include(ROOT_PATH.'lang/english/main_pb.php');"
  • Betrachtet man gerade eine Kategorie und loggt sich anschließend aus, kommt eine 404-Fehlermeldung. Die dann angezeigte Seite in meinem ersten Test war folgende: http://www.meine-domain.de/pb.php&cat_id=1. Richtig müsste es aber folgender Link sein: http://www.meine-domain.de/pb.php?action=overview&cat_id=1. Dieser Fehler ist bei jeder betrachteten Kategorie reproduzierbar.
  • Hat man einen Blog erstellt und veröffentlicht ihn, wird die Datei success.html aufgerufen. Verbleibt man auf dieser Seite und drückt F5 zum aktualisieren, wird der neue Blog ein zweitesmal erstellt. Dies kann man beliebig wiederholen. Die automatische Weiterleitung funktioniert nicht.
  • Das gleiche gilt auch bei der Erstellung einer neuen Kategorie. Auch hier kann man mittels F5 die gerade erstellte Kategorie vor der Weiterleitung beliebig vervielfachen. Automatische Weiterleitung funktioniert korrekt.
  • Die automatische Weiterleitung nach dem Bearbeiten eines Blogs funktioniert nicht.
  • Die automatische Weiterleitung bei deaktivierten MOD Photo-Blog funktioniert nicht.

Was mir auch aufgefallen ist - bei Einschränkung der Berechtigung wird keine entsprechende Meldung ausgegeben. Ich habe dafür in die pb.php vor den Zeilen:

//-----------------------------------------------------
//--- Clickstream -------------------------------------
//-----------------------------------------------------


folgenden Code eingefügt:

if ($user_info['user_level'] == GUEST || $user_info['user_level'] == USER_AWAITING) {
  
show_error_page($lang['no_permission']);
  exit;
}


Funktioniert ohne Probleme und hat keinen Einfluss auf die Meldung, die bei deaktiviertem Photo-Blog ausgegeben wird.

Meine Wünsche:


Meine Fragen zu den eigenen Anpassungen:

1. Anpassung der Clickstream-Ausgabe fürs Kontrollzentrum.

Ich habe das Benutzerkontrollzentrum mit einem eigenen Menü versehen. Siehe auch hier http://www.4homepages.de/forum/index.php?topic=26768.msg145178#msg145178.

Nun habe ich den Link für die Seite "Deine Foto-Blogs" dort hinein verlegt. Leider komme ich bei der Clickstream-Ausgabe nicht weiter. Ich finde nicht den entsprechenden Bereich in der pb.php der für die Clickstream-Ausgabe dieser Seite verantwortlich ist. Kannst du mir dabei bitte helfen?

2. Diverse Textfehler

Bei einigen Textausgaben fehlen Leerzeichen. Dies betrifft z.B. die Zeile "erstellt von: Benutzername in Kategorie:Name der Kategorie" und die Zeile "Kategorie:Kategoriename". Wo genau finde ich diese, damit ich die fehlenden Leerzeichen hinzufügen kann?

3. Wie lange gilt ein Blog als neu und wo kann das geändert werden?


...I've installed
[MOD] Incorporar Moderadores en la galería
http://www.4homepages.de/forum/index.php?topic=17155.0
Can I make my blogging for the site manager and supervisors only...

Verwende hierfür/ Use for this:

// NEUER BLOG EINTRAG

if ($action == "new"){
    if (
$user_info['user_level'] != ADMIN) && $user_info['user_level'] != MODERADOR){
       
show_error_page($lang['no_permission']);
    }


@ rinaldos... hier habe ich auch einen Fehler im Tag gefunden: http://www.4homepages.de/forum/index.php?topic=24953.msg143404#msg143404. Anstatt

{if admin}{button_in}{endif admin}

müsste es

{if is_admin}{button_in}{endif is_admin}

heißen.

Einer Benutzergruppe die Rechte zum Erstellen von neuen Blogs erteilen

Wer nur einer bestimmten Gruppe die Rechte für das Erstellen neuer Blogs erteilen möchte, kann nach der hier von Jan beschriebenen Anleitung verfahren: http://www.4homepages.de/forum/index.php?topic=6566.msg29808#msg29808

In meinem Beispiel sieht das so aus.

Schritt 1: Erstelle im ACP eine neue Benutzergruppe mit dem Namen "Photo-Blog" und merke dir die ID-Nummer dieser Benutzergruppe.

Schritt 2: Dieser Schritt muss nur ausgeführt werden, wenn man die MOD von Jan noch nicht verwendet. Wer diese MOD bereits verwendet, kann bei Schritt 3 weitermachen.

Öffne includes/page_header.php suche:

Code: [Select]
if ($user_info['user_level'] >= USER) {
füge davor folgenden Code ein:

Code: [Select]
$usergroups = array();
  $current_time = time();
  $sql = "SELECT group_id  
          FROM ".GROUP_MATCH_TABLE."
          WHERE user_id = ".$user_info['user_id']."
          AND groupmatch_startdate <= $current_time
          AND (groupmatch_enddate > $current_time OR groupmatch_enddate = 0)";
  $result = $site_db->query($sql);

  while ($row = $site_db->fetch_array($result)) {
    $usergroups[$row['group_id']] = true;
  }

Schritt 3: Zum Verwenden für {if is_in_group_photoblog} und {endif is_in_group_photoblog} im Template, suche:

Code: [Select]
//-----------------------------------------------------
//--- Parse Header & Footer ---------------------------
//-----------------------------------------------------

und füge davor folgenden Code ein:

Code: [Select]
$site_template->register_vars(array(
  "is_in_group_photoblog" => (isset($usergroups[USERGROUP_ID])) ? 1 : 0
));

Ersetze USERGROUP_ID mit der gemerkten ID-Nummer der Benutzergruppe "Photo-Blog".

Schritt 4: Füge im Template user_pb_showpb.html vor und nach {button_in} nun die neu erstellten Tags ein:

Code: [Select]
{if is_in_group_photoblog}{button_in}{endif is_in_group_photoblog}
Fertig ist das Ganze und du kannst jetzt ausgewählten Benutzern die Berechtigung zum Erstellen von eigenen Blogs erteilen, indem du diese der Benutzergruppe "Photoblog" hinzufügst.

15
Mods & Plugins (Requests & Discussions) / Re: MOD PhotoBlog
« on: February 05, 2010, 04:48:23 PM »
Auf den ersten Blick gesehen, ist es wirklich besser ein einfaches Gästebuch einzubauen. Jedoch habe ich mich umgeschaut, da ist nicht viel Auswahl vorhanden. Auf deiner Seite habe ich auch gesehen, wie du ein Gästebuch verwirklicht hast. Ist eine interessante Lösung. Die von mir oben angegebene Variante bereitet aber einfach zu viel Probleme nach der Integration.

Mit Blick auf die Zukunft empfinde ich da deine MOD als bessere Wahl. Damit habe ich eine funktionelle Lösung, die vielseitig verwendbar ist. U.a. eben auch für ein Gästebuch. ;)

Ich werde die MOD heute abend mal integrieren und mich praktisch damit vertraut machen.

Pages: [1] 2 3 4 5 ... 8
Post your comments here