• [Mod] Avatar v2.01 5 0 5 1
Currently:  

Author Topic: [Mod] Avatar v2.01  (Read 478321 times)

0 Members and 2 Guests are viewing this topic.

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #315 on: August 31, 2007, 07:53:29 PM »
Quote
Unknown column 'u.userpic' in 'field list'

See in phpmyadmin, column no exist in USERS_TABLE table.
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #316 on: August 31, 2007, 09:12:07 PM »
So if it doesnt exists,should I make it?
Or should I remove variable u.userpic from code????  :?

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #317 on: August 31, 2007, 09:14:23 PM »
Quote
Or should I remove variable u.userpic from code????

If no use userpic MOD, remove u.userpic ... :?
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #318 on: August 31, 2007, 10:43:36 PM »
OMG, at last I can see avatar near my nickname!!! Thanks for help so far!!! :wink:  :wink:  :wink:
But its got some bugs.
1.  :arrow: Even I choose different avatar, it shows my nickname with default avatar- blank.gif.
Should I change something in templates whois_online or mistake is in sessions.php???
2. I can see avatar in top of nickname,but should be in front, like that--->>>>  avatar| Nickname1
3. I want see users in vertical row not horizontal like that:

avatar| Nickname1
avatar| Nickname2
avatar| Nickname3
avatar| Nickname4

Where can I make that?



Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #319 on: August 31, 2007, 10:47:11 PM »
One more mistake:

When I am not logged in I cant see avatars from other users.

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #320 on: August 31, 2007, 11:06:54 PM »
Quote
When I am not logged in I cant see avatars from other users.

Find:

Quote
$avatar_img = (isset($config['avatar_use']) && $config['avatar_use'] && @file_exists(TEMPLATE_PATH."/avatars/".$user_row['user_avatar']."/".$row['userpic']) && $user_info['user_level'] >= USER) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_row['user_avatar'] == "") ? "blank.gif" : $user_row['user_avatar'])."\" name=\"icons\" border=\"0\" hspace=\"15\" alt=\"\">" : "";

with:

Quote
$avatar_img = (isset($config['avatar_use']) && $config['avatar_use'] && @file_exists(TEMPLATE_PATH."/avatars/".$row['user_avatar'])) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($row['user_avatar'] == "") ? "blank.gif" : $row['user_avatar'])."\" name=\"icons\" border=\"0\" hspace=\"15\" alt=\"\">" : "";

Quote
avatar| Nickname1
avatar| Nickname2
avatar| Nickname3
avatar| Nickname4

Use Icecream MOD for whos online list. Can edit this. ;)
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #321 on: August 31, 2007, 11:15:17 PM »
ok, but what about my default avatar???
It doesn shows my real avatar,just default.... :(

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #322 on: August 31, 2007, 11:20:05 PM »
NO,it doesn helps, can not see avatar,sorry :( :( :(
And it shows my default avatar,not real one!!! :( :(

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #323 on: August 31, 2007, 11:56:03 PM »
Quote
And it shows my default avatar,not real one!!!

Ok so please post icecream topic. I look. ;)
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #324 on: September 01, 2007, 10:26:29 AM »
ok,thanks.
Can you give link to Icecream topic please? :wink:

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #325 on: September 13, 2007, 09:02:18 PM »
have the same error: http://www.4homepages.de/forum/index.php?topic=3978.msg96499#msg96499


"Notice: Undefined index: user_avatar in /home/site/page_header.php on line 116"

This error only appear when a non-registered user search something, with member work perfectly, could somebody help me?  :|

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #326 on: September 13, 2007, 10:28:22 PM »
Quote
"Notice: Undefined index: user_avatar in /home/site/page_header.php on line 116"

Please post from line 110 to line 120. I look ...
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #327 on: September 14, 2007, 01:28:27 AM »
Quote
"Notice: Undefined index: user_avatar in /home/site/page_header.php on line 116"

Please post from line 110 to line 120. I look ...

Thanks a lot thunder, here it is:  :D
Code: [Select]
"url_categories" => $site_sess->url(ROOT_PATH."categories.php"),
  "url_home" => $site_sess->url(ROOT_PATH."index.php"),
  "url_login" => (!empty($url_login)) ? $site_sess->url($url_login) : $site_sess->url(ROOT_PATH."login.php"),
  "url_logout" => (!empty($url_logout)) ? $site_sess->url($url_logout) : $site_sess->url(ROOT_PATH."logout.php"),
  "url_member" => (!empty($url_member)) ? $site_sess->url($url_member) : $site_sess->url(ROOT_PATH."member.php"),
  "url_upload" => (!empty($url_upload)) ? $site_sess->url($url_upload) : $site_sess->url(ROOT_PATH."member.php?action=uploadform"),
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",
  "url_lost_password" => (!empty($url_lost_password)) ? $site_sess->url($url_lost_password) : $site_sess->url(ROOT_PATH."member.php?action=lostpassword"),
  "url_captcha_image" => $site_sess->url(ROOT_PATH."captcha.php"),
  "has_rss" => false,
  "rss_title" => "",

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #328 on: September 14, 2007, 01:34:00 AM »
Change:

Quote
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",

for:

Code: [Select]
"user_avatar_current" => (isset($config['avatar_use']) && $config['avatar_use'] && isset($user_info['user_avatar'])) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #329 on: September 14, 2007, 04:14:52 AM »
working perfectly, thanks a lot man  :D

 

Post your comments here