• [MOD] Simple News Publishing 5 0 5 1
Currently:  

Author Topic: [MOD] Simple News Publishing  (Read 119840 times)

0 Members and 1 Guest are viewing this topic.

Offline ujeb

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #60 on: January 30, 2007, 05:30:44 PM »
hi.. i have problem with this mod  :(

i'm using this mod, but i'm having some troubles

in the settings i see news settings and now, after a few tries, i don't see the button of save settings. i get this errore
 "Fatal error: Call to undefined function: 1() in /membri/barstazione/cms/admin/settings.php on line 161"
the line in parte is:

line 161 in file setting.php:
   
 $value_option($setting_name, $config_value);


i'm using italian language and a 4light_gray template

what can i do?

help me  :)

Offline ujeb

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #61 on: January 31, 2007, 05:54:42 PM »
i need help....


 :oops:


Offline ujeb

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #62 on: February 05, 2007, 09:47:44 PM »
Quote
hi.. i have problem with this mod 

i'm using this mod, but i'm having some troubles

in the settings i see news settings and now, after a few tries, i don't see the button of save settings. i get this errore
 "Fatal error: Call to undefined function: 1() in /membri/barstazione/cms/admin/settings.php on line 161"
the line in parte is:

line 161 in file setting.php:
   
 $value_option($setting_name, $config_value);


i'm using italian language and a 4light_gray template

what can i do?





help me...plz!!!!!

Offline drastx

  • Newbie
  • *
  • Posts: 41
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #63 on: February 06, 2007, 10:21:33 AM »
Quote
hi.. i have problem with this mod 

i'm using this mod, but i'm having some troubles

in the settings i see news settings and now, after a few tries, i don't see the button of save settings. i get this errore
 "Fatal error: Call to undefined function: 1() in /membri/barstazione/cms/admin/settings.php on line 161"
the line in parte is:

line 161 in file setting.php:
   
 $value_option($setting_name, $config_value);


i'm using italian language and a 4light_gray template

what can i do?





help me...plz!!!!!

I think you did somthing wrong with this parts:

Quote
#
#-----[ OPEN ]---------------------------------
#
lang/english/admin.php

#
#-----[ FIND ]---------------------------------
#
?>

#
#-----[ BEFORE, ADD ]------------------------------------------
#
/*-- Setting-Group 8 --*/
$setting_group[8] = "News";
$news_display_optionlist = array(
  "1" => "Show the last 'X' news",
  "2" => "Show news of the last 'X' days",
);

$setting['news_home_display'] = "News display mode";
$setting['news_nb'] = "News number";
$setting['news_nb_days'] = "Days number";
$setting['news_cutoff'] = "Number of days each news is marked as new";
$setting['news_html'] = "Allow HTML in news";
$setting['news_bbcode'] = "Allow BB-Code in news";
$setting['news_bbcodeimg'] = "Allow images (BB-Code) in news";

#
#-----[ OPEN ]---------------------------------
#
lang/french/admin.php

#
#-----[ FIND ]---------------------------------
#
?>

#
#-----[ BEFORE, ADD ]------------------------------------------
#
/*-- Setting-Group 8 --*/
$setting_group[8] = "Nouvelles";
$news_display_optionlist = array(
  "1" => "Afficher les 'X' derničres nouvelles",
  "2" => "Afficher les nouvelles des 'X' derniers jours",
);

$setting['news_home_display'] = "Mode d'affichage des nouvelles";
$setting['news_nb'] = "Nombre de nouvelles";
$setting['news_nb_days'] = "Nombre de jours";
$setting['news_cutoff'] = "Nombre de jours ou la nouvelle est considérée comme 'nouvelle'";
$setting['news_html'] = "Autoriser le HTML dans les nouvelles";
$setting['news_bbcode'] = "Autoriser le BB-Code dans les nouvelles";
$setting['news_bbcodeimg'] = "Autoriser les images (BB-Code) dans les nouvelles";

#
#-----[ OPEN ]---------------------------------
#
admin/settings.php

#
#-----[ FIND ]---------------------------------
#
show_setting_row("highlight_admin", "radio");

#
#-----[ AFTER, ADD ]------------------------------------------
#
show_table_separator($setting_group[8], 2, "#setting_group_8");
show_setting_row("news_home_display", "show_news_display_options");
show_setting_row("news_nb");
show_setting_row("news_nb_days");
show_setting_row("news_cutoff");
show_setting_row("news_html", "radio");
show_setting_row("news_bbcode", "radio");
show_setting_row("news_bbcodeimg", "radio");

I think you need to change "$setting_group[8]" to "$setting_group[9]" or "$setting_group[10]".

Offline ujeb

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #64 on: February 08, 2007, 11:15:48 AM »
hi thanks..

i have make this problem...

but i now have new problem! i need you support!!!

the problem is that i don't see news in my template!!!

please see my siteweb http://barstazione.altervista.org/cms/index.php 

you see that headlines up "who's on  line" is empty!!!

i use template "4lightgray" ...

please help me!!!

thanks

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #65 on: June 11, 2007, 12:26:57 AM »
edited  :D
« Last Edit: June 11, 2007, 02:49:27 AM by knsin0 »

Offline om6acw

  • Full Member
  • ***
  • Posts: 187
    • View Profile
    • My Animal's World
Re: [MOD] Simple News Publishing
« Reply #66 on: June 11, 2007, 12:39:06 AM »
This mod does not work with 1.7.4  :cry:

This mod work nice whit 174  :!: http://www.myanimalsworld.com/news.php

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #67 on: June 11, 2007, 02:49:48 AM »
Sorry, i failed installing the mod, now it works perfectly  :wink:

Offline Fragezeichen

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #68 on: June 11, 2007, 12:35:31 PM »
good question.
but how to add news?

Offline knsin0

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #69 on: June 11, 2007, 03:42:01 PM »
you will find the link in the admin panel  :D

Offline Fragezeichen

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #70 on: June 13, 2007, 01:06:58 AM »
your right,just seem not for first look. :oops:


Offline UFOSWORLD

  • Full Member
  • ***
  • Posts: 102
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #71 on: June 24, 2007, 04:16:43 AM »
Hab den Mod installiert...  läuft gut... zeigt auch News an... 

Datenbank hinzugefügt...

hatte aber Probleme bei den Admineinstellungen mit settings.php und admin.php

nun zeigt er zwar [News] in den Einstellungen an... aber er hüpft beim klick drauf nicht nach unten

er zeigt unten zwar die ganzen Felder an, aber sobald ich was editiere
(z.b, die Anzahl wie viele NEWS angezeigt werden sollen oder wie viele Tage ein NEW an den News kleben soll ) 

und dann auf speichern klicke...  steht bei nächsten betrachten wieder nix drin... die felder und die radio buttons sind leer...

was hab ich falsch gemacht?   muss ich noch was an der Datenbank editieren??

wie gesagt ... tabelle hinzugefügt...  und News werden gespeichert....

merci UFO

Offline UFOSWORLD

  • Full Member
  • ***
  • Posts: 102
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #72 on: June 24, 2007, 04:33:51 AM »
Nachtrag ... Fehler gefunden... hatte die News.sql den zweiten Teil in die Datenbank nicht integriert...  anscheinend war das nicht bei der install_new.php dabei...

Nächstes Problem:

jetzt hab ich auf 1 News in der Anzeige gestellt... aber ich habe zwei drin

im archiv zeigt er aber keine news an....

ab wann tauchen die da auf??

UPDATE....

ganzen Thread nochmal durchgelesen und  dann die Lösung gefunden

http://www.4homepages.de/forum/index.php?topic=6824.msg46587#msg46587

thx for the solution...  works perfect...
« Last Edit: July 13, 2007, 02:14:02 AM by UFOSWORLD »

Offline UFOSWORLD

  • Full Member
  • ***
  • Posts: 102
    • View Profile
Re: [MOD] Simple News Publishing
« Reply #73 on: January 03, 2008, 02:08:43 PM »
Brauche Hilfe!!!

Ist es möglich das News Modul so umzubaun das

1. die News in einer umgekehrten Reihenfolge hat...  (z.b. aktuelle News immer ganz oben)
2. die News die nicht mehr aktuell sind, verschwinden (so das halt immer die aktuellen News ganz oben sind... (falls ich z.b. Termine für die Zukunft reinschreibe, soll immer der Termin angezeigt werden der als nächstes kommen wird...  (siehe Beispiel auf Foto...) wenn der Tag rum is an dem die Events kommen, dann wird der Event nicht mehr angeziegt...
3. die Reihenfolge der angezeigten News verändert werden kann, so das z.b. eine News nachträglich hinzugefügt werden kann und wie bei den Alben mit Pfeil rauf und runter  verschoben werden kann... falls sich eben mal terminliche Änderungen ergeben, oder ein Event dazukommt...

gruss UFO

Offline Pumaaa

  • Jr. Member
  • **
  • Posts: 64
    • View Profile
    • Sunny Täter
Re: [MOD] Simple News Publishing
« Reply #74 on: December 17, 2008, 05:32:14 PM »
Abend zusammen!
Habe den Mod bei mir in die Galerie eingebaut und läuft auch soweit ganz gut.
Ich lasse die News nur auf der index.php Seite anzeigen und auch nur wenn man nicht eingeloggt ist, siehe hier -> http://sunny-taeter.de/
Jetzt stellen sich für mich aber noch folgende Fragen.

1. Im Archiv erscheinen keine News. Sie sollten doch in der news.php angezeigt werden oder?
2. Ich würde gerne den Titel etwas umgestalten. Farblich, sowie von der Anordnung. Habe aber leider nirgens gefunden, wo ich z.B. ändern kann,
dass zuerst das Erstelldatum des Beitrags und dann der Titel kommt. Ist das möglich? Farbe lassen sich ja nur mit den imagerow usw. in der style.css ändern,
aber ich möchte für die News eigene Farben benutzen. Geht das irgendwie?
3. Wie kann man z.B. ein Bild in einen Beitrag einfügen? Über <img scr=" ....>? Aber auch nur wenn html erlaubt ist oder?

Ich hoffe mir kann jemand helfen ....
Danke schonmal ;)
Gruß

 

Post your comments here