Author Topic: Probleme mit Version 1.7.9  (Read 36891 times)

0 Members and 1 Guest are viewing this topic.

Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Probleme mit Version 1.7.9
« on: November 14, 2010, 01:50:37 PM »
Habe die Version 1.7.9 ganz frisch auf einem neuen Webaccount installiert.
Zunächst habe ich nur 3 Kategorien eingerichtet, 4 Bilder hochgeladen und Probekommentare gepostet.

Nun zu den bis dahin bereits aufgetretenen Problemen .

1. Fehlermeldung beim Bild-Upload via Website
Quote
DB Error: Bad SQL Query: INSERT INTO 4images_wordmatch (image_id, word_id, name_match, desc_match, keys_match) SELECT DISTINCT 5, word_id, 0, 0, 1 FROM 4images_wordlist WHERE word_text = 'Kilimanjaro' Duplicate entry '5-17' for key 'image_word_id'

Diese Fehlermeldung wurde für alle Keywords ausgegeben , die ich bereits für ein Bild zuvor vergeben hatte.
Was ist hier los ?

2. Fehlermeldung beim Kommemtar posten
Quote
Fehler : CSRF check failed.

Der Kommentar wurde nicht gepostet.
Was ist hier los ?

3. Die Suche funktioniert sehr unzureichenden.
Beim Klick auf ein Keyword in der Detailansicht, das auch für ein anderes Bild vergeben ist, wird nur das andere Bild gefunden.
Was ist hier los ?


Edit : 14.11.2010

Ich denke, ich kann die Probleme eingrenzen. Die Probleme traten ausnahmslos bei Bildern, die im Bild-Namen einen Umlaut hatten auf. In meinem Fall "Furtwängler Gletscher". Ich kann mit dieser Feststellung zumindest die aufgetretenen Probleme umgehen (indem ich keine Bildnamen mit Umlaut vergebe), doch die "High-End-Lösung" ist das sicher nicht. Auffällig ist darüber hinaus auch, dass sämtliche neuen Funktionen der Version 1.7.9 davon betroffen sind.


Edit : 16.10.210

Oder ob es die Art und Weise des Schreibens der Keywords ist ... ? Mit Komma oder untereinander ... jeweils so wie in der Beschreibung angegeben ? Ich kann es nicht eingrenzen !
Habe nun noch mal Bilder im ACP editiert ... dort stehen die Keywords mit Komma ... beim Speichern folgt dann die Fehlermeldung !!


Edit : 20.11.2020

Analoge Fehlermeldungen und Probleme :
http://www.4homepages.de/forum/index.php?topic=28268.0
http://www.4homepages.de/forum/index.php?topic=24177.msg152952#msg152952
http://www.4homepages.de/forum/index.php?topic=26749.0
http://www.4homepages.de/forum/index.php?topic=28410.0


Edit : 13.12.2010

Und hier gibt es nun den offiziellen Fix : http://www.4homepages.de/forum/index.php?topic=28430.0
Danke Kai ...
« Last Edit: December 13, 2010, 05:12:03 PM by mawenzi »
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline qBass17

  • Addicted member
  • ******
  • Posts: 1.800
  • I ♥ 4I
    • View Profile
Re: Probleme mit Version 1.7.9
« Reply #1 on: November 14, 2010, 02:03:14 PM »
100% agree!

Offline x23piracy

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
    • FHG
Re: Probleme mit Version 1.7.9
« Reply #2 on: November 14, 2010, 04:49:15 PM »
Hi,

ich kann keine Unterkategorien definieren, es wird nicht gespeichert und die Kategorie
wird bzw. bleibt Hauptkategorie...

Hat das noch jemand?


Gruß Jens

Don't trust in md5 it's unsafe change your 4i galerys password hash algorythm! second pw db field, create new hashes over some time, deny old hash. Help members that cry, send informationen mail to the rest. Camouflage new pw hash in cookie. Done!

--(◔̯◔)--

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
Re: Probleme mit Version 1.7.9
« Reply #3 on: November 14, 2010, 04:57:02 PM »
ich kann keine Unterkategorien definieren, es wird nicht gespeichert und die Kategorie
wird bzw. bleibt Hauptkategorie...

Hallo,

ich habe keine Probleme mit 1.7.9, auch mit den Unterkategorien nicht.
Ich habe allerdings auch keine MODs installiert.

nobby

Rembrandt

  • Guest
Re: Probleme mit Version 1.7.9
« Reply #4 on: November 14, 2010, 05:14:01 PM »
@x23piracy , lass bitte das crossposting!    http://www.4homepages.de/forum/index.php?topic=28269.msg152722#msg152722

...
...
leider kann ich keinen deiner fehler bestätigen, weder bei meiner hauptseite bei der ich ein update gemacht habe noch bei einer frisch installierten.

der einzige "fehler" was mir aufgefallen ist, wenn man einen commentar postet sich dann abmeldet und als anderer user wiederum anmeldet kann man keinen commentar schreiben.
Quote
Sie können nicht so kurz nach Ihrem letzten Beitrag erneut posten. Bitte versuchen Sie es später wieder
das passiert wenn man versucht mit der gleichen IP einen commentar zu posten.

mfg Andi

Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: Probleme mit Version 1.7.9
« Reply #5 on: November 15, 2010, 12:07:31 AM »
Hallo Andi ...

vergebe mal für ein neues Bild in deiner 1.7.9-Galerie einen Bildnamen mit Umlaut beim Upload ...
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline x23piracy

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
    • FHG
Re: Probleme mit Version 1.7.9
« Reply #6 on: November 15, 2010, 01:47:42 AM »
Hallo Andi ...

vergebe mal für ein neues Bild in deiner 1.7.9-Galerie einen Bildnamen mit Umlaut beim Upload ...

Hi,

ich bin zwar nicht Andi aber bevor ich festgestellt habe das ich keine Unterkategorien erstellen / definieren
kann habe ich mehrere Kategorien erstellt unter anderem zwei mit Umlauten...

Spielst du darauf an?
Lässt sich das durch entfernen der Umlaute beheben?


MfG Jens

Don't trust in md5 it's unsafe change your 4i galerys password hash algorythm! second pw db field, create new hashes over some time, deny old hash. Help members that cry, send informationen mail to the rest. Camouflage new pw hash in cookie. Done!

--(◔̯◔)--

Rembrandt

  • Guest
Re: Probleme mit Version 1.7.9
« Reply #7 on: November 15, 2010, 04:47:57 AM »
Hallo Andi ...

vergebe mal für ein neues Bild in deiner 1.7.9-Galerie einen Bildnamen mit Umlaut beim Upload ...
funktioniert einwandfrei...
wenn das file selber z.b. "bild_ä.jpg" lautet dann wird das bild umbenannt zu "bild_.jpg" ,
 in der galerie im uploadformular kann ich reinschreiben was ich will es funktioniert.

@x23piracy, auch kategorienamen mit umlauten im namen funktionieren.

Offline x23piracy

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
    • FHG
Re: Probleme mit Version 1.7.9
« Reply #8 on: November 15, 2010, 05:40:45 AM »
@x23piracy, auch kategorienamen mit umlauten im namen funktionieren.

Hi,

kann mir denn vielleicht jemand helfen, kann ich direkt in der db irgendwas kontrollieren?


Gruß Jens

Don't trust in md5 it's unsafe change your 4i galerys password hash algorythm! second pw db field, create new hashes over some time, deny old hash. Help members that cry, send informationen mail to the rest. Camouflage new pw hash in cookie. Done!

--(◔̯◔)--

Rembrandt

  • Guest
Re: Probleme mit Version 1.7.9
« Reply #9 on: November 15, 2010, 07:17:40 AM »
...
hast du ein neuinstallation oder ein manuelles update durchgeführt?

Offline x23piracy

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
    • FHG
Re: Probleme mit Version 1.7.9
« Reply #10 on: November 15, 2010, 08:11:07 AM »
hast du ein neuinstallation oder ein manuelles update durchgeführt?

Neuinstallation direkt 1.7.9

EDIT:

Welche Datei unter /admin sorgt für die Datenbank Änderung beim anlegen von Kategorien?
evtl. stimmt da was nicht, dann tausche ich diese Testweise gegen das Original aus, obwohl
ich mich nicht daran erinnern kann in den Admin files was geändert zu haben seit der installation.

Andi bitte helf mir...


Gruß Jens
« Last Edit: November 15, 2010, 07:47:15 PM by x23piracy »

Don't trust in md5 it's unsafe change your 4i galerys password hash algorythm! second pw db field, create new hashes over some time, deny old hash. Help members that cry, send informationen mail to the rest. Camouflage new pw hash in cookie. Done!

--(◔̯◔)--

Offline mawenzi

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: Probleme mit Version 1.7.9
« Reply #11 on: November 15, 2010, 11:56:21 PM »
Hallo Andi ...

1. Danke für die Möglichkeit des Testens auf deiner Testseite ...
2. Und ich konnte den 1.Fehler und auch den 3.Fehler auf deiner Seite nachvollziehen. Bild im Anhang ...
3. Habe 3 Bilder hinzugefügt ...  alle mit dem Keyword Afrika ... und es werden bei der Suche nur zwei Bilder über die Keywordliste auf der Detailseite gefunden ...
4. Den "Fehler : CSRF check failed." hatte ich auf deiner Seite noch nicht, jedoch wiederholt auf meiner Testseite ...

Stehe weiterhin zu meinem Aussage von oben ... "Neue Funktionen in 1.7.9 noch nicht ausgegoren !" ...

Und Kai ... wie sieht es zumindest mit einem Statement zu den Fehlern aus ?

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline Przemek

  • Pre-Newbie
  • Posts: 3
    • View Profile
    • Transportnews
Re: Probleme mit Version 1.7.9
« Reply #12 on: November 16, 2010, 03:03:40 AM »
The problem with keywords is caused by a single letter in the code ;)
I propose to solve the problem of recovering some of the code for version 1.7.7: http://www.4homepages.de/forum/index.php?topic=28268.0

Offline x23piracy

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
    • FHG
Re: Probleme mit Version 1.7.9
« Reply #13 on: November 16, 2010, 04:57:11 AM »
Hi,

versucht mal bitte eure Lightbox (ohne MODS) zu löschen und betretet danach
die Lightbox erneut. Ich sehe kurz eine "Bad SQL select" dann die Seite allerdings
mit css Fehler (Schriftart zu groß). Hmm

Falls jemand einen Lösungsansatz für mein Kategorie Problem hat bitte her damit.


Gruß Jens

Don't trust in md5 it's unsafe change your 4i galerys password hash algorythm! second pw db field, create new hashes over some time, deny old hash. Help members that cry, send informationen mail to the rest. Camouflage new pw hash in cookie. Done!

--(◔̯◔)--

Rembrandt

  • Guest
Re: Probleme mit Version 1.7.9
« Reply #14 on: November 16, 2010, 07:25:47 AM »
...
3. Habe 3 Bilder hinzugefügt ...  alle mit dem Keyword Afrika ... und es werden bei der Suche nur zwei Bilder über die Keywordliste auf der Detailseite gefunden ...
...

also entweder ich stehe auf der leitung oder wir reden aneinander vorbei.
du hast drei bilder hochgeladen, alle drei enthalten das schlüsselwort "afrika", wenn ich bei einen bild auf dieses klicke dann werden doch alle drei gefunden?
ich habe erneut  x bilder mit den gleichen schlüsselwörtern hochgeladen ich bekomme nirgends fehlermeldungen..


@x23piracy, leider kann ich all die von dir beschriebenen fehler nicht nachvollziehen.

mfg Andi
« Last Edit: November 16, 2010, 07:45:57 AM by Rembrandt »