Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - HelpMeNow

Pages: [1] 2 3 4
1
I reverted back to 1.7.2, and you are right, I still had the problem.
So I looked at my server error logs and found the following:

 PHP Warning: imagejpeg() [<a href='function.imagejpeg'>function.imagejpeg</a>]: Unable to open './../data/thumbnails/1/t.JPG' for writing in /var/www/vhosts/my_domain.com/httpdocs/gallery/includes/image_utils.php on line 88, referer: http://www.my_domain.com/gallery/admin/thumbnailer.php

I discovered that the folder 1 for some reason doesn't exist in the thumbnail folder of data folder. My ftp client must have somehow deleted the whole directory. I created the folder named 1 in the /data/thumbnails directory and thumnails started working.

I also went ahead and again upgraded back to 1.7.3 and the thumbnail works perfect as well.

I appologize for not catching this (delete of folders in the data/thumbnails directory). But, again thank you for your help V@no. I hope this post may help others if they accidently delete folders in the /data/thumbnail directory and wonder why they get the error message smilliar to mine.

Thanks.

2
[olist]
  • upgraded from what version?
  • "lost thumbnails" how? you see 404 icon or jpeg,giv,png, etc icons instead of actual thumbnails?
  • and what do you see if you edit an image in ACP?
  • do you have backup? can you actualy confirm that if you restore backup files everything is working fine, but with new .php files no thumbnails?
  • [/olist]
    I'm asking this, because there was no changes made to image manipulation module, so what you've discribed is hardly could be caused by upgrading (aka replacing ALL .php files with new ones), perhaps either you made a misstake during the upgrade, or the problem was before the upgrade and you just didnt noticed it...
I see the JPG, JPEG icons and etc.
In the ACP, when I go to edit any picture, all the images for the thumbnail files are 404 icon.
I don't have a backup, but I think I may have over-rided the thumbnail directory (looking at the logs for my ftp) but that still doesn't explain why I ge the error.
I upgraded from 1.7.2 version with no hacks (during upgraded, I only replaced the .php files and didn't run the install)

I do remember runing the Auto-thumbnail prior to the upgraded one time, and it did work fine.
I will revert back to 1.7.2 to see if the problem is solved, and then will post my findings.

Thanks V@no  :)

3
After upgrade to 1.7.3 I lost all thumbnails, and auto-thumbnail doesn't work anymore, and generates the old "Error creating thumbnail!" message. I have GD installed and was working fine before the upgrade to 1.7.3. I have the latest GD on my server.

V@no, sure could help your expertise here.

Thanks.

4
Thanks V@no, You mentioned to check the server error logs. And when I examined the error log, I noticed the "Failed Authorization". The whole directory was in a protected area, and as soon as I opened the directory to public, the problem was solved!

Thanks for the tip on checking server error logs.  :P

5
When I click the download button, the file that gets downloaded is always corrupt and always 1.2 KB. I've tried all suggestion on this forum, and I still have this problem.

Please Help.

Thank you

6
because you didnt show what is on that line (plus 2 lines above and below)
secondly, there is nothing useless in global.php so commenting out something is asking for trouble ;)

 :oops: Line 135 is where I've put the " * * * Stars * * * " down in the code:  :oops:

Code: [Select]
  // Remove all control (i.e. with ASCII value lower than 0x20 (space),
  // except of 0x0A (line feed) and 0x09 (tabulator)
  $search2 =
      "\x00\x01\x02\x03\x04\x05\x06\x07\x08\x0B\x0C\x0E\x0F\x10\x11\x12\x13\x14\x15\x16\x17\x18\x19\x1A\x1B\x1C\x1D\x1E\x1F";
  $replace2 = //str_repeat("\r", strlen($search2));
      "\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D\x0D";

  foreach ($array as $key => $val) {
    if (is_array($val)) {
      $val = clean_array($val);
    } else {
******** line 135:      $val = preg_replace($search, $replace, $val);

      $val = str_replace("\r\n", "\n", $val);
      $val = str_replace("\r",   "\n", $val);
      $val = strtr($val, $search2, $replace2);
      $val = str_replace("\r", '', $val);  // \r === \x0D

      do {
        $oldval = $val;
        $val = preg_replace('#</*(applet|meta|xml|blink|link|style|script|embed|object|iframe|frame|frameset|ilayer|layer|bgsound|title|base)[^>]*>#i', "", $val);
      } while ($oldval != $val);
    }

    $array[$key] = $val;
  }

  return $array;
}


7
When you edit .php files, make sure you save them in ASCII not in UTF8 (Unicode)

Thanks V@no, I have saved in ASCII, but you didn't say if it's safe or not to comment out line 135 in global.php ??? Is it okay to do so?

8
I keep getting the following error:

Warning: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset 1078737888 in /home/httpd/vhosts/mydomain.com/httpdocs/4images/global.php on line 135

There was one other case like this I found on the forum, but the solution didn't work in my case.

QUESTION: Will it pose a security problem if I comment out line 135 in global.php  (When I comment this line out, I don't get the error anymore).

9
Language Packs / Re: Where to find Persian language pack?
« on: May 10, 2005, 09:39:20 PM »
I did a little search and found this link, but I'm not sure if this is what you want. I saw a farsi lang in the zip. You may also want to make sure that this site is authorized to provide the language pack...

Can anyone from this forum verify the site below is authorized??

http://www.negarkhane.com/downloads.php

thanks.

11
okay everyone...thanks for you help. I didn't know it as easy as just creating a template for .txt or .html.  :oops:

 :)

12
Is there a way to show .txt or .html files in the details page. Like when users upload an image file...what if they upload a txt file. I would like to be able to have detail page show the content of the txt file or the html file....can someone help. thanks

13
Discussion & Troubleshooting / Re: Mass upload?
« on: June 06, 2003, 02:54:44 AM »
Quote from: Asso
Hi, i've up to 1500 images to upload in my 4images but there isn't the mass upload?! I must upload one by one photo?

thanks!


Nothing beats this way to upload so many images you have:


http://www.4homepages.de/forum/viewtopic.php?t=3080

14
Discussion & Troubleshooting / How to add to the clickstream?
« on: June 03, 2003, 03:03:31 PM »
Here's a link where it explains how to do it:

http://www.4homepages.de/forum/viewtopic.php?t=4996

15
Chit Chat / OT - German 'Blue Laws'
« on: May 28, 2003, 11:08:08 PM »
You know, this just gave me a great idea. I'll go to Europe and I'll come back without buying anyone anything. Then I'll just say:

"Darn! The shops where closed on Sunday which I was planning to buy souveniers."

 :lol:

Pages: [1] 2 3 4
Post your comments here