Author Topic: [MOD]On Klick Prev / Next Images  (Read 106874 times)

0 Members and 1 Guest are viewing this topic.

Offline zimba

  • Newbie
  • *
  • Posts: 33
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #45 on: April 12, 2012, 02:50:33 PM »
Schade, das AjaxRating wäre schon sehr sexy - hast du eventuell einen anderen Tipp für mich, eventuell kann ich ein anderes AJAX Rating einbauen bzw. ein anderes Java als das von yahoo... Thanks

Offline zimba

  • Newbie
  • *
  • Posts: 33
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #46 on: May 10, 2012, 10:34:38 PM »
Der Pfeil entfernt sich von vom Mauszeiger je nach Browserbreite. Hat wer ne Idee wie ich das fixen kann ?

 navi.style.left = (x - 260) + "px";

Danke



------> Erledigt

<div class="tooltip" id="tt1">{lang_prev_image}</div>
<div class="tooltip" id="tt2">{lang_next_image}</div>

im Header unter <body> plaziert

und in der CSS bei .tooltip z-index:1000 vergeben.
« Last Edit: May 16, 2012, 10:53:53 PM by zimba »

Offline Ersen

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #47 on: June 17, 2012, 11:44:42 PM »
i cant see any right or left button in image? How can i add this?

For example

Offline Thorgrim

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #48 on: May 22, 2013, 02:38:57 PM »
Hallo und guten Tag. Hab gestern den MOD eingebaut (Version 1.7.11) und hab da ein recht interessantes Phänomen.

Mit meinem Galaxy S3 und meinem Tablet funzt alles gut. Aber bei meinem Laptop und meinem Rechner auf der Arbeit, da kann ich klicken bis die Maus kaputt geht, die Bilder springen nicht vor und zurück. Zudem flackert die Schrift, wenn ich den Mauszeiger über die Navigationsbereiche ziehe.

Hat da wer eine Idee?

LG
Moritz

Rembrandt

  • Guest
Re: [MOD]On Klick Prev / Next Images
« Reply #49 on: May 22, 2013, 04:03:47 PM »
Willkommen im Forum!
...und hab da ein recht interessantes Phänomen.
...
Mir ist nichts dergleichen bekannt, und ich habe den mod schon auf einigen Webseiten eingebaut.
kannst du den "Fehler" auch auf dieser Webseite sehen?... b.z.w sag mal die Webseite wo man sich das ansehen kann.

mfg Andi

Offline Thorgrim

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #50 on: May 22, 2013, 08:59:03 PM »
Hallo Andi.

Vielen Dank und danke für deine Unterstützung.

Auf der verlinkten Seite tritt das nicht auf.

Zu sehen ist das unter http://hghb.noezserv.de

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.287
    • View Profile
    • Discover the New World of Kindersurprise
Re: [MOD]On Klick Prev / Next Images
« Reply #51 on: May 22, 2013, 09:04:34 PM »
hmm, habe es getestet, bei mir klappt es unter dem Link
Danke Harald




Offline Thorgrim

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #52 on: May 22, 2013, 09:41:11 PM »
Ich versteh das nicht. Ich hab das jetzt an 3 PC's getestet. Laptop und PC auf der Arbeit mit XP, und mein Rechner Zuhause mit Win7. Bei allen drei geht es nicht. Was mach ich denn falsch?

Offline sugersgroer

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #53 on: May 22, 2013, 11:29:54 PM »
Nabend,
ich hab mir den Mod auch eingebaut, allerdings mit der Pfeil Version. Das klicken etc. funktioniert allerdings habe ich auch nur ein flackern wenn ich mit der Maus drüber gehe. Es erscheint kein Pfeil und auch kein Tooltipp.
Habe den Code auch extra drei mal geprüft.
Verwende auch die 1.7.11
Jemand ne Idee was das sein kann?
Achja als Browser verwende ich den IE, Chrome und FF und bei keinem funktioniert es.
Am Handy funktioniert der Mod gar nicht mit dem Chrome.

Hoffe auf etwas Hilfe :-)

LG

Rembrandt

  • Guest
Re: [MOD]On Klick Prev / Next Images
« Reply #54 on: May 23, 2013, 05:26:24 AM »
Willkommen im Forum!
....allerdings habe ich auch nur ein flackern wenn ich mit der Maus drüber gehe....
....
@All, wenn bei euch der Mauszeiger flackert, müßt ihr einen niedrigeren "y" wert angeben.
Versucht es mal mit:
 
Code: [Select]
y - 20
mfg Andi

Offline sugersgroer

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #55 on: May 23, 2013, 01:28:47 PM »
Danke Andi :-)

<script type="text/javascript">
<!--
navi null;
 
document.onmousemove updateNAVI;
 function 
updateNAVI(e) {
  if (
navi != null) {
    
= (document.all) ? window.event.navi.offsetParent.scrollLeft e.pageX;
    
= (document.all) ? window.event.navi.offsetParent.scrollTop  e.pageY;
    
navi.style.left = (40) + "px";
    
navi.style.top   = (10) + "px";
  }
}
 
function 
showNAVI(id) {
  
navi document.getElementById(id);
  
navi.style.display "block"
}
 
function 
hideNAVI() {
  
navi.style.display "none";
}
//-->
</script>


Die Idee hatte ich auch schon. Ich hab da einen wert von 10 und es ändert sich absolut nichts.
Hatte ein Originalwert von dir mit 15 drin stehen.
Weitere Ideen?


EDIT: So das flackern habe ich nun weg bekommen mit einem y Wert von 30. Allerdings werden nach wie vor keine Tooltips oder Pfeile angezeigt. Habe beide Versionen ausprobiert :-(
Kann eigentlich nur mit der Stelle in den Details zusammen hängen
 {if msg}<b>{msg}<br />
                  <
br />
                  </
b>{endif msg}
                  <
div class="tooltip" id="tt1">{lang_prev_image}</div>
                  <
div class="tooltip" id="tt2">{lang_next_image}</div>
                  <
div align="center"
	
	
	
	
	
	
	
	
	
	
<
div style="width:{width}px;height:{height}px; border:10px solid white; box-shadow:0px 0px 12px -5px black; margin:10px">{image}<map name="navi">
{if 
prev_image_name}
  <
area shape="rect" coords="0,0,{navi},{height}"   href="{prev_image_url}" onmouseover="showNAVI('tt1')" onmouseout="hideNAVI()" alt="{prev_image_name}">
{endif 
prev_image_name}
{if 
next_image_name}
  <
area shape="rect"  coords="{navi},0,{width},{height}"  href="{next_image_url}" onmouseover="showNAVI('tt2')" onmouseout="hideNAVI()" alt="{next_image_name}">
   {endif 
next_image_name}
</
map></div>
	
	
	
	
	
	
	
	
	
	
{if 
admin_links}<br />
                    {
admin_links}<br />
                    {endif 
admin_links}<br />


Hab ich da irgendwo nen Fehler? Ich seh auf den ersten Blick keinen.

LG
« Last Edit: May 23, 2013, 01:48:55 PM by sugersgroer »

Rembrandt

  • Guest
Re: [MOD]On Klick Prev / Next Images
« Reply #56 on: May 23, 2013, 04:19:38 PM »
...
Die Idee hatte ich auch schon. Ich hab da einen wert von 10 und es ändert sich absolut nichts.
Hatte ein Originalwert von dir mit 15 drin stehen.
Weitere Ideen?
...
ja, meine vorigen post lesen, stell den wert auf -20 oder noch niedriger ein, der Effekt(Zittern) tritt ein sobald der Mauszeiger die Schrift berührt.

Offline sugersgroer

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #57 on: May 23, 2013, 04:42:38 PM »


Die Idee hatte ich auch schon. Ich hab da einen wert von 10 und es ändert sich absolut nichts.
Hatte ein Originalwert von dir mit 15 drin stehen.
Weitere Ideen?


EDIT: So das flackern habe ich nun weg bekommen mit einem y Wert von 30. Allerdings werden nach wie vor keine Tooltips oder Pfeile angezeigt. Habe beide Versionen ausprobiert :-(
Kann eigentlich nur mit der Stelle in den Details zusammen hängen


Hallo Andi,
deinen Post habe ich gelesen nur wie ich bereits sagte, das zittern ist nur weg wenn der Wert bei 30 oder höher liegt. Wenn ich diesen tiefer stelle flackert es sofort wieder und es erscheint auch dann weder Pfeil noch Tooltip.
Mit deinem Wert von 20 habe ich es getestet aber auch da ein flackern.

Könnte es vielleicht auch daran liegen das die Bilder keine 800x600 sind? Wobei ich da gelesen habe das dies gefixt sein sollte?

LG

Rembrandt

  • Guest
Re: [MOD]On Klick Prev / Next Images
« Reply #58 on: May 24, 2013, 05:43:53 AM »
.... das zittern ist nur weg wenn der Wert bei 30 oder höher liegt. ....
du meinst wenn der Wert bei  minus 30 oder niedriger liegt, dann stell ihn halt noch niedriger ein z.b. minus 35, das ist doch sch***egal.

Offline sugersgroer

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [MOD]On Klick Prev / Next Images
« Reply #59 on: May 24, 2013, 02:56:59 PM »
Uff.... ja habe ich doch getan aber deswegen kommt dennoch weder ein Tooltip noch ein Image für die Pfeile, egal welche Version ich da einbaue bzw. sind ja nur zwei Zeilen zu ändern.

LG

 

Post your comments here