Author Topic: [Mod] Multiupload V.3.1.1  (Read 108786 times)

0 Members and 1 Guest are viewing this topic.

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #30 on: March 07, 2011, 05:02:47 PM »
... Nach dem Upload werden nicht die Original-Dateien angezeigt, sondern nur die Thumbnails vergrößert angezeigt,....
die original dateien werden auch nicht angezeigt, nur die thumbnails.
schau mal nach was du du in deiner media/jpg.html drinnen steh hast.

Offline excursionista

  • Pre-Newbie
  • Posts: 5
    • View Profile
Re: [Mod] Multiupload V.3.1.1
« Reply #31 on: March 20, 2011, 12:49:26 PM »
Hello,
I try this MOD, and it's very useful for me.
But I have a problem, when a user logout from multiupload page, then apears this error page:

Server Error in Application "995_xxxxxxxxxxxxxxxx.COM"Internet Information Services 7.0
Error Summary
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable. Detailed Error Information
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL xxx: xxx: xxxxxxxxxxxxxx: :80/FotosACA/member_multi_upload. php&cat_id=3
Physical Path D:\XVRT\xxxxxxxxxxxxxx.com\Html\FotosACA\member_multi_upload.php&cat_id=3
Logon Method Anonymous
Logon User Anonymous
 Most likely causes:
•The directory or file specified does not exist on the Web server.
•The URL contains a typographical error.
•A custom filter or module, such as URLScan, restricts access to the file.
 Things you can try:
•Create the content on the Web server.
•Review the browser URL.
•Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.
 Links and More InformationThis error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

What can I do? Thanks in advance, and sorry for my englhish,     Xavier

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #32 on: March 20, 2011, 02:54:05 PM »
Welcome to the Forum!

step 3.) have you done in your lanuage?

mfg Andi

Offline excursionista

  • Pre-Newbie
  • Posts: 5
    • View Profile
Re: [Mod] Multiupload V.3.1.1
« Reply #33 on: March 20, 2011, 07:34:21 PM »
Thank you for your fast response.
Yes, I create a new file "multi_upload_notify.html", and estore in lang/my lang/email. But the problem is when user is in "multiupload page", and he click "logout" from this page.
Thank you in advance,
Xavier

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #34 on: March 20, 2011, 07:50:33 PM »
.... and he click "logout" from this page.
...
ah ..ok..
search in root/logout.php:

if (!preg_match("/index\.php/"$url) && !preg_match("/lightbox\.php/"$url) && !preg_match("/login\.php/"$url) && !preg_match("/register\.php/"$url) && !preg_match("/member\.php/"$url)) {
  
redirect($url);
}

and replace:

if (!preg_match("/index\.php/"$url) && !preg_match("/lightbox\.php/"$url) && !preg_match("/login\.php/"$url) && !preg_match("/register\.php/"$url) && !preg_match("/member\.php/"$url) && !preg_match("/member_multi_upload\.php/"$url)) {
  
redirect($url);
}


mfg Andi

Offline excursionista

  • Pre-Newbie
  • Posts: 5
    • View Profile
Re: [Mod] Multiupload V.3.1.1
« Reply #35 on: March 20, 2011, 08:45:38 PM »

Very good!!! Thank you very much, I tried it, and it works very well. Fantastic.
Thank's,

Xavier

Offline Scarala

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • www.MPS-Fotos.de - Die MPS-Fotocommunity
Re: [Mod] Multiupload V.3.1.1
« Reply #36 on: April 29, 2011, 07:28:58 AM »
Gibt es eine möglichkeit, in der Member_multi_upload.php die Zeile
  $num_new .=  "<tr>\n<td class=\"row1\"><b>".$lang['num_addnewimages']."</b></td>\n";
zu löschen und dafür am ende der Upload-Tabelle einen Button "Uploadfeld hinzufügen" einzufügen, so, dass die Seite nicht neu geladen wird? Denn wenn man jetzt die Anzahl der Felder doch noch mal verändert, dann sind alle Eingaben weg.

Oder gibt es alternativ die Möglichkeit, das er nicht genutzte Upload-Felder nicht beachtet? Denn jetzt gibt er nen Upload-fehler, wenn ein Dateifeld leer ist...

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #37 on: April 29, 2011, 07:42:04 AM »
Willkommen im Forum!
...zu löschen und dafür am ende der Upload-Tabelle einen Button "Uploadfeld hinzufügen" einzufügen, so, dass die Seite nicht neu geladen wird? Denn wenn man jetzt die Anzahl der Felder doch noch mal verändert, dann sind alle Eingaben weg.

Oder gibt es alternativ die Möglichkeit, das er nicht genutzte Upload-Felder nicht beachtet? Denn jetzt gibt er nen Upload-fehler, wenn ein Dateifeld leer ist...
zu deiner ersten frage, über das habe ich mir auch schon gedanken gemacht, mal sehn...

zu deiner zweiten frage, pflichtfeld ist ja eh nur der "bildname" und der wird für die galerie benötigt.

mfg Andi

Offline Scarala

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • www.MPS-Fotos.de - Die MPS-Fotocommunity
Re: [Mod] Multiupload V.3.1.1
« Reply #38 on: April 29, 2011, 07:49:53 AM »
Kann man denn nicht ne Abfrage einbauen? So, dass, wenn das dateifeld leer ist, das Bildname-Feld kein Pflichtfeld mehr ist? Dann müsste das doch eigentlich gehen...

Kann leider nicht selbst programmieren...

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #39 on: April 29, 2011, 07:30:14 PM »
Kann man denn nicht ne Abfrage einbauen? So, dass, wenn das dateifeld leer ist, das Bildname-Feld kein Pflichtfeld mehr ist? Dann müsste das doch eigentlich gehen...
..
ich habe im eingangspost schritt 6.) dahingehen editiert das wenn das "Feld" "Bildname:" leer ist, das der Dateiname als Bildname verwendet wird.

mfg Andi

Offline Scarala

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • www.MPS-Fotos.de - Die MPS-Fotocommunity
Re: [Mod] Multiupload V.3.1.1
« Reply #40 on: April 29, 2011, 08:29:41 PM »
Auch nicht schlecht, aber nicht ganz das, was ich brauche  :wink:

Quote
Kann man denn nicht ne Abfrage einbauen? So, dass, wenn das dateifeld leer ist, das Bildname-Feld kein Pflichtfeld mehr ist? Dann müsste das doch eigentlich gehen...

Deine Anderung machts ja im Enteffekt umgekehrt und bringt mir nux gegen den Uploadfehler bei leeren Uploaddatei-Feldern... Also, dass er dann, wenn ein Uploaddatei-Feld leer ist, er Das ganze Formular ignoriert beim hochladen...

Würd mich freuen, wenn man das hinbekommt...

MFG

Scarala

Offline Warrior

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
    • Lawrence Family History
Re: [Mod] Multiupload V.3.1.1
« Reply #41 on: May 06, 2011, 12:56:34 AM »
Does this work with the Image Resize/Big Folder MOD?

Offline mmarschner

  • Newbie
  • *
  • Posts: 15
    • View Profile
    • Motoly
Re: [Mod] Multiupload V.3.1.1
« Reply #42 on: May 08, 2011, 07:27:47 PM »
Hallo Rembrandt,

ich habe mir heute 4images 1.7.10 installiert und das funktioniert einwandfrei. Dann habe ich die Anpassungen für Multiupload so vorgenommen, wie Du es beschrieben hast. Danach habe ich einige Fehler, die ich so nicht finden kann und einmal Deine Ideen dazu haben möchte.

Am Ende der Uploadseite sollte ein Bestätigungscode angezeigt werden. Bei mir ist das Feld aber leer, bzw. es wird das kleine rote Kreuz oben links angezeigt  :cry:. Dieser Fehler tritt auch bei dem Einzelupload auf.

Im Administratorenpanel bekomme ich verschiedene Fehlermeldungen im Kopf angezeigt:

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/motoly.de/httpdocs/gallerie/lang/deutsch/main.php:1) in /var/www/vhosts/motoly.de/httpdocs/gallerie/admin/admin_functions.php on line 179

Die Meldung erscheint 5 mal bis .... line 183.

Weiterhin sind im Administratorenpanel alle Umlaute durch Sonderzeichen ersetzt. Dieses Problem tritt bei mir auch bei der Auswahl der englischen Spachversion auf (Bestätigungscode und Fehler im Adminpannel.

Hast Du eine Idee woran das liegen kann.

Fragende Grüße aus Hamburg von Michael
Wozu brauchen wir Kernkraftwerke - fahrt doch lieber alle Rad.

MotOly - die Domäne für Motorradfahrer, die mit Olympus fotografieren.

Rembrandt

  • Guest
Re: [Mod] Multiupload V.3.1.1
« Reply #43 on: May 09, 2011, 06:11:14 AM »
Willkommen im Forum!

zu der meldung "Warning: Cannot modify header information - headers already sent by"
http://www.4homepages.de/forum/index.php?topic=3378.msg13854#msg13854

zu dem rest, hast du die dateirechte am server alle richtig gesetzt?
siehe dazu root/docs/Installation.deutsch.txt
alternativ dazu kannst du das ausprobieren:  http://www.4homepages.de/forum/index.php?topic=27810.0

mfg Andi

Offline mmarschner

  • Newbie
  • *
  • Posts: 15
    • View Profile
    • Motoly
Re: [Mod] Multiupload V.3.1.1
« Reply #44 on: May 10, 2011, 08:59:02 PM »
Hallo Andi,

erst mal danke für die Informationen. Ich habe alles noch einmal kontrolliert, die Änderungen in Originaldateien noch einmal händisch eingetragen - nicht kopiert -, Deine Anweisungen befolgt, aber ich habe immer noch das Problem im Adminpanel und in der Gallerie. Dort bekomme ich folgende Meldung, bevor ich mich anmelde über dem Seitenkopf:

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/motoly.de/httpdocs/gallerie/lang/deutsch/main.php:1) in /var/www/vhosts/motoly.de/httpdocs/gallerie/includes/sessions.php on line 101

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/motoly.de/httpdocs/gallerie/lang/deutsch/main.php:1) in /var/www/vhosts/motoly.de/httpdocs/gallerie/includes/sessions.php on line 101

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/motoly.de/httpdocs/gallerie/lang/deutsch/main.php:1) in /var/www/vhosts/motoly.de/httpdocs/gallerie/includes/sessions.php on line 101

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/motoly.de/httpdocs/gallerie/lang/deutsch/main.php:1) in /var/www/vhosts/motoly.de/httpdocs/gallerie/includes/functions.php on line 114

 Und wenn ich mich dann angemeldet habe, bekomme ich nur noch eine leere Seite angezeigt. Vielleicht kannst Du einmal über die Dateien drüberschauen. Ich bin der Meinung dass so alles ist, wie es sein soll.

Ein "verzweifelnder" Michael :-)
Wozu brauchen wir Kernkraftwerke - fahrt doch lieber alle Rad.

MotOly - die Domäne für Motorradfahrer, die mit Olympus fotografieren.