• [MOD] Media sites v1.11.1 (2010-12-22) 5 0 5 1
Currently:  

Author Topic: [MOD] Media sites v1.11.1 (2010-12-22)  (Read 314556 times)

0 Members and 1 Guest are viewing this topic.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [MOD] Media sites v1.4 (2009-03-11)
« Reply #30 on: March 19, 2009, 03:38:34 AM »
I've never heard of this site, even though I just added support for it into upcoming v1.5, but I need test it more, the site seem doesn't have same URL structure for each media...
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline ras221

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: [MOD] Media sites v1.4 (2009-03-11)
« Reply #31 on: March 19, 2009, 03:21:13 PM »
Hi, i am new to this php stuff, but felt fairly good about changing my gallery to do this mod, mainly for youtube only. the problem i am having is where is the attached zip files??? i.e. media_sites.zip and media_sites_templates_and_icons.zip packages??? and what do you mean by copy all files from template/default/icons/ folder to templates/<your template>/icons/?? this is the error i am getting now Warning: Cannot modify header information - headers already sent by (output started at /home/owyheeou/public_html/gallery/includes/media_sites.php:379) in /home/owyheeou/public_html/gallery/includes/sessions.php on line 101

Warning: Cannot modify header information - headers already sent by (output started at /home/owyheeou/public_html/gallery/includes/media_sites.php:379) in /home/owyheeou/public_html/gallery/includes/sessions.php on line 101

Fatal error: Call to undefined function media_sites_bbcode() in /home/owyheeou/public_html/gallery/includes/functions.php on line 744


I have done everything exact for the mod well i thought. can you mabe explan in simple words lol?

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [MOD] Media sites v1.4 (2009-03-11)
« Reply #32 on: March 19, 2009, 03:50:35 PM »
Welcome to 4images forum.

Ok, I've renamed the filenames in the the instructions, hope it's less confusing then used to.

The files you need to download are located at the very end of the first post in this topic. I put version number into filenames.
As of the error messages, media_sites.php file does not have 379 lines, so I have no clue what is in your media_sites.php file and where you got it from...

as of copying all files, if you open up the template and icons package, you should find there many files inside folders. i.e.:

templates/default/icons/youtube.gif (this is a media icon for youtube site)
...
templates/default/media/mtv.html (this is a media template for mtv site)
...

you need copy all these files into same folder in your 4images template.
As example, lets say you are using a custom template "blah21"
the path to your template will be:
templates/blah21/
inside your template should have "media" and "icons" folders

so the two files above should be copied into:
templates/blah21/icons/youtube.gif (this is a media icon for youtube site)
...
templates/blah21/media/mtv.html (this is a media template for mtv site)
...
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline ras221

  • Pre-Newbie
  • Posts: 2
    • View Profile
Re: [MOD] Media sites v1.4 (2009-03-11)
« Reply #33 on: March 19, 2009, 04:48:49 PM »
I got it to work, it was a bit confusing on the 1st upload but understand it now. thanks

check it out http://www.owyheeoutlaws.com/gallery/index.php    :D  :D  :D

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #34 on: March 21, 2009, 10:34:18 PM »
Changes in v1.5:
Code: (changes) [Select]
- Fixed: problem with RSS feed when media site was used in a comment
- Fixed: sometimes additional options in the URL didn't work (width/height/autoplay)
- Fixed: metacafe.com didn't obey autoplay url option
- Fixed: mtv.com didn't obey autoplay options
- Added: width/height limit for BBCode
- Added: addresses to media sites home page
- Added: control for autoplay in ACP
- Added: sevenload.com support
- Added: auto thumbnails for youtube, metacafe, stupidvideos, yahoovideo, myspacevideo, liveleak, spikedhumor, myvideo.de, rutube.ru, dailymotion.com, mtv.com
- Changed: dailymotion.com doesn't require address from <embed> anymore
- Changed: break.com doesn't require address from <embed> anymore
- Changed: hulu.com doesn't require address from <embed> anymore

The thumbnail fetching only works when media sites added via members upload form, no ACP support as of yet. I only tested on PHP5 and with no SAFE MODE.
If you have problem with this feature, turn off thumbnail fetching via:
define("MEDIA_THUMB"1); //fetch thumbnails? set to 0 if you receive errors.

Thumbnail fetching doesn't work on already added media sites!


Update from v1.4 to v1.5 instructions:

1) re-do Step 1 and Step 4
2) apply Step 5.1
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline praveen

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #35 on: April 11, 2009, 08:37:28 AM »
Hi,

thank you for the mod.

i am trying to add a video from youtube and i am kind of stuck.

in the add images, URL:
what should i add?

do i have to add like this:
http://www.youtube.com/watch?v=LvF5yzRsUgw

or
<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/LvF5yzRsUgw&hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/LvF5yzRsUgw&hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>


please advise

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #36 on: April 11, 2009, 03:56:06 PM »
Hello and welcome to 4images forum.

So far the only media site that requires use of <embed> is the stupidvideos.com
All others, including youtube, can use direct url from address bar.
other words use http://www.youtube.com/watch?v=LvF5yzRsUgw
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline praveen

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #37 on: April 11, 2009, 04:20:46 PM »
Thank you :)

i added the url as u said, but when i try to view the video nothing shows up.

the detail page has the following youtube code without the video id.

Quote
<object
  width="480"
  height="295"
>
   <param name="movie" value="http://www.youtube.com/v/&fs=1&autoplay=" />
   <param name="allowFullScreen" value="true" />
   <param name="allowscriptaccess" value="always" />
   <param name="autoplay" value="" />
   <embed
     width="480"
     height="295"
     src="http://www.youtube.com/v/&fs=1&autoplay="
     type="application/x-shockwave-flash"
     allowscriptaccess="always"
     allowfullscreen="true"
   ></embed>
</object>

am i missing anything?

here is a screenshot of the admin
http://i42.tinypic.com/2ih9x03.jpg

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #38 on: April 11, 2009, 05:09:14 PM »
You must have skipped a step or two. Double check each step from the installation instructions.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline praveen

  • Newbie
  • *
  • Posts: 36
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #39 on: April 12, 2009, 06:16:26 AM »
my mistake.

instead adding a code above, i added it below.

now it works fine.

Thank you :)

Offline Fryz

  • Jr. Member
  • **
  • Posts: 74
    • View Profile
    • Fryz' Media Galerie
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #40 on: May 05, 2009, 05:00:35 PM »
Hallo Leute, mal ne Frage: Steht dieser Mod nicht mehr zur verfügung? Der "Download attached" funktioniert nicht :-(

Offline mawenzi

  • Moderator
  • 4images Guru
  • *****
  • Posts: 4.500
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #41 on: May 05, 2009, 05:18:15 PM »
@Fryz

... für mich arbeitet der Download der beiden zip-Dateien perfekt ...
Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...

Offline Fryz

  • Jr. Member
  • **
  • Posts: 74
    • View Profile
    • Fryz' Media Galerie
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #42 on: May 05, 2009, 05:31:04 PM »
*autsch*

Danke mawenzi...

ich war nicht eingeloggt... *schäm*

Offline nl2dav

  • Pre-Newbie
  • Posts: 7
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #43 on: May 11, 2009, 02:14:10 PM »
Superb, nice work!

Offline qBass17

  • Addicted member
  • ******
  • Posts: 1.800
  • I ♥ 4I
    • View Profile
Re: [MOD] Media sites v1.5 (2009-03-21)
« Reply #44 on: June 11, 2009, 04:26:16 AM »
Hallo,

..... was genau macht diese MOD?
..... Geht das alles nur über das ACP?
..... Werden die Videos via Link oder Embedcode eingefügt?

..... Verstehe die Modifikation irgendwie grad nicht. Sieht sehr interessant aus, aber ich kann mir gerade nichts darunter vorstellen.

 

Post your comments here