• [Mod] Image Annotation (Watermark) 2 0 5 1
Currently:  

Author Topic: [Mod] Image Annotation (Watermark)  (Read 922537 times)

0 Members and 1 Guest are viewing this topic.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[Mod] Image Annotation (Watermark)
« Reply #90 on: March 12, 2003, 09:59:43 PM »
Quote from: KSA

/home/virtual/site178/fst/var/www/html/4images/arial.ttf

arial.ttf  ASCII  or Binary

 
Binary.

Quote from: KSA
copy font you want to use into your 4images root and set this path in config ?????

no, in AdminControlPanel -> Settings. U should find new options for Annotion at the bottom of the Settings.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline SLL

  • Hero Member
  • *****
  • Posts: 585
    • View Profile
Re: Works fine in LINUX Part II
« Reply #91 on: March 13, 2003, 09:00:16 AM »
Quote from: knuckles
1- apache must be owner of data directory (and chmod'd to 777 or 755)

I believe, this is by default, otherwise 4images won't work at all?

And one more remark (from php.net):
Quote
fontfile: The name of the TrueType font file. (Can also be an URL.) Depending on which version of the GD library that PHP is using, it may attempt to search for files that do not begin with a leading '/' by appending '.ttf' to the filename and searching along a library-defined font path.

Offline KSA

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #92 on: March 13, 2003, 01:09:13 PM »
No problem . with that Not Working ??  :cry:

Offline KSA

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #93 on: March 14, 2003, 11:30:04 PM »
directory chmod 777

and

file  chmod 755


OR

Not chmod

Offline KSA

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #94 on: March 16, 2003, 04:40:46 PM »
WORKING ............  8)

THANK YOU!!

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #95 on: March 25, 2003, 02:58:19 PM »
hello,

i tried to run the MOD and all i have, are some problems, maybe you can help me??!!
i studied this 7 sites about 3 times, but i didn't found the solution for my special probs!! :-(

in control panel/settings i only can see the right columns of the annotation settings, the descriptions (left) are not visible -- i checked all code of the edited files, but i cant find the reason.
any tips for me ???

are there any files, of your sites, i can try to use ??
please send these files with email to this adress: yogen@gmx.de
maybe this could be the solution !!

thnx for your help !!!

Yogen

Offline SLL

  • Hero Member
  • *****
  • Posts: 585
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #96 on: March 25, 2003, 03:08:39 PM »
probably you've forgotten to run installer, so your database is not modifyed yet. also, if you're using lanuage files other than english, check if you've added all neccessary lines there

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #97 on: March 25, 2003, 03:31:14 PM »
hmmm, no , i did all you wrote in the description ... but, i edited and uploaded all files BEFORE i run the installer ;-))
may, this is the problem ??

which new fields must i find in the DB, if all is correct installed ?

thx for help !!

Yogen

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[Mod] Image Annotation (Watermark)
« Reply #98 on: March 25, 2003, 10:59:57 PM »
Quote from: Yogen
in control panel/settings i only can see the right columns of the annotation settings, the descriptions (left) are not visible --

did u do this step of installation?:
Quote
#
#-----[ OPEN ]----------------------------------------
#

/4images/lang/english/admin.php

#
#-----[ FIND ]----------------------------------------
#

$setting['display_whosonline'] = "Display \"Who's Online\". Only visible for admins when deactivated.";
$setting['highlight_admin'] = "Display admins bold in \"Who's online\" ";

#
#-----[ AFTER ADD ]------------------------------------
#

/*-- Setting-Group 8 --*/
$setting_group[8]="Images Annotation settings";
$setting['annotation_use'] = "Use auto images annotation on image upload";
$setting['annotation_font'] = "Annotation font<br /><span class=\"smalltext\">Specify full path and font filename</span>";
$setting['annotation_font_size'] = "Annotation font size";
$setting['annotation_use_shadow'] = "Use letter shadows";
$setting['annotation_shadow_offset'] = "Shadow offset (same right and down)";
$setting['annotation_image_quality'] = "Resulting image quality (in per cent)";
$setting['annotation_text'] = "Annotation message";
$setting['annotation_fill_color'] = "Annotation text fill color<br /><span class=\"smalltext\">Define HEX value, for example #FFFFFF. Have a look at <a target=\"_blank\" href=\"color.html\">color samples</a></span>";
$setting['annotation_shadow_color'] = "Annotation text shadow color<br /><span class=\"smalltext\">Define HEX value, for example #000000. Have a look at <a target=\"_blank\" href=\"color.html\">color samples</a></span>";
$setting['annotation_fill_alpha'] = "Fill color alpha blending (transparency)<br /><span class=\"smalltext\">Alpha blending value must be between 0.0 and 1.0&nbsp;&nbsp;&nbsp;&nbsp;0.0 = no transparency</span>";
$setting['annotation_shadow_alpha'] = "Shadow color alpha blending (transparency)<br /><span class=\"smalltext\">Alpha blending value must be between 0.0 and 1.0&nbsp;&nbsp;&nbsp;&nbsp;0.0 = no transparency</span>";
$setting['annotation_v_alignment'] = "Vertical annotation message alignment";
$setting['annotation_h_alignment'] = "Horizontal annotation message alignment";
$annotation_v_positioning_optionlist = array(
  "top"  => "image top",
  "bottom" => "image bottom"
);
$annotation_h_positioning_optionlist = array(
  "left"  => "left image edge",
  "middle"  => "image middle",
  "right" => "right image edge"
);
$setting['annotation_top_offset'] = "Top annotation message offset";
$setting['annotation_bottom_offset'] = "Bottom annotation message offset";
$setting['annotation_left_offset'] = "Left annotation message offset";
$setting['annotation_right_offset'] = "Right annotation message offset";
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #99 on: March 26, 2003, 12:53:39 PM »
yes, i did, but in:   /4images/lang/deutsch/admin.php
and the admin fields are there, but only the right side of them.

can it be possible that the installing after loading up the edited files is the reason ?
i uploaded the files many times to be sure that no error in accepting the changes is possible.

should i do the hole steps again ??
which DB-fields are new if it all is correct ?

thnx for help ....!!!!!

Yogen

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[Mod] Image Annotation (Watermark)
« Reply #100 on: March 26, 2003, 01:12:16 PM »
Quote from: Yogen
yes, i did, but in:   /4images/lang/deutsch/admin.php

that's probably obvious, but to be sure:
is all your ACP shows in deutsch?

the installation file doesnt do more then just adding new fields into the database, it doesnt metter if u run it before or after.
Another question:
if u change something in those new options u got, and click save, do they actual save what u changed?
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #101 on: March 26, 2003, 01:23:54 PM »
yes, all is in german, and the new fields (right side) of the annotation too!

i edited the annotate.TTF path, the TEXT wich should be placed in the pics, and all that can be saved.

and now ... ;-) ????

Yogen

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #102 on: March 26, 2003, 01:39:10 PM »
i tried, after making a new DB-backup, a re-installation and got following error-messages:

Code: [Select]
DB Error: Bad SQL Query: INSERT INTO 4images_settings () VALUES ('annotation_use', '0')
Duplicate entry 'annotation_use' for key 1

DB Error: Bad SQL Query: INSERT INTO 4images_settings () VALUES ('annotation_font', '/home/4images/annotate.ttf')
Duplicate entry 'annotation_font' for key 1

DB Error: Bad SQL Query: INSERT INTO 4images_settings () VALUES ('annotation_font_size', '10')
Duplicate entry 'annotation_font_size' for key 1

.......


this seems that the fields must be already there !!

i run the batch annotate and got the errors that GD is not 2.0 !!!
this, i knew before, and i said it to my provider, that he will upgrade this !! --->> i'm awaiting the upgrade

but, if GD is not 2.0 -- nevertheless the fields in the CP must be shown, or is this the reason for the missing descriptions ??

greetz

Yogen

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
[Mod] Image Annotation (Watermark)
« Reply #103 on: March 26, 2003, 06:14:06 PM »
the problem is somewhere in the installation...
ok, here is another question:
did u install any other mods?
also, in /lang/deutsch/admin.php make sure there is no duplucation for
Quote
/*-- Setting-Group 8 --*/

but actuly this is nothing to do with the problem...
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Yogen

  • Newbie
  • *
  • Posts: 25
    • View Profile
[Mod] Image Annotation (Watermark)
« Reply #104 on: March 26, 2003, 07:16:51 PM »
hi V@no,

i installed another MOD, but this is only for the lightbox (quotation.php, ...) and has nothing to do with:

/*-- Setting-Group 8 --*/

my provider told me, that next week will be made an upgrade of PHP an GD on all servers. :-)

if you're right with installation probs, so it might be the best way to restore all back to original and then trying installation again ??!!

thnx for all help !! :-)

greetz

Yogen