Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - dereiziger

Pages: [1]
1
Discussion & Troubleshooting / Re: Issue With Search
« on: April 25, 2017, 12:07:25 AM »
anyone?

2
Discussion & Troubleshooting / Issue With Search
« on: April 09, 2017, 05:24:45 PM »
website:  http://globe-trekking.com/vg/gallery
version: 1.8

When I click on a keyword (or type it into the search box, for that matter), it brings back no results, or maybe one or two results. My keywords (When I used the system a long time ago you had to use an _ underscore in place of spaces) might be something like Airbus_A330-200 or PH-AON.

I've also tried removing the _underscore and still get nothing.........



3
Hi Nooby-
Thanks for the help with number of images.

I did try the search, but unfortunately much of the information that comes back is written in German and I do not really understand it, in regards to formatting the date for the Exposure Date/Time. But I will continue to look.

4
I"m not sure what's happened. I went through the mod exactly as written but now everything on my site is jacked. When I load the page it's like the page has become a mirror of itself. Now, as soon as you hover over my menu everything goes haywire....



I have installed both the Facebook mods...  ;-(

http://globe-trekking.com/vg/gallery/details.php?image_id=56

I ended up removing all of the facebook connector information as well as everything from the header.html file that I had added and it works normally again.

I'm still unable to get a photo to show up when I post to facebook. It shows the images that are in my menu bar, however.  ;-\


5
When I put this code in the functions.php

Code: [Select]

//############################ Start EXIF ##############################
        if ($detailed_view ) {
          global $site_db,$lang,$additional_image_fields;
          $additional_field_sql = "";
          foreach ($additional_image_fields as $key => $val){
            $additional_field_sql .= ','.$key;
          }
          $sql = "SELECT image_id".$additional_field_sql."
                  FROM ".IMAGES_TABLE."
                  WHERE image_id = '$image_id'";
          $result = $site_db->query($sql);
          $row = mysql_fetch_object($result);
          $GPSLongitude = $row->image_GPSLongitude;
          $GPSLatitude = $row->image_GPSLatitude;         
          $bgcounter = 0;
          foreach ($row as $key => $val) {
            if ($val != "") {
              $search_key = $key;
              $url_val = '"' . $val . '"';
              $val = (is_numeric($val)) ? round($val,6) : $val;
              $key = str_replace('image_','',($key));
             
              if (isset($lang['exif_'.$key])) {
                $row_bg_number = ($bgcounter++ % 2 == 0) ? 1 : 2;
               
                $site_template->register_vars(array(
                  "exif_value" => "<a href=\"".$site_sess->url(ROOT_PATH."search.php?search_keywords=".urlencode($url_val))."&amp;search_fields=$search_key \">".format_text($val)."</a>",
                  "exif_name" => $lang['exif_'.$key],
                  "row_bg_number" => $row_bg_number,
                  "image_lat" => $GPSLatitude,
                  "image_lon" => $GPSLongitude
                ));
                $exif_info .= $site_template->parse_template("exif_bit");
              }
            }
          }
        }
//########################### End Exif ###################################

in place of this code:
Code: [Select]
if ($detailed_view && $image_info[2] == 2 && function_exists('exif_read_data') && $exif_data = @exif_read_data($src, 'EXIF')) {
          $lens_info = get_lens_info($src);
  $exif_array = get_exif_info($exif_data);
          $bgcounter = 0;
          foreach ($exif_array as $key => $val) {
            $row_bg_number = ($bgcounter++ % 2 == 0) ? 1 : 2;
           
           
            $site_template->register_vars(array(
           
              "exif_value" => format_text($val),
              "exif_name" => $lang['exif_'.$key],
              "row_bg_number" => $row_bg_number
            ));
            $exif_info .= $site_template->parse_template("exif_bit");
          }
        }

I lose my EXIF and Lens information. I'm not savvy enough to combine this information so that it all works.

6
1. I'm trying to figure out how to change the number of new images on the index.php page so that there are maybe 2-3 rows. of new images

2. I'm trying to figure out how I can change the format of the Dates within the ITCP and EXIF data information so that it meets my personal needs. I would like to format such as Month in long format, Day, Year (ie., April 7th, 2017)

Pages: [1]
Post your comments here