Author Topic: PHP 5.3  (Read 7264 times)

0 Members and 1 Guest are viewing this topic.

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
PHP 5.3
« on: September 18, 2009, 03:01:28 PM »
Hallo,

läuft 4images problemlos unter PHP 5.3  :?:

Oder kann es zu Problemen führen.

nobby

Offline baer2009

  • Jr. Member
  • **
  • Posts: 77
    • View Profile
    • Tierfreunde - Portal
Re: PHP 5.3
« Reply #1 on: September 18, 2009, 04:10:31 PM »
Hallo,

läuft 4images problemlos unter PHP 5.3  :?:

Oder kann es zu Problemen führen.

nobby
Hallo nobby, bei mir läuft es unter 5.3 ohne Probleme
gruss baer 2009
Wer ohne Fehler ist der werfe den 1. Stein

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
Re: PHP 5.3
« Reply #2 on: September 18, 2009, 04:15:59 PM »
das ist ja mal eine gute aussage, danke  :thumbup:

mein provider will wohl irgendwann mal umsteigen.

nobby

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: PHP 5.3
« Reply #3 on: September 18, 2009, 04:33:38 PM »
4images v1.7.7 and older are not compatible with php 5.3
It might work, but it will produce few warnings about deprecated functions it's using.


[EDIT]
to clarify my statement, by default 4images might work fine (I can't test it myself at the moment), but it uses set_magic_quotes_runtime() and ereg() functions which are deprecated in php 5.3
It will not produce errors, but might show/log warning messages.
[/EDIT]
« Last Edit: September 18, 2009, 04:51:39 PM by V@no »
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
Re: PHP 5.3
« Reply #4 on: September 18, 2009, 04:39:17 PM »
v@no thanks for the info

Also laut Aussage von V@ano ist 4images 1.7.7 nicht kompatible mit PHP 5.3

Rembrandt

  • Guest
Re: PHP 5.3
« Reply #5 on: September 20, 2009, 04:36:09 PM »
Hi!
..
Also laut Aussage von V@ano ist 4images 1.7.7 nicht kompatible mit PHP 5.3
ich denke mir ein par kleinen änderungen, laüft auch die 1.7.7. mit php5.3.

hier gibt es eine überblick, über die php befehle.

auf meinen server ist zur zeit noch keine php 5.3 verfügbar, sonst würde ich das selber mal versuchen um zu ändern.

mfg Andi

Offline Jan-Lukas

  • Addicted member
  • ******
  • Posts: 1.289
    • View Profile
    • Discover the New World of Kindersurprise
Re: PHP 5.3
« Reply #6 on: September 20, 2009, 05:55:44 PM »
das ist ja mal eine gute aussage, danke  :thumbup:

mein provider will wohl irgendwann mal umsteigen.

nobby

dachte dein Sohn ist dein Provider  :wink:

LG
Danke Harald




Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
Re: PHP 5.3
« Reply #7 on: September 20, 2009, 06:02:48 PM »
Hallo Harald,

ja ist schon richtig...

der hatte mich nur schon mal gefragt.

Er wird wohl bald umsteigen.

nobby