Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kp

Pages: [1]
1
Bug Fixes & Patches / Re: PHP 8 Fix für Liebhaber
« on: August 24, 2021, 11:44:08 AM »
Hallo Zusammen,
habe einen Fix für PHP 8 erstellt, hierbei sind alle Funktionen ohne Einschränkungen wieder nutzbar.
Schaut bitte hier nach: https://www.4homepages.de/forum/index.php?topic=33111.msg168360#msg168360

2
Deutsch siehe weiter unten:
-------------------------------

Because there seems to be no official support anymore I reviewed the code and fixed errors, warnings und deprecated messages for PHP 8.x.
Also errors are fixed wich comes with PHP 7 (SQL backup).
Some functions had to be re-coded because of removed PHP-functions with PHP 8. 
I've tested as much as I could and I couldn't find any error or warning with the new code and it worked for me perfect.
Attached you'll find a zip-file with the changed files. Replace the existing files with them and your gallery should work with PHP 8 and MYSQL.

I spend a lot of time with debugging an find the new code for the needed functions.
 :!: If you think this deserves a bit of respect you could donate me some money to go out with my wife as compensation of my long hours working on that issues ;) So if you want to do so, please donate to  ebay < at > lexow.de

Thank you

-----------------------------------

Da es hier keinen offiziellen Support mehr zu geben scheint (habe auch die Programmieren selbst angeschrieben - ohne Erfolg) habe ich den Code überprüft und die Errors, Warnings und Deprecated Messages von PHP 8.x beseitigt.
Daneben habe ich auch Fehler beseitigt die schon auf PHP 7 nicht mehr funktioniert haben (SQL Backup).
Einige Funktionen musste ich neu/umschreiben da PHP 8 benutzte Funktionen aus den alten Versionen nicht mehr unterstützt.
Ich habe so viel getestet wie möglich um das Script zu prüfen und weitere Fehler zu finden. Stand heute läuft alles einwandfrei bei mir.
Im Anhang findet ihr eine zip-Datei mit den geänderten Dateien. Diese einfach gegen die vorhandenen ersetzen und die Gallery sollte mit PHP 8 und MYSQL funktionieren.

Ich habe viel Zeit mit Debugging und der Suche nach dem neuen Code für die verwendeten Funktionen zugebracht.
 :!: Wenn du denkst, dass verdient etwas Respekt und es dir ein paar Euro wert ist, so würde ich mich über eine kleine Spende freuen mit der ich meine Frau mal zum Essen ausführen kann als Ausgleich für die vielen Arbeitsstunden an den letzten Abenden ;) Wenn dem so ist, dann könnt ihr gerne etwas per Paypal an diese E-Mail-Adresse:  ebay < at > lexow.de   spenden.

Vielen Dank

3
Feedback & Suggestions / Re: 4images 1.8 - Feedback
« on: October 09, 2017, 10:04:45 PM »
So, habe es selbst gelöst.

In der my_sqldb.php steht seit der V1.8 die Zeile:

   mysql_set_charset
('utf8'$this->connection);

Diese Zeile muss auskommentiert oder gelöscht werden.

Die Sache war umso schwerer zu finden, da man sich darauf verlässt, dass, wenn man in der lang/deutsch/main.php den Charactercode einstellt, diese Einstellung auch im gesamten Programm berücksichtigt wird.
Mit dieser Zeile wir die DB aber in jedem Fall auf utf8 eingestellt.
Hier könnte man den Code ggf. etwas optimieren...

Many thanks!!!

Problem 1:
Ich hab allerdings einen fehler beim Text wenn ich auf

 $lang
['charset'] = "UTF-8";


ändere - dann habe ich ein paar "?"  

somit lasse ich
$lang['charset'] = "iso-8859-1";



Hallo,
ich habe im Prinzip das gleiche Problem.
Da meine ganze Seite NICHT in UTF-8 programmiert ist (und es sich auch nicht so ohne weiteres ändern lässt), muss ich die Galerie auf iso-8859-1 oder windows-1252 weiterlaufen lassen.
Leider tritt das Problem auf, dass alle Texte wie Catergorie oder Description etc. die aus der Datenbank gelesen werden, falsch dargestellt werden.
Zum Beispiel wird München als  München ausgegeben.
Ein Umstellen auf UFT-8 macht es wieder richtig, aber der Rest meiner Seite wird dann falsch dargestellt.

Glaubt mir, ich habe schon 2 volle Tage meines Urlaubs mit probieren und debuggen verbracht.
Habe Funktionen wie formattext htmlspechialschars usw. untersucht aber keine Lösung gefunden.
Habe auch z.B. alle 4Image Dateien in ANSI Foirmat konvertiert usw. aber es bringt nichts.

Man kann es sogar schon gut an der Kategorie-Dropdown-Box sehen.
Der oberste Text der aus der PHP selbst kommt heißt korrekt "Kategorie wählen" mit ä
wohingegen die anderen Texte die Fehler bei den Umlauten aufweisen.

Habe jetzt erst mal aus Verzweiflung und Resignation auf V1.7.13 zurück gewechselt.

Hat jemand eine Idee wieso/wo die Texte aus der mysql DB falsch interpretiert werden?

P.S: Kann bei Bedarf auch die Version 1.8 wieder aufspielen.

Schon mal vielen Dank wenn sich jemand dem Problem anehmen kann.

4
Feedback & Suggestions / Re: 4images 1.8 - Feedback
« on: October 05, 2017, 08:37:05 PM »
Many thanks!!!

Problem 1:
Ich hab allerdings einen fehler beim Text wenn ich auf

 $lang
['charset'] = "UTF-8";


ändere - dann habe ich ein paar "?"  

somit lasse ich
$lang['charset'] = "iso-8859-1";



Hallo,
ich habe im Prinzip das gleiche Problem.
Da meine ganze Seite NICHT in UTF-8 programmiert ist (und es sich auch nicht so ohne weiteres ändern lässt), muss ich die Galerie auf iso-8859-1 oder windows-1252 weiterlaufen lassen.
Leider tritt das Problem auf, dass alle Texte wie Catergorie oder Description etc. die aus der Datenbank gelesen werden, falsch dargestellt werden.
Zum Beispiel wird München als  München ausgegeben.
Ein Umstellen auf UFT-8 macht es wieder richtig, aber der Rest meiner Seite wird dann falsch dargestellt.

Glaubt mir, ich habe schon 2 volle Tage meines Urlaubs mit probieren und debuggen verbracht.
Habe Funktionen wie formattext htmlspechialschars usw. untersucht aber keine Lösung gefunden.
Habe auch z.B. alle 4Image Dateien in ANSI Foirmat konvertiert usw. aber es bringt nichts.

Man kann es sogar schon gut an der Kategorie-Dropdown-Box sehen.
Der oberste Text der aus der PHP selbst kommt heißt korrekt "Kategorie wählen" mit ä
wohingegen die anderen Texte die Fehler bei den Umlauten aufweisen.

Habe jetzt erst mal aus Verzweiflung und Resignation auf V1.7.13 zurück gewechselt.

Hat jemand eine Idee wieso/wo die Texte aus der mysql DB falsch interpretiert werden?

P.S: Kann bei Bedarf auch die Version 1.8 wieder aufspielen.

Schon mal vielen Dank wenn sich jemand dem Problem anehmen kann.

Pages: [1]
Post your comments here