4images Help / Hilfe > News & Announcements

4images 1.9

(1/1)

kai:
:flag-en: The new version 4images 1.9 has been released. This release brings full PHP 8 compatibility.
We recommend all users to update to the current version. All changes and features are listed in "docs/Changelog.txt".

:flag-de: Die neue Version 4images 1.9 wurde veröffentlicht. Das Release beinhaltet Anpassung für den Betrieb unter PHP 8.
Wir empfehlen allen Nutzern ein Update auf die aktuelle Version. Alle Änderungen und Features sind in der Datei "docs/Changelog.txt" aufgelistet.

Download:
https://www.4homepages.de/download-4images

Demo:
https://www.4homepages.de/demo

Please use this thread for feedback about the 4images 1.9 version.

Für Feedback zur 4images 1.9 Version bitte diesen Thread nutzen.

kai:
=========================================================
ChangeLog Version 1.9
=========================================================
- PHP8 compatibility

wflorian:
Thank you for the update!

kp:
Found a PHP8 bug in this version.
If I use the function "check for new images" (German: Neue Bilder checken) and there are new images in the chosen category (which I've uploaded upfront via FTP) you will see nothing (because there is a not displayed error).
The problem is in the file admin\checkimages.php at line 836.
Here you have to change
if (!@in_array($image_list_all[$key][$i], $image_list_sql[$key]))
to
if (($result->num_rows == 0) or (!@in_array($image_list_all[$key][$i], $image_list_sql[$key]))) 

If you aren't experienced enough to change this, you can load my attached fixed file and replace it at your webspace.
Would be cool if the 4images guys could add this fix to there 1.9(.1) package.

kp:
Found another PHP8 bug in this version.
The admin-function "Edit images" (German: Bilder bearbeiten) the result is strange when there are no filters set. Sometimes I got 0 images, sometimes 5000 sometimes all of them. This comes from the new handling in misusing a compare of string with an integer.
The problem is in the file admin\images.php at line 664.
Here you have to change
if ($image_id != "") {
to
if ($image_id != 0) {

If you aren't experienced enough to change this, you can load my attached fixed file and replace it at your webspace.
Would be cool if the 4images guys could add this fix to there 1.9(.1) package.

Navigation

[0] Message Index

Go to full version