• [Mod] Avatar v2.01 5 0 5 1
Currently:  

Author Topic: [Mod] Avatar v2.01  (Read 473737 times)

0 Members and 1 Guest are viewing this topic.

Offline AntiNSA2

  • Hero Member
  • *****
  • Posts: 774
  • As long as I can finish my site before I die.
    • View Profile
    • http://www.thelifephotography.com
Re: [Mod] Avatar v2.01
« Reply #390 on: March 01, 2009, 05:25:29 PM »
Hi V@no... happy to see you are still here...

I dont know whats up.. Im using 1.7.6

and getting this:

Parse error: syntax error, unexpected T_DOUBLE_ARROW in /home/lifephotography/htdocs/member.php on line 1352
which is:

"user_email" => format_text(stripslashes($user_email), 2),


together with code that looks like this:


  $site_template->register_vars(array(
   "lang_avatar" => $lang['avatar'],
   "lang_avatar_file" => $lang['avatar_file'],
   "lang_avatar_dim" => $lang['avatar_max_dim']." ".$config['avatar_width']."x".$config['avatar_height'].$lang['px'],
   "lang_avatar_select" => $lang['avatar_select'],
   "user_avatar_images" => $images,
   "user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_avatar == "") ? "blank.gif" : $user_avatar)."\" name=\"icons\" border=\"0\" alt=\"\">" : "",
   "lang_or" => $lang['or'],
   "user_avatar_file" => $config['avatar_user_custom'],
    "user_name" => htmlspecialchars(stripslashes($user_name)), 2),
    "user_email" => format_text(stripslashes($user_email), 2),
    "user_email2" => format_text(stripslashes($user_email2), 2),
    "user_homepage" => format_text(stripslashes($user_homepage), 2),
    "user_icq" => $user_icq,
    "user_showemail_yes" => $user_showemail_yes,
    "user_showemail_no" => $user_showemail_no,
    "user_allowemails_yes" => $user_allowemails_yes,
    "user_allowemails_no" => $user_allowemails_no,
    "user_invisible_yes" => $user_invisible_yes,
    "user_invisible_no" => $user_invisible_no,
    "lang_profile_of" => $lang['profile_of'],
    "lang_email" => $lang['email'],


Is there something I am doing wrong?

Thanks always

thelifephotography.com  -  4images
www.thecenterofthenet.com  - drupal

As long as I can finish my site before I die.

Offline AntiNSA2

  • Hero Member
  • *****
  • Posts: 774
  • As long as I can finish my site before I die.
    • View Profile
    • http://www.thelifephotography.com
Re: [Mod] Avatar v2.01
« Reply #391 on: March 02, 2009, 12:02:19 AM »
Ah sorry.. working 140 hours a week and trying to do site in between. I found my mistake, but I switched to the member pic instead ::)
As long as I can finish my site before I die.

Offline Fastian

  • Full Member
  • ***
  • Posts: 199
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #392 on: March 14, 2009, 08:50:09 AM »
Quote from: drhtm
is it possible to add the avatar in the box 'Registered Users' after a member login right after their name and above the link to 'lightbox'?

And if a user hasn't chosen an avatar is it possible to put a default image or text in that space to remind the user to choose an avatar?

thanks
hmmm...I like the idea add avatar under the name :wink:
just did it on my site:open /includes/page_header.php
Find:
Code: [Select]
 "url_upload" => (!empty($url_upload)) ? $site_sess->url($url_upload) : $site_sess->url(ROOT_PATH."member.php?action=uploadform"),Add after:
Code: [Select]
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",
Then, open user_logininfo.html template. Add this:
Code: [Select]
{user_avatar_current}

About default image - just change blank.gif with image u want.
@V@no
After this modification, I am getting following error message on Search page.
Notice: Undefined index: user_avatar in xxxx\includes\page_header.php on line 204
And on line 204 I have this
Code: [Select]
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" border=\"0\" alt=\"\">" : "",When I view Search page as Admin, I don't get this error.
Can you please help.
I m not a  Programmer.
          But
I m a Good Learner.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [Mod] Avatar v2.01
« Reply #393 on: March 14, 2009, 09:07:38 AM »
Did steps 4 and 12?
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Fastian

  • Full Member
  • ***
  • Posts: 199
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #394 on: March 14, 2009, 09:20:29 AM »
Did steps 4 and 12?
Yes. I am pretty sure I followed your instructions completely. Infect, I double checked everything just now.
Addition user filed is there in db_field_definitions.php and in my DB, I can see "user_avatar" under 4images_users table.

Also, this error comes in Search page only when I view as a Guest. When logged in as Admin/User, I don't see this error message.
I m not a  Programmer.
          But
I m a Good Learner.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [Mod] Avatar v2.01
« Reply #395 on: March 14, 2009, 09:38:53 AM »
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Fastian

  • Full Member
  • ***
  • Posts: 199
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #396 on: March 14, 2009, 11:34:48 AM »
Bug fixes -> [1.7 - 1.7.6] Additional user fields not being used for guests
Sorry  :oops:
I missed it. I should have looked there.
It works perfect now  :)
I m not a  Programmer.
          But
I m a Good Learner.

Offline maus

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #397 on: March 27, 2009, 11:23:31 AM »
Avatarbild in die user_logininfo.html ist auch zu sehen aber ist man in profil von ein andern erscheint das Avatarbild von mir.

Offline 4ella

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
    • http://www.dancersrecruit.com/pictures/
Re: [Mod] Avatar v2.01
« Reply #398 on: April 20, 2009, 02:01:46 AM »
Hello can anybody help me I have 1.7.6 version , 4times reinstalled member.php and for this reason also downloaded new 1.7.6 and I always get this error when entering to control panel :
I also tried this thread and I get always the same error: http://www.4homepages.de/forum/index.php?topic=23012.0
I m not able to upload avatar at all , I dont  see no avatar in members profile so I dont know what to do anymore, before posting anything Im always trying 2days to make it myself but right now I give it up . Is first post updated for 1.7.6 ?
member.php I made 3x times from the beginning so I dont believe it would be my fault , pls help  :cry:

Warning: opendir(./templates/default/avatars/users/) [function.opendir]: failed to open dir: No such file or directory in /home2/dancersr/public_html/pictures/member.php on line 1292

Warning: readdir(): supplied argument is not a valid Directory resource in /home2/dancersr/public_html/pictures/member.php on line 1294

Warning: closedir(): supplied argument is not a valid Directory resource in /home2/dancersr/public_html/pictures/member.php on line 1295

Warning: opendir(./templates/default/avatars/) [function.opendir]: failed to open dir: No such file or directory in /home2/dancersr/public_html/pictures/member.php on line 1304

Warning: readdir(): supplied argument is not a valid Directory resource in /home2/dancersr/public_html/pictures/member.php on line 1306

Warning: closedir(): supplied argument is not a valid Directory resource in /home2/dancersr/public_html/pictures/member.php on line 1307

http://www.dancersrecruit.com/pictures/
4IMAGES 1.7.6 version/default theme
Apache version   2.2.11 (Unix)
PHP version   5.2.9
MySQL version   5.0.75-community-log
Architecture   x86_64
Operating system   Linux

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [Mod] Avatar v2.01
« Reply #399 on: April 20, 2009, 02:29:04 AM »
Looks like you didn't do step 12 properly. Make sure you created the new folders and set persmissions to CHMOD 777
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline 4ella

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
    • http://www.dancersrecruit.com/pictures/
Re: [Mod] Avatar v2.01
« Reply #400 on: April 20, 2009, 06:17:47 PM »
Thanks V@no for very quick respond , right now I will try it

Man you are amazing , Thanks a lot  :D , compliments , you know perfectly what to do , I'm really stupid , I was controling only members.php but problem was like you 've said step 12. I made folder - *avatar *- instead *avatars *, permission were ok , I see everything now , now I will control the rest and will try to upload some avatars if everything works .
« Last Edit: April 20, 2009, 06:35:10 PM by 4ella »

http://www.dancersrecruit.com/pictures/
4IMAGES 1.7.6 version/default theme
Apache version   2.2.11 (Unix)
PHP version   5.2.9
MySQL version   5.0.75-community-log
Architecture   x86_64
Operating system   Linux

Offline Anarchology

  • Jr. Member
  • **
  • Posts: 60
  • I LULZ too much!
    • View Profile
    • Tainted Pix
Re: [Mod] Avatar v2.01
« Reply #401 on: April 27, 2009, 06:00:27 AM »
For some reason, I'm noticing that the avatars don't show to anyone logged out. Has anyone else had this problem, or has it been addressed already somewhere else in this thread?

Thanks in advance!
A personal THANK YOU to all of the great programmers on this site for helping me get my site from something basic to what it is today!

My site: http://taintedpix.com
(warning: some adult content)

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [Mod] Avatar v2.01
« Reply #402 on: April 27, 2009, 09:08:56 AM »
This should not be happening. Did you double check all the steps?
Any example where we can see this?
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline Anarchology

  • Jr. Member
  • **
  • Posts: 60
  • I LULZ too much!
    • View Profile
    • Tainted Pix
Re: [Mod] Avatar v2.01
« Reply #403 on: April 28, 2009, 09:55:26 PM »
This should not be happening. Did you double check all the steps?
Any example where we can see this?

I backed up my database, and ran an older one before the Avatar add. Then re-ran the install for it. Now I am able to see the avatars ONLY when I am logged in under Admin, but not when logged in under a normal Member or as a Guest. I'm guessing there is a string I need to switch around in the modified scripts. I'll look through it all and see if I could find it myself. If anyone finds it before me, please post it up! Thanks!

Oh, and here is a direct link to my test site image page where the comments are at the bottom. If you guys see solid light-blue boxes under the user names, then I figured it out!

http://www.savegasforums.com/img-slum-7.htm

This is a screen cap of what it looks like for me being logged in as an admin...
http://www.savegasforums.com/img-this-is-what-the-admin-sees-9.htm

EDIT: Alright, I narrowed it down to being related to the database changes. When I grabbed the user database backup from my old site, and uploaded it, the Avatars didn't show at all. Then I reinstalled the install_avatars.php file (got the usual "double" message). Then, the avatars still just are able to be seen by the admin when in comments. Oddly, when looking at the member profiles, you can see the avatar whether guest, member, or admin. This is just weird.
« Last Edit: April 29, 2009, 01:55:21 AM by Anarchology »
A personal THANK YOU to all of the great programmers on this site for helping me get my site from something basic to what it is today!

My site: http://taintedpix.com
(warning: some adult content)

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Administrator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: [Mod] Avatar v2.01
« Reply #404 on: April 29, 2009, 05:14:40 AM »
To be sure
1) if you login as regular member, can you see the avatars?
2) did you install ALL Bug Fixes & Patches for your version of 4images?
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)