• [Mod] Avatar v2.01 5 0 5 1
Currently:  

Author Topic: [Mod] Avatar v2.01  (Read 472510 times)

0 Members and 1 Guest are viewing this topic.

Offline Marquis2000

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #330 on: October 14, 2007, 08:31:16 PM »
Hallo hoffentlich spricht hier jemand Deutsch :)

Ich würde gerne den Avatar im Template: user_logininfo.html angezeigt haben. Dazu habe ich folgendes probiert, die Zeilen

{if_user_avatar_current}
{user_avatar_current}
{endif_user_avatar_current}

in das user_logininfo.html Template an entsprechender Stelle geschrieben. Leider zeigt er den Avatar aber nicht an. KAnn mir jemand helfen?? Danke schon mal!

Gruß Marquis

Offline Marquis2000

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #331 on: October 25, 2007, 03:39:06 PM »
Weiß das echt keiner ??

Offline Icemann71

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #332 on: October 25, 2007, 11:56:14 PM »
Weiß das echt keiner ??

versuche mal

includes/page_header.php
suche
 
Code: [Select]
"url_lost_password" => (!empty($url_lost_password)) ? $site_sess->url($url_lost_password) : $site_sess->url(ROOT_PATH."member.php?action=lostpassword"),
dadrüber einfügen
 
Code: [Select]
"user_avatar_current" => ($config['avatar_use']) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_info['user_avatar'] == "") ? "blank.gif" : $user_info['user_avatar'])."\" name=\"icons\" border=\"0\" alt=\"\">" : "",
Have a nice Day ;-)

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #333 on: October 26, 2007, 09:17:59 AM »
Hi all

i installed this mod for a long time ago and it works great.
I have the old 4image version 1.7.1
I have now read all 24 sites of this mod, but i can´t found the answer for my only bug:

A user has uploaded his own avatar it is working great, but when he upload another avatar again, it shows the same avatar like before.
He has to refresh the site..to show the new one.
Is there a solution?

greetings,
glitzer

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #334 on: October 26, 2007, 12:06:13 PM »
Hi all

i installed this mod for a long time ago and it works great.
I have the old 4image version 1.7.1
I have now read all 24 sites of this mod, but i can´t found the answer for my only bug:

A user has uploaded his own avatar it is working great, but when he upload another avatar again, it shows the same avatar like before.
He has to refresh the site..to show the new one.
Is there a solution?

greetings,
glitzer

Yes. In member.php file,

find:

Quote
$update_process = 1;
  }
  $action = "editprofile";

replace:

Code: [Select]
$update_process = 1;
  }
  redirect("member.php?action=editprofile");
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #335 on: October 26, 2007, 12:14:49 PM »
Hi V@no.

now i get this error when i what to upload an avatar

Fatal error: Call to undefined function: redirect() in /www/htdocs/ekarten/pics01/member.php on line 1369

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #336 on: October 26, 2007, 12:19:24 PM »
V@no ? I post this ... no V@no ... :?

For redirect error, you use old version of 4images. Please install all patch and upgrade from here:

http://www.4homepages.de/forum/index.php?board=17.0

8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #337 on: October 26, 2007, 12:25:58 PM »
ooh no sorry thunderstrike   :oops:

Yes i use the old one 1.7.1 because i have so many mods included..i don´t want to loose them with the upgrade.

I hope the bug fixed help me to use this mod!

Thank you very much

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #338 on: October 26, 2007, 03:09:05 PM »
Hi Thunderstrike,

me once again  :lol:

I checked now all bug fixes..but it still does not work. (the avatar function, after uploading an avatar again, i have to refresh the site manually to see the new avatar)

Do you have another idea?

greets,
glitzer

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #339 on: October 27, 2007, 12:38:15 AM »
Quote
Do you have another idea?

Yes, download last 4images version and go to includes/functions.php file. Copy & paste redirect function in your includes/functions.php file on top of ?> tag and try again.
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #340 on: October 27, 2007, 08:42:17 AM »

Hi Thunderstrike!

Good Idea, but it also doesn´t work.  :roll:

Perhaps you could take a look on my function file?
perhaps you can find mistakes or the problem.

Thank you very much for your help!


Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #341 on: October 27, 2007, 02:13:11 PM »
Quote
but it also doesn´t work.

And please read step 6 of my signature. You install code but then ?
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #342 on: October 27, 2007, 02:17:35 PM »
Hi Thunderstrike.

its the same like before...the new avatar is not to see..i have to refresh the site..to see it.

greets glitzer

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #343 on: October 27, 2007, 02:25:51 PM »
Sigh - ok change to this:

Code: [Select]
$update_process = 1;
  }
  header("Location: " . $site_sess->url(ROOT_PATH . "member.php?action=editprofile"));
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline glitzer

  • Full Member
  • ***
  • Posts: 204
    • View Profile
    • over 7000 E-Cards
Re: [Mod] Avatar v2.01
« Reply #344 on: October 27, 2007, 04:02:45 PM »

hi Thunderstrike,

thank you for trying help me, but i think i let it be.
With your last code, it is always the same..the avatar is not refreshed.

I can live with this little problem ;-)
Thanks a lot for your quick support  :D