• [Mod] Avatar v2.01 5 0 5 1
Currently:  

Author Topic: [Mod] Avatar v2.01  (Read 473717 times)

0 Members and 1 Guest are viewing this topic.

Offline mathuatden

  • Jr. Member
  • **
  • Posts: 55
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #285 on: August 05, 2007, 07:07:25 AM »
How I can add this mod for 4images 1.7.4

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #286 on: August 05, 2007, 02:18:13 PM »
Quote
How I can add this mod for 4images 1.7.4

Error message ? Source ? URL where no work ?
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline mathuatden

  • Jr. Member
  • **
  • Posts: 55
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #287 on: August 05, 2007, 03:05:58 PM »
this is the first I add this mod for 4images 1.7.4 on localhost but uncuessful please help me. thank you (i am vietnamese, please to meet you)

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #288 on: August 05, 2007, 03:27:20 PM »
I can help but need to know error message ... what is say for no work ?
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Mr_LovaLove

  • Full Member
  • ***
  • Posts: 233
  • Unkown
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #289 on: August 06, 2007, 07:51:39 PM »
since there is no error msg !!


how can he helps you !!

and its working with me and am using 1.7.4


if thunder said so ! :P that means he ganna help you ! only thing you have to do is explain the probem you have ( show him or us ther error msg )  ! ( have been helped alot by him * thanks * )
English Please :@

Offline The Sailor

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #290 on: August 12, 2007, 02:29:54 PM »
i used a New Registered User mod from state.php here is the code:

Code: [Select]
//-----------------------------------------------------
//--- New Member --------------------------------------
//-----------------------------------------------------
$sql = "SELECT *
        FROM ".USERS_TABLE."
        WHERE ".get_user_table_field("", "user_id")." <> ".GUEST."
        ORDER by ".get_user_table_field("", "user_joindate")." DESC";
$row = $site_db->query_firstrow($sql);

$new_member = "Welcome to our new registered user, ".(($row[$user_table_fields['user_id']]) ? " <a href=\"".$site_sess->url(ROOT_PATH."member.php?action=showprofile&user_id=".$row[$user_table_fields['user_id']])."\"><B>".$row[$user_table_fields['user_name']]."</B></a>\n" : "<B>".$row[$user_table_fields['user_name']]."</B>");
$site_template->register_vars("new_member", $new_member);
unset($new_member);

and i use {new_member} it show the new registered member just fine but how can i show his Avatar ???? :oops:
(^_^)

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #291 on: August 20, 2007, 12:23:37 AM »
SQL Query start with guest level ... avatar can no show for GUEST ... no use for this.
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #292 on: August 28, 2007, 07:42:01 PM »

Maybe somebody could give a code how to show avatars in users online list?

P.S. so far MOD runs great on my site with 1.4.7 version.

Thanks!

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #293 on: August 28, 2007, 08:05:31 PM »
Quote
Maybe somebody could give a code how to show avatars in users online list?

Which one ? Is possible post topic of users online list ?

Quote
P.S. so far MOD runs great on my site with 1.4.7 version.

Hope mean v1.7.4 and not 1.4.7 ... if so ... run in fix now !!   :| ... 8O
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #294 on: August 28, 2007, 08:17:38 PM »
If I understand you correct:

I just want in default whois_online template show user avatar near his nickname.  :wink:

Sorry for mistake.  :lol:

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #295 on: August 28, 2007, 08:19:39 PM »
Is MOD from icecream for whos online dropdown ... no find ... I use search but no result. :(
userpic with whos online and think avatar. ;)
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #296 on: August 28, 2007, 08:28:50 PM »
So its no way I can show user's avatar near user nickname using this MOD?
In MOD Member Personal photo it was done with sessions.php.....

http://www.4homepages.de/forum/index.php?topic=6797.165


Maybe it's possible???

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #297 on: August 28, 2007, 09:22:04 PM »
Ok so this:

http://www.4homepages.de/forum/index.php?topic=6797.msg60455#msg60455

?

In includes/sessions.php file,

find:

Quote
$sql = "SELECT s.session_user_id, s.session_lastaction, s.session_ip".get_user_table_field(", u.", "user_id").get_user_table_field(", u.", "user_level").get_user_table_field(", u.", "user_name").get_user_table_field(", u.", "user_invisible").", userpic

replace:

Quote
$sql = "SELECT s.session_user_id, s.session_lastaction, s.session_ip".get_user_table_field(", u.", "user_id").get_user_table_field(", u.", "user_level").get_user_table_field(", u.", "user_name").get_user_table_field(", u.", "user_invisible").", u.userpic, u.user_avatar

Find:

Quote
$user_profile_link = (!empty($url_show_profile)) ? str_replace("{user_id}", $row['session_user_id'], $url_show_profile) : ROOT_PATH."member.php?action=showprofile&amp;".URL_USER_ID."=".$row['session_user_id'];

add after:

Quote
$avatar_img = (isset($config['avatar_use']) && $config['avatar_use'] && @file_exists(TEMPLATE_PATH."/avatars/".$user_row['user_avatar']/".$row['userpic']) && $user_info['user_level'] >= USER) ? "<img src=\"".TEMPLATE_PATH."/avatars/".(($user_row['user_avatar'] == "") ? "blank.gif" : $user_row['user_avatar'])."\" name=\"icons\" border=\"0\" hspace=\"15\" alt=\"\">" : "";

Find:

Quote
$user_online_list .= "<a href=\"".$site_sess->url($user_profile_link)."\"><center>".$whos_online_userpic."<br />".$username."</a>".$invisibleuser."</center>".REPLACE_EMPTY. REPLACE_EMPTY;     

replace:

Quote
$user_online_list .= "<a href=\"".$site_sess->url($user_profile_link)."\"><center>".$avatar_img."<br />".$username."</a>".$invisibleuser."</center>".REPLACE_EMPTY. REPLACE_EMPTY;
« Last Edit: August 28, 2007, 10:21:37 PM by thunderstrike »
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #298 on: August 28, 2007, 09:48:07 PM »
Parse error: parse error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home/www/boxel.id.lv/includes/sessions.php on line 445  :(


And my sessions.php looks like this.
When changing code I found some difference between yours and mine code.
Are you using some other version???

Offline Gstyleris

  • Pre-Newbie
  • Posts: 6
    • View Profile
Re: [Mod] Avatar v2.01
« Reply #299 on: August 28, 2007, 09:48:54 PM »
<?php
/**************************************************************************
 *                                                                        *
 *    4images - A Web Based Image Gallery Management System               *
 *    ----------------------------------------------------------------    *
............................
« Last Edit: August 28, 2007, 10:28:47 PM by Nicky »