• [MOD] Facebook Connector V1.0 & V2.0 5 0 5 1
Currently:  

Author Topic: [MOD] Facebook Connector V1.0 & V2.0  (Read 244142 times)

0 Members and 1 Guest are viewing this topic.

Offline piczilla

  • Pre-Newbie
  • Posts: 8
    • View Profile
Re: [MOD] Facebook Connector V1.0
« Reply #45 on: July 18, 2010, 11:22:26 PM »
Okay,

I looked all over facebook developers how to do this. Then I realized I could look at the forums. I was so glad when I found it!
One problem, I get the error below

"ALTER TABLE `4images_users` ADD `fb_userid` VARCHAR(255) NOT NULL, ADD `fl_facebook` ENUM(\'new\',\'normal\',\'registered\') NOT NULL DEFAULT \'registered\'"

I added it in phpmyadmin with the correct specs, but it keeps giving me this error! I attached a screenshot of what my phpmyadmin looks like.

Thanks,
Coulton

« Last Edit: July 18, 2010, 11:35:20 PM by piczilla »

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #46 on: July 18, 2010, 11:36:36 PM »
Okay,

I looked all over facebook developers how to do this. Then I realized I could look at the forums. I was so glad when I found it!
One problem, I get the error below

"ALTER TABLE `4images_users` ADD `fb_userid` VARCHAR(255) NOT NULL, ADD `fl_facebook` ENUM(\'new\',\'normal\',\'registered\') NOT NULL DEFAULT \'registered\'"

I added it in phpmyadmin with the correct specs, but it keeps giving me this error!

Thanks,
Coulton



Yes, facebook's website for developers is very hard to understand...

My question to you is, what error? :?:
it looks like it placed the fields into your database correctly...
Buddy Duke
www.budduke.com

Offline piczilla

  • Pre-Newbie
  • Posts: 8
    • View Profile
Re: [MOD] Facebook Connector V1.0
« Reply #47 on: July 18, 2010, 11:38:38 PM »
Yes, facebook's website for developers is very hard to understand...

My question to you is, what error? :?:
it looks like it placed the fields into your database correctly...

The same error I got before I added the stuff in the database.

ALTER TABLE `4images_users` ADD `fb_userid` VARCHAR(255) NOT NULL, ADD `fl_facebook` ENUM(\'new\',\'normal\',\'registered\') NOT NULL DEFAULT \'registered\'

I even emptied my cache and tried it in a different browser.

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #48 on: July 18, 2010, 11:43:25 PM »
I am assuming you are still trying to run the installer?
If so, just delete that file because you have the fields entered into your database correctly...

Buddy Duke
www.budduke.com

Offline piczilla

  • Pre-Newbie
  • Posts: 8
    • View Profile
Re: [MOD] Facebook Connector V1.0
« Reply #49 on: July 19, 2010, 12:21:04 AM »
Thanks! Installed it and now it's starting to act funny. The login to facebook button doesn't appear and the logout doesn't want to work. Thoughts?

Thanks,
Coulton

PS: here is the link http://insanestream.com/piczilla/

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #50 on: July 19, 2010, 12:23:23 AM »
Buddy Duke
www.budduke.com

Offline piczilla

  • Pre-Newbie
  • Posts: 8
    • View Profile
Re: [MOD] Facebook Connector V1.0
« Reply #51 on: July 19, 2010, 12:52:23 AM »
Just did, now the facebook logout button shows all the time whether logged in or not and does not work.

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #52 on: July 19, 2010, 01:01:36 AM »
The design of your page is messed up.
You need to go in and clean allot of things up...
just what I saw was that you places some of the javascript stuff in more then once and in the wrong area...

other things that I do not normally see on sites is that you have your <css> styles and a <table> command all coming before your <html> command.
most pages start with
<html>
<head> this is where you meta and javascripts should reside except for the one that has the fb-root it needs to be at the top of your body
</head>
<body> which is where your table should begin and the rest of your page stuff
</body>
</html>


I am getting the login button on my browser but nothing happens when I press it.
I see there is also a login button in your comment area through that app, not sure how it will interact with the mod.

but I would start be cleaning everything up and/or starting over with a fresh copy of your template that you are using...

If you give me a link to the template you are using, I may have time later this week to look at it but am getting off the computer for tonight.

UPDATE:
I think you need to remove this code from your page to get it to work correctly...
Code: [Select]
<script src="http://connect.facebook.net/en_US/all.js"></script>
<script>
  FB.init({appId: '<<REMOVED FOR SECURITY>>', status: true, cookie: true, xfbml: true});
  FB.Event.subscribe('auth.sessionChange', function(response) {
    if (response.session) {
      // A user has logged in, and a new cookie has been saved
    } else {
      // The user has logged out, and the cookie has been cleared
    }
  });
</script>

This is the one in your <HEAD></HEAD> area...
I think it is conflicting with this mod. I believe it was installed when you added your comments from facebook.
My mod should accomplish the same thing and your comments should still work.

Let me know if you are still having troubles.
« Last Edit: July 19, 2010, 03:35:50 PM by budduke »
Buddy Duke
www.budduke.com

Offline piczilla

  • Pre-Newbie
  • Posts: 8
    • View Profile
Re: [MOD] Facebook Connector V1.0
« Reply #53 on: July 20, 2010, 04:33:31 AM »
The design of your page is messed up.
You need to go in and clean allot of things up...
just what I saw was that you places some of the javascript stuff in more then once and in the wrong area...

other things that I do not normally see on sites is that you have your <css> styles and a <table> command all coming before your <html> command.
most pages start with
<html>
<head> this is where you meta and javascripts should reside except for the one that has the fb-root it needs to be at the top of your body
</head>
<body> which is where your table should begin and the rest of your page stuff
</body>
</html>


I am getting the login button on my browser but nothing happens when I press it.
I see there is also a login button in your comment area through that app, not sure how it will interact with the mod.

but I would start be cleaning everything up and/or starting over with a fresh copy of your template that you are using...

If you give me a link to the template you are using, I may have time later this week to look at it but am getting off the computer for tonight.

UPDATE:
I think you need to remove this code from your page to get it to work correctly...
Code: [Select]
<script src="http://connect.facebook.net/en_US/all.js"></script>
<script>
  FB.init({appId: '<<REMOVED FOR SECURITY>>', status: true, cookie: true, xfbml: true});
  FB.Event.subscribe('auth.sessionChange', function(response) {
    if (response.session) {
      // A user has logged in, and a new cookie has been saved
    } else {
      // The user has logged out, and the cookie has been cleared
    }
  });
</script>

This is the one in your <HEAD></HEAD> area...
I think it is conflicting with this mod. I believe it was installed when you added your comments from facebook.
My mod should accomplish the same thing and your comments should still work.

Let me know if you are still having troubles.


Thanks for everything. I actually uploaded the back-ups, cleaned the code out a bit, then redid the mod and it worked. And as for the comments, I am going to remove it and add the comments that came with 4images using the facebook profile picture mod. The only reason I used facebook comments in the first place is because the profile pictures.

Thanks again,
Coulton

Offline alemam

  • Newbie
  • *
  • Posts: 18
  • games mofadlty
    • View Profile
    • العاب مفضلتي
Re: [MOD] Facebook Connector V1.0
« Reply #54 on: July 21, 2010, 05:47:29 PM »

after login Can not view member information

And form login non-hidden

after login in user facebook

see photo

« Last Edit: July 21, 2010, 06:17:04 PM by alemam »

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #55 on: July 21, 2010, 07:54:07 PM »
@ alemam,
Sometimes it takes a second or two to get in...
I would recheck all inserts in the mod.
Can you provide a link so I can see what is happening?
Does it create a user account for the user that logged in with facebook?
Buddy Duke
www.budduke.com

Offline alemam

  • Newbie
  • *
  • Posts: 18
  • games mofadlty
    • View Profile
    • العاب مفضلتي
Re: [MOD] Facebook Connector V1.0
« Reply #56 on: July 21, 2010, 09:11:49 PM »
this my link http://games.mofadlty.com

not  create a user account for the user that logged in with facebook
« Last Edit: July 21, 2010, 09:27:33 PM by alemam »

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #57 on: July 21, 2010, 10:13:08 PM »
@ alemam,
When I looked at the source of your page I saw this...
Code: [Select]
            function login(){
                document.location.href = 'http://games.mofadlty.com/?fb_status=1';
There should be an index.php in front of the ? symbol...

This is what mine looks like on my original page...
Code: [Select]
            function login(){
                document.location.href = 'http://www.budduke.com/index.php?sessionid=6c29a7e2d7b7b4708db6f8fda913354c&fb_status=1';

Something is not right, in the pageheader.php file it should pass self_full which should be the full path including the session if needed...
Do a search for self_full in the pageheader.php file to see if anything is changed in that area.
Buddy Duke
www.budduke.com

Offline alemam

  • Newbie
  • *
  • Posts: 18
  • games mofadlty
    • View Profile
    • العاب مفضلتي
Re: [MOD] Facebook Connector V1.0
« Reply #58 on: July 22, 2010, 11:02:57 AM »
it's good my _   page_header.php

danlowd my page_header.php

http://games.mofadlty.com/page_header.zip

this form your source siter

Code: [Select]
            function login(){
                document.location.href = 'http://www.budduke.com/index.php?fb_status=1';
            }
            function logout(){
                document.location.href = 'http://www.budduke.com/index.php?fb_status=1';



« Last Edit: July 22, 2010, 11:27:13 AM by alemam »

Offline budduke

  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • http://www.budduke.com
Re: [MOD] Facebook Connector V1.0
« Reply #59 on: July 22, 2010, 12:17:08 PM »
@akemam,

I will need to see all the files that where changed, if you can zip all them together for me to look at...
Buddy Duke
www.budduke.com

 

Post your comments here