Author Topic: Probleme mit zusätzlichen Feldern  (Read 9335 times)

0 Members and 1 Guest are viewing this topic.

bildergallery

  • Guest
Probleme mit zusätzlichen Feldern
« on: November 07, 2007, 06:19:48 PM »
hallo zusammen,
ich benutze den google mod und möchte den mitgliedern diese funktion auch anbieten.
nun habe ich das problem, dass der radio button nicht auf nein sondern auf ja steht.

template
Code: [Select]
<input type="radio" name="image_gmap_show" value="1"{image_gmap_show_yes} />{lang_yes}
<input type="radio" name="image_gmap_show" value="0"{image_gmap_show_no} />{lang_no}

db fields.php

Code: [Select]
$additional_image_fields['image_gmap_show'] = array($lang['image_gmap_show'], "radio", 1);
in der db selbst ist der eintrag auf 0
was mache ich falsch?

gruss ivan

Offline nobby

  • 4images Guru
  • *******
  • Posts: 2.873
    • View Profile
Re: Probleme mit zusätzlichen Feldern
« Reply #1 on: November 07, 2007, 09:13:00 PM »
Hallo Ivan,

die 0 und 1 ist doch Ja/Nein, richtig  :!:
Wenn Du nun die 0 und 1 gegeneinander austauscht müsstest Du dann zum Ziel kommen  :?:  :|

gruss nobby

Offline Nicky

  • Administrator
  • 4images Guru
  • *****
  • Posts: 3.195
    • View Profile
Re: Probleme mit zusätzlichen Feldern
« Reply #2 on: November 08, 2007, 10:28:39 AM »
okay....

ich hab den fehler gemacht..

es funktioniert doch..

Code: [Select]
$additional_image_fields['image_photographer'] = array($lang['image_photographer'], "radio", 1);

Code: [Select]
              <input type="radio" name="image_photographer" value="1"{image_photographer_yes} /> JA
              <input type="radio" name="image_photographer" value="0"{image_photographer_no} /> NEIN
cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi

Offline Nicky

  • Administrator
  • 4images Guru
  • *****
  • Posts: 3.195
    • View Profile
Re: Probleme mit zusätzlichen Feldern
« Reply #3 on: November 08, 2007, 11:09:19 AM »
die einfachste lösung :)

Code: [Select]
              <input type="radio" name="image_photographer" value="1" /> JA
              <input type="radio" name="image_photographer" value="0" checked="checked" /> NEIN
cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi

Offline thunderstrike

  • 4images Guru
  • *******
  • Posts: 2.327
    • View Profile
Re: Probleme mit zusätzlichen Feldern
« Reply #4 on: November 08, 2007, 06:14:21 PM »
@ivan:

I no get german but here for add additional user fields with details page (option no. 2). ;)

http://www.4homepages.de/forum/index.php?topic=19297.0
8 steps need when ask question -

- PHP version (ACP - > phpinfo())
- mySQL version (ACP - > phpinfo())
- 4images version
- Post screenshot / URL
- Post code in BB Code (no need full file for code) or post attach file
- It doesn't work. What is say - what is do for no work
- Install MOD ? If so - please say (troubleshooting)
- Read FAQ ? Install Bug fixes ?

 

Post your comments here