Author Topic: Warning Function copy failed to open......  (Read 3557 times)

0 Members and 1 Guest are viewing this topic.

Offline rosie

  • Pre-Newbie
  • Posts: 3
    • View Profile
Warning Function copy failed to open......
« on: September 08, 2006, 06:26:04 PM »
Hi all.
I am getting this message when I try to Validate  images in my 4images 1.7.2

Warning: copy(./../data/media/8/cherokeeanddd.jpg) [function.copy]: failed to open stream: Permission denied in /home/onlyfarm/public_html/vote/admin/admin_functions.php on line 111

Warning: copy(./../data/thumbnails/8/.jpg) [function.copy]: failed to open stream: Permission denied in /home/onlyfarm/public_html/vote/admin/admin_functions.php on line 155
Error adding image: True Love (cherokeeanddd.jpg)

 I made sure there is a folder named 8 under the data/media and data/thumbnails¬  ¬ AND¬  ¬  have deleted them 3 times and made new ones.
I also have made sure the correct permissions are set.¬ 
I tried to read the faq's and fix this myself but I am still getting the error.
Can someone please Help me?

Here is the url to my site where the vote script is.¬  ¬ http://www.onlyfarms.com/vote/   if someone would like to upload a photo so I can test again and fix this.
I am glad to pay for help here, I am very happy with this script, just limited in my knowledge of fixing problems. :lol:

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: Warning Function copy failed to open......
« Reply #1 on: September 09, 2006, 01:52:37 AM »
If your host turned on SAFE MODE, then thats the problem...refer FAQ for more info and possible work around it.
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline rosie

  • Pre-Newbie
  • Posts: 3
    • View Profile
Re: Warning Function copy failed to open......
« Reply #2 on: September 11, 2006, 06:55:07 PM »
Hi Thank you for taking the time to answer.  Safe Mode is not on.  Please -Can you help with anything else I need to check for?

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: Warning Function copy failed to open......
« Reply #3 on: September 11, 2006, 11:04:04 PM »
Then there are only two reasons could possibly cause this:
1) data/media/8/ does not exists
2) data/media/8/ is not writable (aka not CHMOD 777)

I know you insist that you've checked the permissions, but it wont hurt to double check ;)
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

Offline rosie

  • Pre-Newbie
  • Posts: 3
    • View Profile
Re: Warning Function copy failed to open......
« Reply #4 on: September 12, 2006, 12:07:22 AM »
Quote
but it wont hurt to double check

OR Triple check.  I had checked more than once, but just now when I read your reply I checked again -and all of them except 4 folders were set to 755!
The weird thing is, just now when I clicked each folder and then clicked on 'change permissions' the permissions were already all ticked and showing 777 all I had to do was click to change them, it's never been like that before. It should have been showing 755 and then I could have changed it to 777........strange
I changed all of them back and maybe now it will work I'm sure it should.
I wonder if this had something to do with my server being down a few hours last week? I wonder how the permissions got changed and why they were correct when I clicked on it. Any ideas?
Oh by the way Thank you for your patience and your quick response here.

Offline V@no

  • If you don't tell me what to do, I won't tell you where you should go :)
  • Global Moderator
  • 4images Guru
  • *****
  • Posts: 17.849
  • mmm PHP...
    • View Profile
    • 4images MODs Demo
Re: Warning Function copy failed to open......
« Reply #5 on: September 12, 2006, 12:29:48 AM »
another posibility is something wrong with your FTP client ;)

If I were you, I'd contact host administrator with this question, maybe they changed something or even they could check their logs to make sure the server wasnt hacked...who knows..
Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)

 

Post your comments here