Author Topic: Bug Report 1.6 - Search errors for anything but 'All Fields'  (Read 9093 times)

0 Members and 1 Guest are viewing this topic.

Offline Chris

  • 4images Moderator
  • 4images Guru
  • *****
  • Posts: 4.487
  • Did u ever stop to think and then forget to start?
    • View Profile
I entered the word 'Pond' into the "Search by Keyword" form field.

CASE 1:

If I leave the "All fields" radio button selected, I get 7 images returned.  There are actually 386 images that have the keyword 'Pond'.

CASE 2:

If I select either the "Only image name", "Only description", or "Only keywords" radio buttons, I get the following error:

Code: [Select]
DB Error: Bad SQL Query: SELECT m.image_id FROM 4images_wordlist w, 4images_wordmatch m WHERE w.word_text LIKE 'pond' AND m.word_id = w.word_id AND wm.name_match = 1
Unknown table 'wm' in where clause


Also, for CASE 1, hitting my browser BACK button doesn't return me to the search form.  Instead I see the same search results again but the table width is slightly altered.  Hitting BACK again takes me to the page from where I clicked "Advanced Search".  I don't know if this has anything to do with the problem or helps in any way.

Offline Jan

  • Administrator
  • 4images Guru
  • *****
  • Posts: 5.024
    • View Profile
    • 4images - Image Gallery Management System
Bug Report 1.6 - Search errors for anything but 'All Fields'
« Reply #1 on: June 28, 2002, 09:44:27 AM »
Thanks Chris, i will check this.

Greets Jan
Your first three "must do" before you ask a question:
1. Forum rules
2. FAQ
3. Search

Offline Jan

  • Administrator
  • 4images Guru
  • *****
  • Posts: 5.024
    • View Profile
    • 4images - Image Gallery Management System
Your first three "must do" before you ask a question:
1. Forum rules
2. FAQ
3. Search

 

Post your comments here