4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
May 27, 2018, 11:32:45 PM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Modifications / Modifikationen
| |-+  Mods & Plugins (Releases & Support)
| | |-+  Signature image v2.3 (Moderators: mawenzi, Rembrandt)
| | | |-+  Message #167058
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: «« « 1 ... 28 29 30 31 [32] Print
Current Topic Rating: *****
Author Topic: Signature image v2.3  (Read 487923 times)
geohei
Jr. Member
**
Offline Offline

Posts: 85

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #465 on: January 21, 2018, 09:32:26 AM »

Hi.

I just changed my web server from PHP 5.6 to 7.0.
signature.php (v2.3) isn't working anymore.
The rest of 4images works fine.

Is there any "classic" trap I was falling into?

Otherwise, I post the exact erros.

Thanks,

... later ...

I noticed that ...

1
/signature/go

... works, but ...

1
/signature/signature.png

... creates this error:

1
2
3
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /4images/includes/db_mysql.php:37 Stack trace:
#0 /signature/signature.php(142): Db->__construct('<myhost>', '<myuser>', '<mypassword>', '<mydatabase>')
#1 {main} thrown in /4images/includes/db_mysql.php on line 37

<myhost>, <myuser>, <mypassword> and <mydatabase> are of course correct.

... later ...

I found the solution.

Changing this line in signature ...

1
2
3
...
  include(ROOT_PATH.'includes/db_mysqli.php');
...

(i.s.o. db_mysql.php)
« Last Edit: January 21, 2018, 10:36:42 AM by geohei » Logged

Pages: «« « 1 ... 28 29 30 31 [32] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.056 seconds with 21 queries.
Post your comments here