4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
February 18, 2018, 12:19:19 AM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Modifications / Modifikationen
| |-+  Mods & Plugins (Releases & Support) (Moderators: mawenzi, Rembrandt)
| | |-+  [Mod] Keep Track Of What Each User Has Downloaded
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: «« « 1 ... 8 9 10 11 [12] Print
Current Topic Rating: *****
Author Topic: [Mod] Keep Track Of What Each User Has Downloaded  (Read 165473 times)
viadata
Newbie
*
Offline Offline

Posts: 32

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #165 on: September 27, 2010, 12:13:47 AM »

Hallo Chris,

ich benutze deine MOD und bin voll zufrieden. Gute Arbeit!
Für mich wäre es von großem Nutzen, wenn ich sowas wie mit den Downloads auch für den Leuchtkasten hätte.
Ich gehe auf auf USER bearbeiten und sehe in der List neben den Downloads auch den Inhalt des Leuchtkastens.

Geht das? Oder geht das vielleicht auch als PlugIn ?

Danke für einen Antwort.

Holger
Logged
Warrior
Jr. Member
**
Offline Offline

Posts: 73

Thank You
-Given: 13
-Receive: 8


View Profile WWW
« Reply #166 on: April 20, 2011, 02:42:18 AM »

EDIT: (original post I made) Never mind.

(new content in this post) Got it working with the original coding. Good to see it works in hte latest 4Images Smile
« Last Edit: April 20, 2011, 06:51:55 AM by Warrior » Logged

wdomi
Newbie
*
Offline Offline

Posts: 27

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #167 on: May 30, 2011, 08:51:07 PM »

Hi Chris,
I have started an new test for my database using your mod. I have installed vers. 1.7.10. and modified everything as supposed. The installation works without errors but if I using the profile for the user applied I dont get a result of downloaded images. Instead of a message "Die Suche ergab keine Treffer" mening "no hits".  What did I wrong?
Logged
kooogel
Pre-Newbie

Offline Offline

Posts: 1

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #168 on: October 13, 2011, 03:05:04 AM »

Hi!

Thanks for this Mod. I've installed everything right the way you wrote. But I had an error with adding the ID's of downloaded images to the database. The problem I found was the following:

1
2
if ($user_info['user_level'] == USER// Mod: Track User Downloads
    
add_to_downloaded_image_ids($image_id); // Mod: Track User Downloads

When adding this line of code to the download.php file you have to add { and } to that if-request. So the right way would be

1
2
3
if ($user_info['user_level'] == USER) { // Mod: Track User Downloads
    
add_to_downloaded_image_ids($image_id); // Mod: Track User Downloads
// Mod: Track User Downloads

Anyway, there's also a problem with zip-downloads out of the lightbox. The id's of the downloaded images don't get written into the database. Has anyone a solution for this??

EDIT:
I also found the second problem. Smile Just added the code V@no posted in http://www.4homepages.de/forum/index.php?topic=4606.0;msg=25435
And again: Thank you for this Mod! Now it works perfectly!!!

Greatz
Christoph
« Last Edit: October 13, 2011, 03:30:06 AM by kooogel » Logged
Jan-Lukas
Addicted member
******
Offline Offline

Posts: 1276

Thank You
-Given: 151
-Receive: 47


View Profile WWW
« Reply #169 on: March 18, 2012, 01:24:19 AM »

Funktioniert in der 1.7.10 perfekt...
Logged

Danke Harald



oliver2610
Pre-Newbie

Offline Offline

Posts: 2

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #170 on: September 23, 2012, 08:16:27 AM »

Habe den mod in 1.7.11 mit Ausführung 4i_install_tud_fixed.zip, bekomme weißen Bildschirm. Nach Ausbau lief es wieder ohne Schwierigkeiten. Hat jemand eine Ahnung, was ich falsch gemacht haben könnte?
Logged
deb0727
Pre-Newbie

Offline Offline

Posts: 2

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #171 on: August 31, 2013, 12:53:22 AM »

This link isn't working...can someone help...I have done everything I was supposed to but doing this

4i_install_tud.php
Because the database must be modified, and it can be difficult to do correctly, I have written and tested an installer. Download the 4i_install_tud.zip file attached to this post. Extract the 4i_install_tud.php file and upload it to your web site. In a web browser, go to http://www.example.com/4images/4i_install_tud.php and follow the on-screen instructions.  Once your database is successfully updated, you should delete 4i_install_tud.php
Logged
Warrior
Jr. Member
**
Offline Offline

Posts: 73

Thank You
-Given: 13
-Receive: 8


View Profile WWW
« Reply #172 on: August 31, 2013, 03:15:28 AM »

At the bottom of the very first post are two attachments. Did you get those?
Logged

xcitepress
Pre-Newbie

Offline Offline

Posts: 1

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #173 on: November 06, 2016, 12:09:50 PM »

Hey there - is it possible to reup the attached files? It doesnt work it i unzip it...
Logged
nobby
4images Guru
*******
Offline Offline

Posts: 2822

Thank You
-Given: 9
-Receive: 70


View Profile
« Reply #174 on: November 06, 2016, 03:37:58 PM »

Hey there - is it possible to reup the attached files? It doesnt work it i unzip it...

It works  Shocked  Posting 1 by Chris

nobby

* 4i_install_tud.zip (1.63 KB - downloaded 0 times.)
* 4i_install_tud_fixed.zip (1.6 KB - downloaded 0 times.)
Logged
winzie
Newbie
*
Offline Offline

Posts: 12

Thank You
-Given: 2
-Receive: 0


View Profile
« Reply #175 on: February 11, 2017, 11:24:48 PM »

 Shocked does this mod work with 1.8 V ?
Logged
Pages: «« « 1 ... 8 9 10 11 [12] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.177 seconds with 19 queries.
Post your comments here