4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
September 28, 2016, 05:30:51 AM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Issues / Ausgaben
| |-+  Discussion & Troubleshooting (Moderators: Acidgod, ivan, Rembrandt)
| | |-+  display problems for audio + video
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: display problems for audio + video  (Read 5407 times)
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« on: February 15, 2003, 03:36:39 PM »

Yesterday I finished my gallery with all MODs and a final design and while "runnning a final test" I noticed, that audiofiles (mp3 and wav) were to be heared but the player wasn't displayed and videofiles (mpeg + avi, BUT NOT mov) were not displayed at all.
Because it was very late and i desperatly needed a nap I left it as it was, but today I tried it again and now not even the audiofiles are to be heared. I even tried different browsers (IE 6.0, Mozilla 1.2 and Opera 7.0).

I really don't know where to start looking for the cause of this, because when I  uploaded those files they were displayed just the way it's supposed to be. After that I put in some MODs and changed the appearence of the gallery, but nothing like the media templates.

So any help on this would be more than welcome.
If you want to look for yourself you'll find the audio files   Arrow here and the video files   Arrow here.

---------------------------------------------------------------------------------

Ich habe gestern meine Galerie mit allen MODs und dem finalen Layout fertiggestellt, und bei einem letzten "Rundgang" festgestellt, dass Audio Dateien (mp3 + wav) nur noch zu hören waren, aber der Player nicht  und Video Dateien (mpeg + avi, ABER NICHT mov) überhaupt nicht mehr angezeigt wurden.
Da es schon recht spät war und ich unbedingt eine Mütze voll schlaf brauchte, habe ich alles so gelassen wie es war, nur um heute festzustellen, dass jetzt bei mir auch die Audio Dateien nicht mehr wiedergegeben werden. Ich habe es selbst mit anderen Browsern versucht (IE 6.0, Mozilla 1.2 and Opera 7.0).

Ich weiß wirklich nicht wo ich nach der Ursache suchen soll, denn als dich die entsprechenden Dateien upgeloadet habe, wurden sie genauso angezeigt, wie es sein sollte. Dann habe ich ein paar MODs eingebaut und das Erscheinungsbild geändert, aber halt nichts, was z.B. die Mediatemplates verändert hätte.

Ich wäre über jede Hilfe froh.
Wenn Ihr mal selber einen Blick werfen wollt, findet Ihr die Audio Dateien Arrow hier und die Video Dateien Arrow hier.
Logged
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 562

mmm PHP...


View Profile WWW
« Reply #1 on: February 15, 2003, 04:54:48 PM »

I  can hear your mp3 files (cant check .avi, I'm not registered)
but it sounds that something wrong with your computer.
try set that mp3 associates with WindowsMedia player from WMPlayer's settings.
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #2 on: February 15, 2003, 05:05:47 PM »

I don't know what you're getting at...

Why should it make a difference, if the mp3 files on my pc are associated to Windows Media Player or to Winamp, which they are. Why were they played a few days ago, but not now? I haven't changed the file association. It's still the same.

Did you just hear them or did you also saw the player?


BTW, I opened the video category to public.
Logged
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 562

mmm PHP...


View Profile WWW
« Reply #3 on: February 15, 2003, 05:33:37 PM »

yes, I can hear, watch your media files, no problem at all, and I see my media player embeded player on the page.
and my point was that if there something messed up in your windows' settings, it might happend, that your browsers dont know what pluging to use when it asked to play media file...
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #4 on: February 15, 2003, 10:29:20 PM »

Now I'm totally devestated...

I've been to other site, and there audio and video files were displayed like it should be...
I deleted all cookiees and my temporary internet files, like V@no suggested, and now I'm at least able to hear the audio files again even if I don't see the player Mad  Mad  Mad

I even tried to upload the media templates from the zip file again but in vain. Tried to look at the code of detail.php and detail.html but I probably don't see the woods for the trees.
So would it be an idea, to post the code of those files here, that someone else could take a look?

I'm getting desperate, because I don't have the slightest clue of what's going wrong.
Logged
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #5 on: February 15, 2003, 11:17:35 PM »

Actually the videos are displayed too ( I forgot to close a window of my browser Wink ) but still no player. Which is kind of dumb if you want to end the loop or pause...

And at least two other people can verify this "behavior". One of them is using Netscape 7.0...
Logged
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #6 on: February 16, 2003, 12:16:54 AM »

Ahh.. now I've found it  Exclamation  Exclamation
Ahh.. ich hab's gefunden Exclamation  Exclamation

... but I still don't know why this has happend.
... aber ich versteh immer noch nicht, warum es passiert ist.

The fault was caused by the header.html.
I had a DHTML script implemented for a navigation bar. After I took it out everything was back to normal...
Der Fehler kam aus der header.html.
Da war ein DHTML Script für ein Navigationsmenü eingebaut. Als ich es herausnahm, war alles wieder so wie es sein sollte...


I would now really appreciate it, if someone could tell me why the script causes the plug ins not to be displayed.
This Nav-Bar is to be found troughout our community, I would like to keep it there without causing this proplem. Any ideas on how to do this?
Ich würde es wirklich begrüßen, wenn mir jemand sagen kann, warum dieses Script die Player nicht anzeigen läßt. Diese Navigationsmenü ist auf unserer gesamten Seite vertreten, von daher möchte ich es auch in der Galerie beibehalten, aber ohne diese Fehler. Irgendwelche Vorschläge, wie es besser zu implementieren ist?

Here's the code:
1
2
<SCRIPT SRC="http://www.bs-scouts.de/phpBB2/ssm.js" language="JavaScript1.2"></SCRIPT>
<SCRIPT SRC="http://www.bs-scouts.de/phpBB2/ssmItems.js" language="JavaScript1.2"></SCRIPT>

And this is the code of ssm.js
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78

//Static Slide Menu 6.5 © MaXimuS 2000-2001, All Rights Reserved.
//Site: http://www.absolutegb.com/maximus
//E-mail: maximus@nsimail.com
//Script featured on Dynamic Drive (http://www.dynamicdrive.com)

NS6 = (document.getElementById&&!document.all)
IE = (document.all)
NS = (navigator.appName=="Netscape" && navigator.appVersion.charAt(0)=="4")

tempBar='';barBuilt=0;ssmItems=new Array();

moving=setTimeout('null',1)
function moveOut() {
if ((NS6||NS)&&parseInt(ssm.left)<0 || IE && ssm.pixelLeft<0) {
clearTimeout(moving);moving = setTimeout('moveOut()', slideSpeed);slideMenu(10)}
else {clearTimeout(moving);moving=setTimeout('null',1)}};
function moveBack() {clearTimeout(moving);moving = setTimeout('moveBack1()', waitTime)}
function moveBack1() {
if ((NS6||NS) && parseInt(ssm.left)>(-menuWidth) || IE && ssm.pixelLeft>(-menuWidth)) {
clearTimeout(moving);moving = setTimeout('moveBack1()', slideSpeed);slideMenu(-10)}
else {clearTimeout(moving);moving=setTimeout('null',1)}}
function slideMenu(num){
if (IE) {ssm.pixelLeft += num;}
if (NS||NS6) {ssm.left = parseInt(ssm.left)+num;}
if (NS) {bssm.clip.right+=num;bssm2.clip.right+=num;}}

function makeStatic() {
if (NS||NS6) {winY = window.pageYOffset;}
if (IE) {winY = document.body.scrollTop;}
if (NS6||IE||NS) {
if (winY!=lastY&&winY>YOffset-staticYOffset) {
smooth = .2 * (winY - lastY - YOffset + staticYOffset);}
else if (YOffset-staticYOffset+lastY>YOffset-staticYOffset) {
smooth = .2 * (winY - lastY - (YOffset-(YOffset-winY)));}
else {smooth=0}
if(smooth > 0) smooth = Math.ceil(smooth);
else smooth = Math.floor(smooth);
if (IE) bssm.pixelTop+=smooth;
if (NS6||NS) bssm.top=parseInt(bssm.top)+smooth
lastY = lastY+smooth;
setTimeout('makeStatic()', 1)}}

function buildBar() {
if(barText.indexOf('<IMG')>-1) {tempBar=barText}
else{for (b=0;b<barText.length;b++) {tempBar+=barText.charAt(b)+"<BR>"}}
document.write('<td align="center" rowspan="100" width="'+barWidth+'" bgcolor="'+barBGColor+'" valign="'+barVAlign+'"><p align="center"><font face="'+barFontFamily+'" Size="'+barFontSize+'" COLOR="'+barFontColor+'"><B>'+tempBar+'</B></font></p></TD>')}

function initSlide() {
if (NS6){ssm=document.getElementById("thessm").style;bssm=document.getElementById("basessm").style;
bssm.clip="rect(0 "+document.getElementById("thessm").offsetWidth+" "+document.getElementById("thessm").offsetHeight+" 0)";ssm.visibility="visible";}
else if (IE) {ssm=document.all("thessm").style;bssm=document.all("basessm").style
bssm.clip="rect(0 "+thessm.offsetWidth+" "+thessm.offsetHeight+" 0)";bssm.visibility = "visible";}
else if (NS) {bssm=document.layers["basessm1"];
bssm2=bssm.document.layers["basessm2"];ssm=bssm2.document.layers["thessm"];
bssm2.clip.left=0;ssm.visibility = "show";}
if (menuIsStatic=="yes") makeStatic();}

function buildMenu() {
if (IE||NS6) {document.write('<DIV ID="basessm" style="visibility:hidden;Position : Absolute ;Left : '+XOffset+' ;Top : '+YOffset+' ;Z-Index : 20;width:'+(menuWidth+barWidth+10)+'"><DIV ID="thessm" style="Position : Absolute ;Left : '+(-menuWidth)+' ;Top : 0 ;Z-Index : 20;" onmouseover="moveOut()" onmouseout="moveBack()">')}
if (NS) {document.write('<LAYER name="basessm1" top="'+YOffset+'" LEFT='+XOffset+' visibility="show"><ILAYER name="basessm2"><LAYER visibility="hide" name="thessm" bgcolor="'+menuBGColor+'" left="'+(-menuWidth)+'" onmouseover="moveOut()" onmouseout="moveBack()">')}
if (NS6){document.write('<table border="0" cellpadding="0" cellspacing="0" width="'+(menuWidth+barWidth+2)+'" bgcolor="'+menuBGColor+'"><TR><TD>')}
document.write('<table border="0" cellpadding="0" cellspacing="1" width="'+(menuWidth+barWidth+2)+'" bgcolor="'+menuBGColor+'">');
for(i=0;i<ssmItems.length;i++) {
if(!ssmItems[i][3]){ssmItems[i][3]=menuCols;ssmItems[i][5]=menuWidth-1}
else if(ssmItems[i][3]!=menuCols)ssmItems[i][5]=Math.round(menuWidth*(ssmItems[i][3]/menuCols)-1);
if(ssmItems[i-1]&&ssmItems[i-1][4]!="no"){document.write('<TR>')}
if(!ssmItems[i][1]){
document.write('<td bgcolor="'+hdrBGColor+'" HEIGHT="'+hdrHeight+'" ALIGN="'+hdrAlign+'" VALIGN="'+hdrVAlign+'" WIDTH="'+ssmItems[i][5]+'" COLSPAN="'+ssmItems[i][3]+'">&nbsp;<font face="'+hdrFontFamily+'" Size="'+hdrFontSize+'" COLOR="'+hdrFontColor+'"><b>'+ssmItems[i][0]+'</b></font></td>')}
else {if(!ssmItems[i][2])ssmItems[i][2]=linkTarget;
document.write('<TD BGCOLOR="'+linkBGColor+'" onmouseover="bgColor=\''+linkOverBGColor+'\'" onmouseout="bgColor=\''+linkBGColor+'\'" WIDTH="'+ssmItems[i][5]+'" COLSPAN="'+ssmItems[i][3]+'"><ILAYER><LAYER onmouseover="bgColor=\''+linkOverBGColor+'\'" onmouseout="bgColor=\''+linkBGColor+'\'" WIDTH="100%" ALIGN="'+linkAlign+'"><DIV  ALIGN="'+linkAlign+'"><FONT face="'+linkFontFamily+'" Size="'+linkFontSize+'">&nbsp;<A HREF="'+ssmItems[i][1]+'" target="'+ssmItems[i][2]+'" CLASS="ssmItems">'+ssmItems[i][0]+'</DIV></LAYER></ILAYER></TD>')}
if(ssmItems[i][4]!="no"&&barBuilt==0){buildBar();barBuilt=1}
if(ssmItems[i][4]!="no"){document.write('</TR>')}}
document.write('</table>')
if (NS6){document.write('</TD></TR></TABLE>')}
if (IE||NS6) {document.write('</DIV></DIV>')}
if (NS) {document.write('</LAYER></ILAYER></LAYER>')}
theleft=-menuWidth;lastY=0;setTimeout('initSlide();', 1)}
and this of ssmItems.js
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
<!--

/*
Configure menu styles below
NOTE: To edit the link colors, go to the STYLE tags and edit the ssm2Items colors
*/
YOffset=100; // no quotes!!
XOffset=0;
staticYOffset=50; // no quotes!!
slideSpeed=20 // no quotes!!
waitTime=300; // no quotes!! this sets the time the menu stays out for after the mouse goes off it.
menuBGColor="#999999";
menuIsStatic="yes"; //this sets whether menu should stay static on the screen
menuWidth=120; // Must be a multiple of 10! no quotes!!
menuCols=2;
hdrFontFamily="verdana";
hdrFontSize="1";
hdrFontColor="#ffffff";
hdrBGColor="#999999";
hdrAlign="left";
hdrVAlign="center";
hdrHeight="15";
linkFontFamily="Verdana";
linkFontSize="1";
linkBGColor="#ccccccc";
linkOverBGColor="#FFcc66";
linkTarget="_top";
linkAlign="Left";
barBGColor="#ff9900";
barFontFamily="Verdana";
barFontSize="1";
barFontColor="#ffffff"; //EAE8CF
barVAlign="center";
barWidth=10; // no quotes!!
barText=" .:: Navigator ::. "; // <IMG> tag supported. Put exact html for an image to show.

///////////////////////////

// ssmItems[...]=[name, link, target, colspan, endrow?] - leave 'link' and 'target' blank to make a header
ssmItems[0]=["»Community"] //create header
ssmItems[1]=["Portal", "../portal/index.php", ""]
ssmItems[2]=["Homepage", "../main_frame.html", "_blank"]
ssmItems[3]=["Foren-Übersicht", "../phpBB2/index.php", ""]
ssmItems[4]=["Community Regeln", "../phpbBB2/rules.php", ""]
ssmItems[5]=["»Foren Menü"]
ssmItems[6]=["Statistik", "../phpBB2/statistics.php", "",]
ssmItems[7]=["FAQs", "../phpBB2/faq.php", "", 1, "no"]
ssmItems[8]=["Suchen", "../phpBB2/search.php", "", 1]
ssmItems[9]=["Mitgliederliste", "../phpBB2/memberlist.php", ""]
ssmItems[10]=["Benutzergruppen", "../phpBB2/groupcp.php", ""]
ssmItems[11]=["Profil", "../phpBB2/profile.php?mode=editprofile", "", 1, "no"]
ssmItems[12]=["PN-Box", "../phpBB2/privmsg.php?folder=inbox", "", 1]
ssmItems[13]=["Kalender", "../phpBB2/calendar.php", "", 1, "no"]
ssmItems[14]=["Links", "../phpBB2/links.php", "", 1]
ssmItems[15]=["»Service"]
ssmItems[16]=["Neue Beiträge", "../phpBB2/search.php?search_id=newposts", ""]
ssmItems[17]=["Eigene Beiträge", "../phpBB2/search.php?search_id=egosearch", ""]
ssmItems[18]=["Wer ist online?", "../phpBB2/viewonline.php", ""]
ssmItems[19]=["Avatar einrichten", "../phpBB2/profile.php?mode=editprofile#avatar", ""]
ssmItems[20]=["PW vergessen?", "../phpBB2/profile.php?mode=sendpassword", ""]
ssmItems[21]=[""]
buildMenu();

//-->
Logged
helluvaguy
Jr. Member
**
Offline Offline

Posts: 52

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #7 on: February 19, 2003, 11:51:21 AM »

Just a humble inquiry, if someone is able to tell me why the above mentioned DHTML script causes these problems with the display of audio and video?

------------------------------------------------------------------------------

Nur mal eine bescheidene Nachfrage, ob mir jemand erklären kann, warum das oben erwähnte DHTML Script zu diesen Problemen bei der Darstellung von Audio und Video Dateien führt?
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.278 seconds with 19 queries.