4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 24, 2014, 05:21:45 PM

Login with username, password and session length
Search:     Advanced search
Follow 4images on twitter: Click here to follow!
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Issues / Ausgaben
| |-+  Discussion & Troubleshooting (Moderators: Acidgod, ivan, Rembrandt)
| | |-+  Division By Zeror Error in error_log File
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: Division By Zeror Error in error_log File  (Read 3158 times)
khansahib
Full Member
***
Offline Offline

Posts: 100

Thank You
-Given: 14
-Receive: 2


View Profile
« on: December 30, 2011, 05:45:41 AM »

Hello,

I was checking the error_log file and I can see the following error message in that file.

Quote  [Expand]
[30-Dec-2011 08:35:19] PHP Warning:  Division by zero in /home/site/public_html/gallery/includes/functions.php on line 315

whereas on line 315 in functions.php I can see the following:

1
$exif_array[$exif_match[$key]] = "1/".round((1/($ExposureTime[0]/$ExposureTime[1])),0)." sec(s)";

Please suggest how to resolve this.

Cordially,
Khansahib
Logged
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 556

mmm PHP...


View Profile WWW
« Reply #1 on: December 30, 2011, 01:33:06 PM »

What is your 4images version?
This has been fixed in 1.7.10
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
khansahib
Full Member
***
Offline Offline

Posts: 100

Thank You
-Given: 14
-Receive: 2


View Profile
« Reply #2 on: December 30, 2011, 03:22:36 PM »

What is your 4images version?
This has been fixed in 1.7.10


Sir, 4images version is the updated one i.e. 1.7.10 I have posted the line which is pointed out by error_log file. Is there anything wrong with the posted php code?

Also I have attached my gallery's functions.php file

Please suggest.

* functions.php (71.8 KB - downloaded 4 times.)
Logged
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 556

mmm PHP...


View Profile WWW
« Reply #3 on: December 30, 2011, 04:44:55 PM »

This is strange, in theory no such errors should occur...can you provide the image that produces this error? I'd like to see what's in the EXIF of it.
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
khansahib
Full Member
***
Offline Offline

Posts: 100

Thank You
-Given: 14
-Receive: 2


View Profile
« Reply #4 on: December 30, 2011, 05:03:54 PM »

Hello,

I have attached the error_log file, I hope you will review it.

* error_log.txt (6.85 KB - downloaded 8 times.)
Logged
khansahib
Full Member
***
Offline Offline

Posts: 100

Thank You
-Given: 14
-Receive: 2


View Profile
« Reply #5 on: November 03, 2012, 05:34:51 PM »

I can still see the same error, can anybody please update me?
Logged
Rembrandt
Moderator
4images Guru
*****
Offline Offline

Posts: 4085

Thank You
-Given: 106
-Receive: 858

Vienna


View Profile WWW
« Reply #6 on: November 03, 2012, 07:38:22 PM »

Hi!
I can still see the same error, can anybody please update me?
what for 4images version, and:
This is strange, in theory no such errors should occur...can you provide the image that produces this error? I'd like to see what's in the EXIF of it.

mfg Andi
Logged

Meine 4Images Modifikationen  Now over 100 Modification Online!    Meine 4images Demo Seite


Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
khansahib
Full Member
***
Offline Offline

Posts: 100

Thank You
-Given: 14
-Receive: 2


View Profile
« Reply #7 on: November 04, 2012, 02:38:45 AM »

Hi!
I can still see the same error, can anybody please update me?
what for 4images version, and:
This is strange, in theory no such errors should occur...can you provide the image that produces this error? I'd like to see what's in the EXIF of it.

mfg Andi

mfg,

there is not image details all I can see in error_log files is already attached, can you please guide me so I can follow those steps in-order to get EXIF of it.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.104 seconds with 20 queries.