4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 18, 2018, 01:37:32 PM

Login with username, password and session length
Search:     Advanced search
You're looking for some 4images templates and styles? Then visit this thread to show websites with 4images templates to download.
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Help / Hilfe
| |-+  Bug Fixes & Patches
| | |-+  [1.7 - 1.7.6] Additional user fields not being used for guests
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: [1.7 - 1.7.6] Additional user fields not being used for guests  (Read 23914 times)
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 578

mmm PHP...


View Profile WWW
« on: September 15, 2008, 05:29:47 AM »

This bug doesn't affect 4images itself, only possibly some MODs.

$additinal_user_fields array not being used for guests, and $user_info array will contain only default 4images fields, which might through out warning messages in some MODs.

The fix is simple:
in includes/sessions.php find:

1
    return $user_info;

Insert ABOVE:
1
2
3
4
5
6
7
8
    global $additional_user_fields;
    foreach (
$additional_user_fields as $key => $val)
    {
      if (!isset(
$user_info[$key]))
      {
        
$user_info[$key] = "";
      }
    }
« Last Edit: September 15, 2008, 02:35:13 PM by V@no » Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
mawenzi
4images Moderator
4images Guru
*****
Offline Offline

Posts: 4500

Thank You
-Given: 36
-Receive: 121


View Profile
« Reply #1 on: September 15, 2008, 10:26:53 AM »

... thanks for sharing this fix ...
... but now there is the following error message ...
1
Warning: Invalid argument supplied for foreach() in /usr/export/www/.../includes/sessions.php on line ...
« Last Edit: September 15, 2008, 01:35:54 PM by mawenzi » Logged

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 578

mmm PHP...


View Profile WWW
« Reply #2 on: September 15, 2008, 02:35:44 PM »

Ops...forgot add global.
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
mawenzi
4images Moderator
4images Guru
*****
Offline Offline

Posts: 4500

Thank You
-Given: 36
-Receive: 121


View Profile
« Reply #3 on: September 16, 2008, 01:36:17 PM »

... ok ... now it is perfect ...
... thanks again ...
Logged

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...
hannes61
Newbie
*
Offline Offline

Posts: 15

Thank You
-Given: 2
-Receive: 0


View Profile
« Reply #4 on: November 06, 2008, 08:32:24 AM »

Solves this the problem for the detailed view, where it is possible to add
comments to an image without filling the spam check?


Logged

V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 578

mmm PHP...


View Profile WWW
« Reply #5 on: November 06, 2008, 09:03:19 AM »

Welcome to 4images forum.
Open global.php and change to 0 where you don't want have captcha:
1
2
3
4
5
$captcha_enable              = 1;
$captcha_enable_comments     = 1;
$captcha_enable_upload       = 1;
$captcha_enable_registration = 1;
$captcha_enable_postcards    = 1;
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
hannes61
Newbie
*
Offline Offline

Posts: 15

Thank You
-Given: 2
-Receive: 0


View Profile
« Reply #6 on: November 06, 2008, 11:09:47 AM »

Thanks.

Now I know more about, where to change settings for CAPTCHA.
Only Big Chars, ... Smile

But I had the case, that i could add comments without filling the CAPTCHA field,
even when  it was displayed.  Rolling Eyes

But now it seems to work. Only comments can be send when the field  is filled.

Thanks again, Hannes 
Logged

Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.216 seconds with 19 queries.