4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2018, 02:09:54 AM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  International
| |-+  Español / Castellano (Moderator: benzo)
| | |-+  Ayuda MOD Member Personal Photo y user_logininfo.html
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: Ayuda MOD Member Personal Photo y user_logininfo.html  (Read 9385 times)
rumpinavia
Pre-Newbie

Offline Offline

Posts: 2

Thank You
-Given: 0
-Receive: 0


View Profile
« on: August 21, 2008, 11:17:57 PM »

Hola a todos.

Instale el mod Personal Member Photo, y deseo mostrar el avatar del usuario en el user_logininfo.html para que cuando inicie sesion, se muestre su avatar. El codigo del user_logininfo es el siguiente

1
2
3
4
5
6
7
8
9
10
11
<table width="100%" border="0" cellpadding="4" cellspacing="0">
  <tr>
    <td valign="top" align="left"><p>{lang_loggedin_msg}<br />
           {if userpic_img}         
          <img src="{userpic_img}">       
{endif userpic_img}
   </p>
      <p>&raquo; <a href="{url_control_panel}">{lang_control_panel}</a><br />
      &raquo; <a href="{url_logout}">{lang_logout}</a></p></td>
  </tr>
</table>

Y no muestra el avatar en la seccion, si los muestra en la edicion de perfil y los comentarios, tal cual como el mod lo especifica (asi que podria descartar que sea por mala implementacion del mod).

Alguna recomendacion para esto.

De Antemano gracias

Pablo
Logged
rumpinavia
Pre-Newbie

Offline Offline

Posts: 2

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #1 on: August 29, 2008, 07:00:35 AM »

Solucionado jejeje

en tu template/user_logininfo.html

1
2
3
4
5
6
7
8
9
<table width="100%" border="0" cellpadding="4" cellspacing="0">
  <tr>
    <td valign="top" align="left"><p>{lang_loggedin_msg}<br />
       {userpic}       
   </p>
      <p>&raquo; <a href="{url_control_panel}">{lang_control_panel}</a><br />
      &raquo; <a href="{url_logout}">{lang_logout}</a></p></td>
  </tr>
</table>

Y en includes/page_header.php

Buscar
1
"url_lost_password" => (!empty($url_lost_password)) ? $site_sess->url($url_lost_password) : $site_sess->url(ROOT_PATH."member.php?action=lostpassword"),

añadir debajo
1
"userpic" => ($config['userpic']) ? "<img src=\"".ROOT_PATH."data/userpic/".(($user_info['userpic'] == "") ? "blank.gif" : $user_info['userpic'])."\" name=\"icons\" border=\"0\" alt=\"\">" : "",

y eso era todo jejej

Pablo Navia N.
Logged
Enguma
Pre-Newbie

Offline Offline

Posts: 1

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #2 on: October 10, 2015, 05:58:39 PM »

If the user does not have uploaded Avatar, so you see "blank.gif".
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.091 seconds with 19 queries.
Post your comments here