4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 16, 2018, 06:13:19 AM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Help / Hilfe
| |-+  FAQ, Tips
| | |-+  Lost admin password - what to do?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 » »» Print
Author Topic: Lost admin password - what to do?  (Read 46135 times)
Jayeth33
Pre-Newbie

Offline Offline

Posts: 9

Thank You
-Given: 0
-Receive: 0


View Profile WWW
« on: September 12, 2002, 11:00:49 PM »

Is there anyway to retrive a lost admin password?

I  set up a local copy, but dont remember the pass word that the admin user has, as it was several days/weeks ago.

any help retriving the lost password or do i just need to reinstall


jaye
« Last Edit: December 05, 2007, 01:00:51 AM by kai » Logged
Nicky
Administrator
4images Guru
*****
Offline Offline

Posts: 3195

Thank You
-Given: 26
-Receive: 56


View Profile
« Reply #1 on: September 12, 2002, 11:30:10 PM »

there is a link in enduser section click on "Forgot password".

if you don't have a mail server on your local PC..

phpmysqladmin:
put this into your 4image_users / user_password field where is your admin username
21232f297a57a5a743894a0e4a801fc3

this is for password: admin
Logged

cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi
martino
Pre-Newbie

Offline Offline

Posts: 4

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #2 on: September 28, 2007, 04:00:22 PM »

Hello,

I have a similar problem.  My gallery had been hacked - I then updated to the latest version of 4images (1.7.4).  I was then able to view my gallery again.
The problem is, I have missplaced my user/pass for the admin section.  I have entered phpmysqladmin but I cannot find this field: 21232f297a57a5a743894a0e4a801fc3 nor can I find the username: admin when I browse the records.

Any help would be greatly appreciated.
Thanks!
Logged
mawenzi
4images Moderator
4images Guru
*****
Offline Offline

Posts: 4500

Thank You
-Given: 36
-Receive: 121


View Profile
« Reply #3 on: September 28, 2007, 04:26:01 PM »

... please read Nickys post carefully ... !
... and realise it so ...
Logged

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...
martino
Pre-Newbie

Offline Offline

Posts: 4

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #4 on: September 28, 2007, 04:55:06 PM »

The problem is that there is no "admin" username anymore.
I have added user_name - admin and user_password: 21232f297a57a5a743894a0e4a801fc3 but it still doesn't let me enter Admin section.

Logged
mawenzi
4images Moderator
4images Guru
*****
Offline Offline

Posts: 4500

Thank You
-Given: 36
-Receive: 121


View Profile
« Reply #5 on: September 28, 2007, 05:10:25 PM »

... please read Nickys post carefully ... !
Quote  [Expand]

put this into your 4image_users / user_password field where is your admin username
21232f297a57a5a743894a0e4a801fc3

... I think you know your admin-username ... and I think it is not admin ... admin is your new password ... !
Logged

Your first three "must do" before you ask a question ! ( © by V@no )
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

You are on search for top 4images MOD's ?
- then please search here ... Mawenzi's Top 100+ MOD List (unsorted sorted) ...
martino
Pre-Newbie

Offline Offline

Posts: 4

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #6 on: September 28, 2007, 05:58:51 PM »

The admin username was in fact "admin" but its not there anymore.  When I added it via phpmyadmin it still will not let me access the admin section.
Logged
ivan
4images Moderator
4images Guru
*****
Offline Offline

Posts: 2279

Thank You
-Given: 4
-Receive: 31


View Profile WWW
« Reply #7 on: September 28, 2007, 06:02:20 PM »

1) registry a new member with name test123

2) got to phpadmin and search this name test123

3) then copy this code in the password field
21232f297a57a5a743894a0e4a801fc3

4) set the code in user_level field to 9

5) go to your website (new data for admin)
username: test123
password: admin

6) replace/change the username and password in acp

7) update your gallery of 1.7.4

Cool read this instruction http://www.4homepages.de/forum/index.php?topic=14982.0
and make a htacess of admin folder

* 2007-09-28_180634.gif (28.2 KB - downloaded 567 times.)
« Last Edit: September 28, 2007, 06:13:17 PM by ivan » Logged

greetings / grüsse
ivan

Facebook Fan Page | Follow Twitter

Blog: Reisen Blog
Bilder Gallery: Bilder Gallery
martino
Pre-Newbie

Offline Offline

Posts: 4

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #8 on: September 28, 2007, 06:39:41 PM »

Thanks to the help - it worked!  Very Happy

Much appreciated.
M
Logged
akynos
Pre-Newbie

Offline Offline

Posts: 3

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #9 on: November 29, 2007, 05:48:56 AM »

Ok so i read this thread but am still lost because i need it broken down to be like i'm five years old. so deep breath...here goes.

my web designer left me high and dry with a site that if i have issues with its very difficult to resolve.
after having to change all my passwords for all the admin areas of my site and email accts i am unable to login to the members admin area of my site which uses 4images.
i do not know how to do this, i am not a site designer, but my site was designed so i could update it myself. i guess it was not anticipated that i may run into issues like my username and password.
i can login to the preview admin, but the members admin username and password is not working.

can someone please tell me, step by step, how i would go about fixing this issue so i can update my site, without making a mess of things. can this task me done by someone with no experience with web development but has some common sense. i would be so grateful for a response, i really need to get into my site!

Akynos
Logged
Nicky
Administrator
4images Guru
*****
Offline Offline

Posts: 3195

Thank You
-Given: 26
-Receive: 56


View Profile
« Reply #10 on: November 29, 2007, 08:36:03 AM »

hi..

try this..

create file with name pw.php and put this into this file
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<?php
define
('ROOT_PATH''./');
include(
ROOT_PATH.'config.php');
include(
ROOT_PATH.'includes/db_mysql.php');
include(
ROOT_PATH.'includes/constants.php');
include(
ROOT_PATH.'includes/functions.php');
$site_db = new Db($db_host$db_user$db_password$db_name);
$sql "UPDATE ".USERS_TABLE." SET user_password = '21232f297a57a5a743894a0e4a801fc3' WHERE user_level =".ADMIN."";
$site_db->query($sql);


$sql2 "SELECT user_name FROM ".USERS_TABLE." WHERE user_level =".ADMIN."";
$result $site_db->query($sql2);
    while (
$user_row $site_db->fetch_array($result)) {
       echo 
"Password changed for user: <b>".format_text($user_row['user_name'], 2)."</b><br />\n";
    }
?>


save it.

upload file pw.php via ftp there where your config.php is (root of 4images folder).

now start you webbrowser.
call this url > http://yoursite.com/your4imagesfolder/pw.php

you will see a site with administrator usernames where password was changed

 Exclamation Exclamation  Arrow Arrow Delete file pw.php from server.

note:
for ALL administrators on your 4images site password will be changend to password admin

try now to login to administrator area
« Last Edit: March 04, 2008, 08:41:53 AM by Nicky » Logged

cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi
akynos
Pre-Newbie

Offline Offline

Posts: 3

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #11 on: November 29, 2007, 01:30:14 PM »

nicky thank u so much for the quick response. however there is one issue i have, i have no idea where i am creating this. let me take a guess from past experience, i can create this in wordpad, then upload it correct? now when i upload it to config php? where exactly is that folder or am i misunderstanding something  here? i going to look for that, and i pray this works, tho i'm sure it will! forgive my ignorance but i seriously have no clue. i need to know all those details so i can try and fix this problem which i've been having for months. thank u so much!

Akynos
Logged
Nicky
Administrator
4images Guru
*****
Offline Offline

Posts: 3195

Thank You
-Given: 26
-Receive: 56


View Profile
« Reply #12 on: November 29, 2007, 01:51:53 PM »

example of a php editor > http://www.pspad.com/en/download.php (download it)
and create the pw.php file

or take another one > http://www.google.at/search?hl=en&q=php+free+editor&btnG=Google-Suche&meta=

send me your 4images url over Private Message.
Logged

cheers
Nicky
Your first three "must do" before you ask a question ! (© by V@no)
- please read the Forum Rules ...
- please study the FAQ ...
- please try to Search for your answer ...

nicky.net 4 4images
Signature stolen from mawenzi
manurom
Guest
« Reply #13 on: November 29, 2007, 02:07:53 PM »

Hello;
@Nicky, very nice job!

@akynos, please trust in Nicky. He will help you a lot!

Hope you'll get rid of your problem.
Logged
akynos
Pre-Newbie

Offline Offline

Posts: 3

Thank You
-Given: 0
-Receive: 0


View Profile
« Reply #14 on: November 29, 2007, 03:17:17 PM »

am totally listening to nicky and so thankful for the help!

-A
Logged
Pages: [1] 2 » »» Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.051 seconds with 19 queries.
Post your comments here