4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 24, 2014, 07:48:07 AM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Modifications / Modifikationen
| |-+  Mods & Plugins (Releases & Support) (Moderators: mawenzi, Rembrandt)
| | |-+  [MOD] Google Friendly Urls For 4images Best Seo Mod
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: «« « 1 ... 23 24 25 26 [27] 28 29 30 31 32 » »» Print
Current Topic Rating: *****
Author Topic: [MOD] Google Friendly Urls For 4images Best Seo Mod  (Read 298764 times)
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 549

mmm PHP...


View Profile WWW
« Reply #390 on: September 24, 2010, 02:48:31 PM »

This is not a problem, this is how it supposed to be...

http://www.blooberry.com/indexdot/html/topics/urlencoding.htm#whatwhy
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
Nosferatu
Full Member
***
Offline Offline

Posts: 204

Thank You
-Given: 30
-Receive: 7


View Profile WWW
« Reply #391 on: September 24, 2010, 04:28:05 PM »

kk thx

and is that a problem for search bots / engins,... google, bing, .... ?
Logged

V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 549

mmm PHP...


View Profile WWW
« Reply #392 on: September 24, 2010, 04:39:39 PM »

I doubt it
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
Nosferatu
Full Member
***
Offline Offline

Posts: 204

Thank You
-Given: 30
-Receive: 7


View Profile WWW
« Reply #393 on: September 24, 2010, 05:14:34 PM »

Someone send me with email that:

In includes/functions.php file,
 
find:
1
2
3
4
if (strpos($text, "@")) {
    $text = preg_replace("#([\n ])([a-z0-9\-_.]+?)@([\w\-]+\.([\w\-\.]+\.)?[\w]+)#i", "\\1<a href=\"mailto:\\2@\\3\">\\2@\\3</a>", $text);
  }
 
add below:
1
2
3
4
5
6
7
8
9
if (strpos($text, "%20")) {
    $text = str_replace("%20", "_", $text);
  }
  if (strpos($text, "%26")) {
    $text = str_replace("%26", "_", $text);
  }
  if (strpos($text, "%24")) {
    $text = str_replace("%24", "_", $text);
  }

That dont work Sad
Logged

V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 549

mmm PHP...


View Profile WWW
« Reply #394 on: September 24, 2010, 05:57:01 PM »

assuming you are using optimized version of this mod, then you can add as replacement characters for spaces, commas, etc inside fix_name function:
1
2
3
      " " => "_", //space
      "," => "_", //comma
      "$" => "_", //dollar sign
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
Nosferatu
Full Member
***
Offline Offline

Posts: 204

Thank You
-Given: 30
-Receive: 7


View Profile WWW
« Reply #395 on: September 24, 2010, 09:48:39 PM »

i think i checked it Wink

in database and so the name is right eg: u, v, w, x, y, z

in sitescript i have

u%2C-v%2C-w%2C-x%2C-y%2C-z

and "," dont work in web i thnk

if i write in the session "%2C" => "-",

it dont work...

but if i write "," => "X",

it work.....

is that right that i can't user , ?
Logged

V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 549

mmm PHP...


View Profile WWW
« Reply #396 on: September 24, 2010, 10:00:46 PM »

%2C - is not a character, it's an HEX code for a character, therefor you can't use it for replacement, at least not like that.

"," => "X",  - this is the same format as I showed, if it works, then what is the problem? Wink
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
Nosferatu
Full Member
***
Offline Offline

Posts: 204

Thank You
-Given: 30
-Receive: 7


View Profile WWW
« Reply #397 on: September 24, 2010, 10:09:25 PM »

ok Wink "," isnt a real problem but i add now all things that i cant use ....

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
     "," => "",
      "/" => "",
      ":" => "",
      "ö" => "oe",
      "ä" => "ae",
      "ü" => "ue",
      "(" => "",
      ")" => "",
      "!" => "",
      "*" => "",
      "ß" => "ss",
      "?" => "",
      "&" => "and",        
      "=" => "is",
      "+" => " and ",
  "[" => "",
  "]" => "",
  "%" => "",
  "#" => "",
  "@" => "",

and i am not finish ....
Thats not normal i think ...

Edit: i am finish now Wink i hope it
Logged

didoman
Newbie
*
Offline Offline

Posts: 32

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #398 on: October 13, 2010, 02:56:59 PM »

I am using the .htaccess from the first page and Vano's optimized session.php
Everything works fine. Thanks.

I have been through the thread (twice) and see that a few people want a cosmetic change to the cat and img that precede the URL.
ie. Just cosmetically changing the pointers "img" and "cat" to another word

Example I would like to change the name of "img" to "movie"
http://example.com/movie-example-1132.htm

I believe Vano mentioned ages ago that those 3 letters are just cosmetic and can be changed but I can't find out how to do it. Nobody mentions how in any thread.

I assumed it would just be a simple matter of changing the line in .htaccess, --- but this doesn't work
eg. RewriteRule ^movie-(.*)-([0-9]+)\.htm$ details.php?image_id=$2&%{QUERY_STRING}

Is there something I have to change elsewhere in sessions.php?

Just wondering if anybody could help out with this one. Thanks

Reminder  Laughing


« Last Edit: October 24, 2010, 05:00:44 AM by didoman » Logged
didoman
Newbie
*
Offline Offline

Posts: 32

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #399 on: October 25, 2010, 06:47:10 AM »

Hi,
Sorry to pest, but anybody know a quick answer to my last question.  Embarassed
Logged
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 549

mmm PHP...


View Profile WWW
« Reply #400 on: October 26, 2010, 03:42:10 AM »

Yes, you need change a few lines in step 4.
for example search for (part of a line):
1
str_replace('details.php', 'img

and

1
str_replace('categories.php', 'cat
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
didoman
Newbie
*
Offline Offline

Posts: 32

Thank You
-Given: 0
-Receive: 1


View Profile
« Reply #401 on: October 26, 2010, 07:27:41 AM »

Excellent, changing this and also in .htaccess works great.
Once again Vano thank you for your brilliant help. Your help over the years has been an inspiration to a lot people.  Laughing

I am now trying to figure out a way for search to also show the image name. Little bit more tricky.
eg. example.com/movie222.search.htm  -->  example.com/movie222.image-name.htm

That is to include the name of the image in the search URL.
Not sure if it helps with Google, but you never know?

Any hints you can throw my way will be appreciated.
Logged
chintan100
Pre-Newbie

Offline Offline

Posts: 5

Thank You
-Given: 1
-Receive: 0


View Profile
« Reply #402 on: November 13, 2010, 02:33:34 PM »

Hi,

I have a weird problem.

My site is http://www.lotofwallpapers.com  and i have installed this mod by following the instructions in the first post. 4images version is 1.7.8.

My .htaccess file looks exactly like the one in the first post and i have also checked sessions.php twice to make sure everything is according to post.

The mod works fine for entire site except search.

As you can see, i have 28 ferrari modena wallpapers on site right now but if i search for "ferrari" in the search, it says "Your search resulted in no matching records."  Shocked
Same goes for searching "modena".  Shocked

To be sure installing the facebook mod did not have any effect, i installed the script on local server and then added only this mod but it is also giving the same problem.  Confused
I searched this topic for the word "search" and went through all the resulting posts but non helped. Sad

Someone please help me.
Logged
chintan100
Pre-Newbie

Offline Offline

Posts: 5

Thank You
-Given: 1
-Receive: 0


View Profile
« Reply #403 on: November 19, 2010, 09:36:31 AM »

Can anyone answer this question please?
Logged
raghunadhreddys
Newbie
*
Offline Offline

Posts: 46

Thank You
-Given: 3
-Receive: 1


View Profile
« Reply #404 on: December 03, 2010, 04:34:59 AM »

Hi friends i am using 4images latest version.and i installed seo friendly urls plugin.

when i tried to send an e-card its showing the error message

"The requested URL /postcard.img122.htm was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."


And also,user registration verification,for got password functions are not working.

please solve my problem
Logged
Pages: «« « 1 ... 23 24 25 26 [27] 28 29 30 31 32 » »» Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
piqs.de - Fotocommunity & lizenzfreie Fotos
Page created in 0.105 seconds with 20 queries.