4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
February 18, 2018, 11:23:45 PM

Login with username, password and session length
Search:     Advanced search
You're looking for some 4images templates and styles? Then visit this thread to show websites with 4images templates to download.
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
+  4images Forum & Community
|-+  4images Help / Hilfe
| |-+  Error Messages / Fehlermeldungen
| | |-+  Warning: session_start(): open(
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: Warning: session_start(): open(  (Read 20499 times)
V@no
If you don't tell me what to do, I won't tell you where you should go :)
Administrator
4images Guru
*****
Offline Offline

Posts: 17849

Thank You
-Given: 47
-Receive: 565

mmm PHP...


View Profile WWW
« on: January 17, 2006, 01:22:22 AM »

This error became pretty common around here. Unfortunetly the only thing you can do about it is contact your host's administrator and hope they fix this as soon as possible.

This is server-side problem and without root access to the server is not possible to fix it.


I was suffering from the same problem that many are ... seeing these messages when you run 4images:

 Fatal error: session_start(): Failed to initialize storage module: user (path: /tmp) in
 /your_home_directory/path_to_4images_gallery/includes/sessions.php on line 84

If you are getting this message *CONSISTENTLY*, then there is clearly something wrong with the hosting company's server setup, and you need to ask them to take a look. Hopefully, they will fix it.

But, if 4Images works fine most of the time, and you sometimes see one of these messages, or your server seems to get hung up on them for a minute or so, then it starts working again ... try this:

Create a /tmp/sessions directory in your home directory, check the permission to make sure it is writeable, then add the following line to .htaccess:

php_value session.save_path /your_home_directory/tmp/sessions

This solved my problem 100%, and I assume it will work for many of you, too. This simply isolates your 4Images session variables to a private /tmp space, avoiding whatever conflicts were causing the problem.
Logged

Your first three "must do" before you ask a question:
Please do not PM me asking for help unless you've been specifically asked to do so. Such PMs will be deleted without answer. (forum rule #6)
Extension for Firefox/Thunderbird: Master Password+    Back/Forward History Tweaks (restartless)    Cookies Manager+    Fit Images (restartless for Thunderbird)
wasimkhan
Newbie
*
Offline Offline

Posts: 14

Thank You
-Given: 8
-Receive: 0


View Profile
« Reply #1 on: January 27, 2011, 02:13:08 PM »

Warning: imagettftext() expects parameter 1 to be resource, boolean given in gallery\includes\annotate.php on line 192  any one can solve this
Logged
wassimo
Newbie
*
Offline Offline

Posts: 22

Thank You
-Given: 4
-Receive: 0


View Profile
« Reply #2 on: January 27, 2011, 05:38:08 PM »

thanks  V@no   Very Happy
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.043 seconds with 19 queries.