4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 15, 2018, 10:33:40 PM

Login with username, password and session length
Search:     Advanced search
Follow 4images on twitter: Click here to follow!
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
  Show Posts
Pages: [1] 2 3 4 5 ... 7 » »»
1  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: [MOD] Check new images in ALL categories v2.11 (updated 22-04-2006) on: November 21, 2009, 07:51:12 PM
I suddenly get error messages when checking for new images.

The gallery version is 1.7.7. with the checkimages mod.
After I updated to 177 and added the mod things worked, there were only some problems with adding new categories.
The current problem seems to have nothing to do with it though.

Error message:
Quote  [Expand]
Warning: opendir(./../data/media/1): failed to open dir: Permission denied in /home/<user>/public_html/<root>/admin/checkimages.php on line 800
This message appears for every category I have.

The line in question in checkimages.php is
800:
Quote  [Expand]
     if ($handle = opendir(MEDIA_PATH.$cat_path))


I tried:
uploading checkimages.php again
uploaded admin and inlcudes folder of  the original again, uploaded the mod files (including checkimages.php)

Same error. Could it be that the mod is not working with 1.7.7? Though why it used to work I don't know.
CMOD error? Not that I have changed anything ..

I do not want to have to delete everything and set it up again, I really get tired with it (and 4images galleries). *sigh*
Any ideas what to do, where to look?

2  4images Issues / Ausgaben / Installation, Update & Configuration / Re: Update - kann ich mit Mods etwas falsch machen? on: August 28, 2009, 06:04:29 PM
Danke. Inzwischen denke ich wirklich über einen Providerwechsel nach.
Bei einer kleinen Gallery geht's ja noch, aber sollte so etwas meiner großen (selber Provider, aber anderer Account) passieren .. nunja. Einmal hatte ich da ja schon das Vergnügen.

Nochmal nachgefragt. Daß mit dem Update die Mods überschrieben werden, ok. Logisch.
Nehmen wir mal einen Mod, der z.B thumbnailer.php ändert. Vor dem update kopiere ich die modifizierte Datei bzw. habe ich die schon am PC.

Dann mache ich das Update und spiele dann die (alte) modifizierte thumbnailer.php wieder hoch. Kann das ev. ein Sicherheitsproblem werden? Das Update macht man ja eben, um möglichst viel Sicherheit zu haben. Bei thumbnailer.php wird's wohl kein großes Problem sein, aber es sind ja unterschiedliche Dateien betroffen, je nach Mod.

Meine modifzierten Dateien sind inzwischen wohl von Vers. 1.7.4. oder sogar früher.
Andererseits werden aber die Dateien in den Mod-Downloads auch nicht laufend aktualisiert oder?

Leider werden wirklich gute Sachen wie halt batchcopymoveedit etc. nicht standardmäßig in die neuen Versionen übernommen. Bisher jedenfalls.


3  4images Issues / Ausgaben / Installation, Update & Configuration / Update - kann ich mit Mods etwas falsch machen? on: August 27, 2009, 08:51:38 PM
Ich habe eine allgemeine Frage zu Updates.

Ich habe einige Mods (z.B. batchcopymoveedit, autothumbnailer, checknewimages etc.). Dafür werden Files in die jeweiligen Verzeichnisse geladen, die die bestehenden überschreiben.
Wenn ich ein Update mache, überschreibe ich so aber die neuesten Files (z.B. images.php) mit einem recht alten File.
Kann damit der Effekt des Updates zunichte gemacht werden? Z.B. daß man Sicherheitslücken hat?

Wie macht ihr das denn, wenn ihr verschiedene Mods habt und die Galerie aber immer auf den neuesten Scriptstand halten wollt?

Und noch eine Frage - ist 4images besonders anfällig? Mir wurden nun zum 2. Mal in 4 Monaten Verzeichnisse gelöscht. Mein Provider meint (wie übich), es wäre wohl ein Hacker und es läge an veralteteten Scripts. In Frage kommen da aber nur die 4images Scripts, beides Version 1.7.6. Paßwort für den Account ändere ich auch öfters .. Komischer Hacker übrigens, der nur 2 Directories löscht ..
Redet mein Provider sich billig aus oder ist das eine vermehrte Tendenz?
4  4images Issues / Ausgaben / Discussion & Troubleshooting / Database reset nötig und wie? on: August 27, 2009, 08:42:20 PM
Nachdem meine Galerie gehackt wurde, waren die Media und Template Folder mit allen Unterverzeichnissen gelöscht.
Ich habe nun erstmal auf 1.7.7. upgraded (von 1.7.6.).
Dann einige Mods hinzugefügt. War vielleicht eine Spur voreilig ..

Gehe ich nun auf die index Seite, werden mir dort die alten Kategorien angezeigt. Natürlich ohne Bilder.
Füge ich manuell diese Kategorien in /media und /thumbnails ein und lade ein Bild in eine Kategorie wird es mit "check new images" nicht gefunden.

Mir bleibt da wohl nur ein komplettes reset bzw. Löschen der Database und Anlegen der Kategorien via cpanel - aber wie geht ein reset?
Geht das via 4images? Muß ich unbedingt mit mysqlmanager ran - damit kenne ich mich fast gar nicht aus - wenn es nur so geht, hat jemand vielleicht einen Link zu einer Anleitung für Dummies?

Ich habe gesehen, daß in "backup database" die Möglichkeit für ein reset besteht, weiß aber nicht, was es bewirkt. Da es eh schon egal war, habe ich es probiert, das war's aber nicht ..


5  4images Issues / Ausgaben / Discussion & Troubleshooting / Re: Erhalte Fehlermeldung bei Kategorieerstellung on: June 28, 2009, 04:22:26 PM
Häng mich mal hier dran, weil ich das gleiche Problem habe und auf Fehlersuche bin.

Quote  [Expand]
Setzen die angegebenen Zugriffsrechte für folgende Verzeichnisse:

     chmod 777 (drwxrwxrwx) : templates
     chmod 777 (drwxrwxrwx) : templates/default
     chmod 777 (drwxrwxrwx) : templates/default/media

     Setzen die angegebenen Zugriffsrechte für folgende Dateien:

     chmod 666 (-rw-rw-rw-) : alle Dateien im Verzeichnis "templates/default"
     chmod 666 (-rw-rw-rw-) : alle Dateien im Verzeichnis "templates/default/media"
Widerspricht sich das nicht? Erst soll man das Verzeichnis samt SubDirs auf 777 setzen, dann auf 666?

Und sind 777 cmods nicht ein offenes Tor für mögliche Hacker? Hatte schon öfter Probleme mit 4images Gallerien und mein Provider sagte immer, die cmods dürften nicht auf 777 stehen .. zwar sagen Provider immer solche Standardsätze, aber ist da nicht was Wahres dran?
Bei mir waren z.B. mal alle Folder in media gelöscht .. futsch.

6  4images Issues / Ausgaben / Discussion & Troubleshooting / Re: Unterschiedliche Bildgröße in details.php (html) und postcard.php (.html) on: January 31, 2009, 05:54:33 PM
Niemand?
Schade. Sad
7  4images Issues / Ausgaben / Discussion & Troubleshooting / Re: Unterschiedliche Bildgröße in details.php (html) und postcard.php (.html) on: January 24, 2009, 04:29:29 PM
Bitte für Dummies .. was genau müßte man wo einfügen, wenn man die Größe des Bildes in der e-card (und nur dort) festlegen will?
Und in welcher Datei - alle 3 postcard .. html nehme ich an, oder?


8  4images Issues / Ausgaben / Discussion & Troubleshooting / e-cards problem / e-cards Problem on: February 21, 2008, 02:19:13 PM
Gallery version: 1.7.4
Problem: recipients don't receive e-cards

Question: which settings do I need to enable this function?
It does not work with smtp server settings disabled.
If I enable smtp I can enter the smtp host but I have not got a username or password from  my ISP. Do I have to ask thathem for that? Is this setting (smtp server on) required for e-cards?

Spam filter of recipient is not the problem
"- If check web log and mail log in FTP or cPanel, what is say for error ?"
" - If check in cPanel for SPAM email add, see if match with email you type."
I have no option in the cpanel for mail logs or spam email add ..

**********************

Gallery Version: 1.7.4
Problem: Empfänger erhält keine e-cards

Frage: welche Settings werden benötigt?
SMTP Server ist im CP nicht aktiviert.
Sind diese Einstellungen aber aktiviert, geht es dennoch nicht. Vom ISP habe ich nur den SMTP Servernamen, aber keinen Usernamen oder Passwort erhalten. Brauche ich die? Müssen SMTP Einstellungen überhaupt aktiviert sein um e-card Versand zu ermöglichen?

Spam Filter biem Empfänger sind nicht das Problem.
"- If check web log and mail log in FTP or cPanel, what is say for error ?"
" - If check in cPanel for SPAM email add, see if match with email you type."
Ich habe im CP keine Option "mail log" oder "spam email add" gefunden ..
9  4images Modifications / Modifikationen / Mods & Plugins (Requests & Discussions) / Re: Batch edit/move categories? on: February 21, 2008, 02:11:13 PM
No way to do that? Pity. Sad
10  4images Modifications / Modifikationen / Mods & Plugins (Requests & Discussions) / Re: Batch edit/move categories? on: February 14, 2008, 11:27:48 AM
With all due respect but I searched.
And I know this mod, use it and it is NOT what I need.
I need to batch move categories.
11  4images Modifications / Modifikationen / Mods & Plugins (Requests & Discussions) / Batch edit/move categories? on: February 14, 2008, 01:02:51 AM
Is there a mod or way to move several categories in one go?

Example:
magazines
--- 2007
--- 2007-name1
--- 2007-name2
If I want to move both 2007-name categories into the category 2007 I now must edit each one.
No problem with 2 but tiresome with several categories.

Is there a way round like there is for images with the batch copy/move/edit/delete mod?

12  4images Issues / Ausgaben / Feedback & Suggestions / Re: 4images 1.7.5 - Feedback on: February 04, 2008, 08:22:07 PM
Ich mußte meine Gallery grad völlig neu aufsetzen und bin immer noch am Arbeiten .. bringt 175 irgendwelche Vorteile, sicherheitsmäßig? Sonst warte ich bis die Bugs in der Bugfix gefixt sind ... Smile

Ich seh's ja ein, wenn man für etwas nicht zahlt, sollte man auch nicht groß Ansprüche stellen, aber mich irritiert es schon ziemlich, daß seit je her einige wirklich nützliche Mods nicht eingebaut werden, sondern jedesmal eben als Mod angefügt werden müssen (als Beispiel die Batch edit/copy/move oder auch Permissions auch für Subcategories Funktionen). Bei jedem potentiellen Upgrade muß man dann überlegen, ob davon die Mods beeinflußt werden.




13  4images Modifications / Modifikationen / Templates & Styles (Releases & Support) / Re: Sites with 4images templates to download on: January 15, 2008, 09:06:36 PM
Darf ich mich anschließen und nach chique_black fragen?
Nova scheint es nicht mehr zu geben oder sind die umgezogen?
Geht chique_black mit 1.7.4?

I'd like to ask if chique_black is still available. Has Nova moved?
And does this template work with 1.7.4?

14  4images Issues / Ausgaben / Installation, Update & Configuration / Upgrading respect. new gallery question on: January 15, 2008, 08:51:47 PM
Over the years my gallery has got a bit messed up and I would like to clean up.

Would this work:

installing a clean version of the newest version of 4homepages in a new folder
uploading the backup of the gallery
uploading the actual images and thumbnails (does the backup create the directories too?)
installing a template and if necessary some mods

or alternatively:
renaming the data directory (images and thumbnails)
deleting everything else
uploading the newest version of 4images
removing the new data directory and renmaing the old one to data again
restoring the database from the backup

Since I have many directories and images, creating them manually would take ages.
My fear is that restoring the db wouldn't work or the folders will not be integrated etc. in which case I will have to start with a compelte new gallery and do everything again especially creating folders in the cp and uploading images, not to mention that keywords etc. will be lost as well.
15  4images Issues / Ausgaben / Discussion & Troubleshooting / Database backup created, download not possible on: January 15, 2008, 08:40:04 PM
I wanted to backup my database and download the backup.
Vs. is 1.7.4
The last time I did this was in December 2007, no problems.
Now, I could create the backup but when going on "download" there is the following error:
Quote  [Expand]
Fatal error: Call to undefined function: get_basefile() in /home/mydir/public_html/gallery/admin/backup.php on line 54

It is also not possible to delete earlier backups (same error message).

I have not installed any mods or did any changes.
I have had a problem with a hacker and uploaded the index.php again overwriting the hacked one. Could this be the reason for the problem?
Is there a way to fix the backup.php or how can I donwload the backup otherwise (no idea where it is stored)?


Pages: [1] 2 3 4 5 ... 7 » »»
Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.054 seconds with 18 queries.
Post your comments here